Hola!
Estoy tratando de conectar una base Oracle con una PostgreSQL, a traves
de Oracle Heterogeneous Service.
Las bases estan en 2 servers distintos. El server Oracle es un Linux
RHEL4, y la versión de Oracle es 10.2.0.4. El server Postgres es un
Linux RHEL5, y la versión de Postgres es 8.2.4. Instale (en el server
oracle) DG4ODBC que es el gateway de Oracle, UnixODBC que es el driver
manager... y todo lo que necesito ahora es instalar el driver
PostgreSQL. Baje de internet psqlodbc-08.04.0100... pero no puedo correr
el ejecutable "./configure" porque me dice que falta definir una
variable de environment ... "PG_CONFIG". Encontré el archivo pg_config
en el server PostgreSQL, pero quisiera saber si hay algún paquete que yo
pueda instalar en el server Oracle (que no sea la Base completa
PostgreSQL) para conseguir pg_config.

Muchas Gracias por su ayuda!
Daniela.

Search Discussions

  • Jose Luis Balle at Dec 14, 2009 at 6:51 pm
    Antes que nada nunca usé los ODBC en linux, pero, no creo que sea
    posible ya que pg_config devolvería valores importantes para poder
    compilar el driver ODBC como por ej. la ubicación de las librerias de
    la versión de postgres.
    Por otro lado, si dijeramos que compilas los ODBC en el linux que
    tiene postgres no se si funcionaría luego en una versión distinta de
    RHEL ...
    ¿cuál es el motivo de no instalar un postgres donde corres Oracle?


    El día 14 de diciembre de 2009 15:16, Daniela Mamede d'Almeida
    <dmamede@mecon.gov.ar> escribió:
    Las bases estan en 2 servers distintos. El server Oracle es un Linux RHEL4,
    y la versión de Oracle es 10.2.0.4. El server Postgres es un Linux RHEL5, y
    la versión de Postgres es 8.2.4. Instale (en el server oracle) DG4ODBC que
    es el gateway de Oracle, UnixODBC que es el driver manager... y todo lo que
    necesito ahora es instalar el driver PostgreSQL. Baje de internet
    psqlodbc-08.04.0100... pero no puedo correr el ejecutable "./configure"
    porque me dice que falta definir una variable de environment ...
    "PG_CONFIG". Encontré el archivo pg_config en el server PostgreSQL, pero
    quisiera saber si hay algún paquete que yo pueda instalar en el server
    Oracle (que no sea la Base completa PostgreSQL) para conseguir pg_config.


    --
    "Los derechos humanos deberían ser para las personas...."
  • Jose Luis Balle at Dec 14, 2009 at 7:02 pm
    ¿que sucedería si montas el raíz de postgres en el RHEL4 y apuntas el
    PG_CONFIG a esa ubicación?
    BINDIR = /usr/local/pgsql/bin
    DOCDIR = /usr/local/pgsql/share/doc
    HTMLDIR = /usr/local/pgsql/share/doc
    INCLUDEDIR = /usr/local/pgsql/include
    PKGINCLUDEDIR = /usr/local/pgsql/include
    INCLUDEDIR-SERVER = /usr/local/pgsql/include/server
    LIBDIR = /usr/local/pgsql/lib
    PKGLIBDIR = /usr/local/pgsql/lib
    LOCALEDIR = /usr/local/pgsql/share/locale
    MANDIR = /usr/local/pgsql/share/man
    SHAREDIR = /usr/local/pgsql/share
    SYSCONFDIR = /usr/local/pgsql/etc
    PGXS = /usr/local/pgsql/lib/pgxs/src/makefiles/pgxs.mk

    estos son todos datos relativos a la ubicación de pg_config...

    El día 14 de diciembre de 2009 15:50, Jose Luis Balle
    <joseluisballe@gmail.com> escribió:
    Antes que nada nunca usé los ODBC en linux, pero, no creo que sea
    posible ya que pg_config devolvería valores importantes para poder
    compilar el driver ODBC como por ej. la ubicación de las librerias de
    la versión de postgres.
    Por otro lado, si dijeramos que compilas los ODBC en el linux que
    tiene postgres no se si funcionaría luego en una versión distinta de
    RHEL ...
    ¿cuál es el motivo de no instalar un postgres donde corres Oracle?


    El día 14 de diciembre de 2009 15:16, Daniela Mamede d'Almeida
    <dmamede@mecon.gov.ar> escribió:
    Las bases estan en 2 servers distintos. El server Oracle es un Linux RHEL4,
    y la versión de Oracle es 10.2.0.4. El server Postgres es un Linux RHEL5, y
    la versión de Postgres es 8.2.4. Instale (en el server oracle) DG4ODBC que
    es el gateway de Oracle, UnixODBC que es el driver manager... y todo lo que
    necesito ahora es instalar el driver PostgreSQL. Baje de internet
    psqlodbc-08.04.0100... pero no puedo correr el ejecutable "./configure"
    porque me dice que falta definir una variable de environment ...
    "PG_CONFIG". Encontré el archivo pg_config en el server PostgreSQL, pero
    quisiera saber si hay algún paquete que yo pueda instalar en el server
    Oracle (que no sea la Base completa PostgreSQL) para conseguir pg_config.


    --
    "Los derechos humanos deberían ser para las personas...."


    --
    "Los derechos humanos deberían ser para las personas...."

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-es-ayuda @
categoriespostgresql
postedDec 14, '09 at 6:17p
activeDec 14, '09 at 7:02p
posts3
users2
websitepostgresql.org.es
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase