Hola como estan,

estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de
acceder la phppgadmin me sale el mensaje:
Su versión de PHP no tiene el soporte correcto de bases de datos.

ya descomente el php_pgsql.dll pero no pasa nada antes se solucionaba
adicionando una variable de entorno donde estaba el pgsql pero ahora ni con
eso, cuando habilito otras extensiones como gd me aparecen en el phpinfo
pero no el pgsql
tengo win xp sp3, apache 2.63 open_ssl,

cualquier ayuda sera bienvenida,
gracias de antemano,
saludos

Search Discussions

  • Jorge Sánchez Escobedo at Jun 23, 2009 at 12:55 am

    2009/6/22 Carlos Mendez <lucas1850@gmail.com>:
    Hola como estan,

    estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de
    acceder la phppgadmin me sale el mensaje:
    Su versión de PHP no tiene el soporte correcto de bases de datos.

    ya descomente el php_pgsql.dll pero no pasa nada antes se solucionaba
    adicionando una variable de entorno donde estaba el pgsql pero ahora ni con
    eso, cuando habilito otras extensiones como gd me aparecen en el phpinfo
    pero no el pgsql
    tengo win xp sp3, apache 2.63 open_ssl,

    cualquier ayuda sera bienvenida,
    gracias de antemano,
    saludos
    Revisa el log de apache, suponiendo que estas utilizando php desde apache.

    --
    "Linux is for people who hate Windows, BSD is for people who love UNIX".

    "Documentation is like sex: when it is good, it is very, very good;
    and when it is bad, it is better than nothing."
  • Sergio Gabriel Rodriguez at Jun 23, 2009 at 3:46 am
    2009/6/22 Espartano <espartano.mail@gmail.com>
    2009/6/22 Carlos Mendez <lucas1850@gmail.com>:
    Hola como estan,

    estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de
    acceder la phppgadmin me sale el mensaje:
    Su versión de PHP no tiene el soporte correcto de bases de datos.
    Fijate en el php.ini cual es tu directorio extension y luego mira si tenes
    ahi el php_pgsql.dll



    Sergio Gabriel Rodriguez
    http://www.3trex.com.ar
  • José Manuel Ruiz at Jun 23, 2009 at 7:15 am

    El 23 de junio de 2009 00:14, Carlos Mendez escribió:

    Hola como estan,

    estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de
    acceder la phppgadmin me sale el mensaje:
    Su versión de PHP no tiene el soporte correcto de bases de datos.

    ya descomente el php_pgsql.dll pero no pasa nada antes se solucionaba
    adicionando una variable de entorno donde estaba el pgsql pero ahora ni con
    eso, cuando habilito otras extensiones como gd me aparecen en el phpinfo
    pero no el pgsql
    tengo win xp sp3, apache 2.63 open_ssl,

    cualquier ayuda sera bienvenida,
    gracias de antemano,
    saludos
    Además de descomentar "php_pgsql.dll" observa que está accesible para que
    apache pueda cargar la librería.

    Si te da muchos problemas y quieres una solución rápida XAMPP tiene un
    módulo de PostgreSQL, yo lo he probado en Linux y funciona perfecto. No sé
    si en M$ Window$ XP $P3 funcionará.

    --
    "Comparte lo que sabes, aprende lo que no sepas"
    Todo por el conocimiento libre

    Linux user number 441469

    Me gustaría cambiar el mundo, pero no tengo el código fuente !

    Me limito a dejar mi granito de arena en http://blog.josemanuelruizbaena.com
  • Carlos Mendez at Jun 23, 2009 at 1:39 pm
    Hola que tal, gracias por responder,

    revisando el log de apache aparece:

    PHP Warning: PHP Startup: Unable to load dynamic library
    'C:/Servidor/PHP/ext/php_pgsql.dll' - El sistema operativo no puede ejecutar
    %1.\r\n in Unknown on line 0

    pero tengo el php_pgsql.dll en la carpeta ext,

    gracias de antemano por la ayuda,
    saludos

    El 23 de junio de 2009 03:15, José Manuel Ruiz <
    josemanuelruizbaena@gmail.com> escribió:

    El 23 de junio de 2009 00:14, Carlos Mendez <lucas1850@gmail.com>escribió:

    Hola como estan,
    estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de
    acceder la phppgadmin me sale el mensaje:
    Su versión de PHP no tiene el soporte correcto de bases de datos.

    ya descomente el php_pgsql.dll pero no pasa nada antes se solucionaba
    adicionando una variable de entorno donde estaba el pgsql pero ahora ni con
    eso, cuando habilito otras extensiones como gd me aparecen en el phpinfo
    pero no el pgsql
    tengo win xp sp3, apache 2.63 open_ssl,

    cualquier ayuda sera bienvenida,
    gracias de antemano,
    saludos
    Además de descomentar "php_pgsql.dll" observa que está accesible para que
    apache pueda cargar la librería.

    Si te da muchos problemas y quieres una solución rápida XAMPP tiene un
    módulo de PostgreSQL, yo lo he probado en Linux y funciona perfecto. No sé
    si en M$ Window$ XP $P3 funcionará.

    --
    "Comparte lo que sabes, aprende lo que no sepas"
    Todo por el conocimiento libre

    Linux user number 441469

    Me gustaría cambiar el mundo, pero no tengo el código fuente !

    Me limito a dejar mi granito de arena en
    http://blog.josemanuelruizbaena.com
  • Juan José (Pepe) at Jun 23, 2009 at 2:05 pm
    Mira si trabasjas sobre windows te recomiendo usar el Wamp Server es muy comodo a la hora de montar las extensiones, de todas meneras revisa en el PHP.INI si tienes bien puesta la ruta de las esxtenciones que no deberia darte problema, lo anterir que te recomente es lo mejor, o tra forma instala un linux y te quitas eso de arriba ya que las extenciones se instalan desde el repo y te ahorras ese problema. Partilularmente uso Ambos sistemas operatibos y wn windows Wamp server y el Linux Apache 2 y isntalo el Php con sus extenciones desde el Synaptic.



    saludos.





    Juan Jose Rosales

    UCI 2009
  • Edwin Quijada at Jun 23, 2009 at 3:16 pm
    revisa que tengas libpq en system32



    *-------------------------------------------------------*
    *-Edwin Quijada
    *-Developer DataBase
    *-JQ Microsistemas

    *-Soporte PostgreSQL

    *-www.jqmicrosistemas.com
    *-809-849-8087
    *-------------------------------------------------------*







    ________________________________
    Date: Tue, 23 Jun 2009 09:39:48 -0400
    Subject: Re: [pgsql-es-ayuda] php no se conecta con pgsql
    From: lucas1850@gmail.com
    To: josemanuelruizbaena@gmail.com
    CC: pgsql-es-ayuda@postgresql.org

    Hola que tal, gracias por responder,

    revisando el log de apache aparece:

    PHP Warning: PHP Startup: Unable to load dynamic library 'C:/Servidor/PHP/ext/php_pgsql.dll' - El sistema operativo no puede ejecutar %1.\r\n in Unknown on line 0


    pero tengo el php_pgsql.dll en la carpeta ext,

    gracias de antemano por la ayuda,
    saludos

    El 23 de junio de 2009 03:15, José Manuel Ruiz> escribió:



    El 23 de junio de 2009 00:14, Carlos Mendez> escribió:



    Hola como estan,

    estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de acceder la phppgadmin me sale el mensaje:
    Su versión de PHP no tiene el soporte correcto de bases de datos.

    ya descomente el php_pgsql.dll pero no pasa nada antes se solucionaba adicionando una variable de entorno donde estaba el pgsql pero ahora ni con eso, cuando habilito otras extensiones como gd me aparecen en el phpinfo pero no el pgsql



    tengo win xp sp3, apache 2.63 open_ssl,

    cualquier ayuda sera bienvenida,
    gracias de antemano,
    saludos



    Además de descomentar "php_pgsql.dll" observa que está accesible para que apache pueda cargar la librería.

    Si te da muchos problemas y quieres una solución rápida XAMPP tiene un módulo de PostgreSQL, yo lo he probado en Linux y funciona perfecto. No sé si en M$ Window$ XP $P3 funcionará.



    --
    "Comparte lo que sabes, aprende lo que no sepas"
    Todo por el conocimiento libre

    Linux user number 441469

    Me gustaría cambiar el mundo, pero no tengo el código fuente !

    Me limito a dejar mi granito de arena en http://blog.josemanuelruizbaena.com


    _________________________________________________________________
    See how Windows® connects the people, information, and fun that are part of your life
    http://clk.atdmt.com/MRT/go/119463819/direct/01/
  • Mariano Reingart at Jun 23, 2009 at 4:30 pm

    Hola:
    revisa que tengas libpq en system32
    PHP Warning: PHP Startup: Unable to load dynamic library
    'C:/Servidor/PHP/ext/php_pgsql.dll' - El sistema operativo no puede
    ejecutar %1.\r\n in Unknown on line 0

    pero tengo el php_pgsql.dll en la carpeta ext,
    Fijate con el Dependency Walker, sobre php_pgsql.dll y libpq que libreria
    te esta faltando:
    http://www.dependencywalker.com/

    Sds
    Mariano
  • PgRadar at Jun 23, 2009 at 5:00 pm
    La mejor solución que encontré hasta ahora a esa situación que da mucho
    malestar con el PHP es:
    incluir el archivo php_pgsql.dll en el directorio X:\PHP\

    X:\PHP\php_pgsql.dll


    La otra solución que te ofrece Edwin también es factible pero es más
    críptica desde mi punto de vista

    Saludos


    ----- Original Message -----
    From: "Edwin Quijada" <listas_quijada@hotmail.com>
    To: <lucas1850@gmail.com>; <josemanuelruizbaena@gmail.com>
    Cc: <pgsql-es-ayuda@postgresql.org>
    Sent: Tuesday, June 23, 2009 11:16 AM
    Subject: RE: [pgsql-es-ayuda] php no se conecta con pgsql

    revisa que tengas libpq en system32



    *-------------------------------------------------------*
    *-Edwin Quijada
    *-Developer DataBase
    *-JQ Microsistemas

    *-Soporte PostgreSQL

    *-www.jqmicrosistemas.com
    *-809-849-8087
    *-------------------------------------------------------*







    ________________________________
    Date: Tue, 23 Jun 2009 09:39:48 -0400
    Subject: Re: [pgsql-es-ayuda] php no se conecta con pgsql
    From: lucas1850@gmail.com
    To: josemanuelruizbaena@gmail.com
    CC: pgsql-es-ayuda@postgresql.org

    Hola que tal, gracias por responder,

    revisando el log de apache aparece:

    PHP Warning: PHP Startup: Unable to load dynamic library
    'C:/Servidor/PHP/ext/php_pgsql.dll' - El sistema operativo no puede
    ejecutar %1.\r\n in Unknown on line 0


    pero tengo el php_pgsql.dll en la carpeta ext,

    gracias de antemano por la ayuda,
    saludos

    El 23 de junio de 2009 03:15, José Manuel Ruiz> escribió:



    El 23 de junio de 2009 00:14, Carlos Mendez> escribió:



    Hola como estan,

    estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de
    acceder la phppgadmin me sale el mensaje:
    Su versión de PHP no tiene el soporte correcto de bases de datos.

    ya descomente el php_pgsql.dll pero no pasa nada antes se solucionaba
    adicionando una variable de entorno donde estaba el pgsql pero ahora ni
    con eso, cuando habilito otras extensiones como gd me aparecen en el
    phpinfo pero no el pgsql



    tengo win xp sp3, apache 2.63 open_ssl,

    cualquier ayuda sera bienvenida,
    gracias de antemano,
    saludos



    Además de descomentar "php_pgsql.dll" observa que está accesible para que
    apache pueda cargar la librería.

    Si te da muchos problemas y quieres una solución rápida XAMPP tiene un
    módulo de PostgreSQL, yo lo he probado en Linux y funciona perfecto. No
    sé si en M$ Window$ XP $P3 funcionará.



    --
    "Comparte lo que sabes, aprende lo que no sepas"
    Todo por el conocimiento libre

    Linux user number 441469

    Me gustaría cambiar el mundo, pero no tengo el código fuente !

    Me limito a dejar mi granito de arena en
    http://blog.josemanuelruizbaena.com


    _________________________________________________________________
    See how Windows® connects the people, information, and fun that are part
    of your life
    http://clk.atdmt.com/MRT/go/119463819/direct/01/--
    TIP 9: visita nuestro canal de IRC #postgresql-es en irc.freenode.net
  • Carlos Mendez at Jun 23, 2009 at 7:49 pm
    Gracias a todos por responder,

    si tengo el libpq.dll en system32,
    y ya puse tambien el php_pgsql en la carpeta PHP pero no sucede nada,
    tendria algo que ver que el apache sea el apache openssl, por otra parte no
    entiendo lo de poner el php_pgsql.dll en /PHP

    Gracias de antemano por la ayuda,
    saludos



    El 23 de junio de 2009 12:02, PgRadar <pgradar@radar.com.py> escribió:
    La mejor solución que encontré hasta ahora a esa situación que da mucho
    malestar con el PHP es:
    incluir el archivo php_pgsql.dll en el directorio X:\PHP\

    X:\PHP\php_pgsql.dll


    La otra solución que te ofrece Edwin también es factible pero es más
    críptica desde mi punto de vista

    Saludos


    ----- Original Message ----- From: "Edwin Quijada" <
    listas_quijada@hotmail.com>
    To: <lucas1850@gmail.com>; <josemanuelruizbaena@gmail.com>
    Cc: <pgsql-es-ayuda@postgresql.org>
    Sent: Tuesday, June 23, 2009 11:16 AM
    Subject: RE: [pgsql-es-ayuda] php no se conecta con pgsql


    revisa que tengas libpq en system32



    *-------------------------------------------------------*
    *-Edwin Quijada
    *-Developer DataBase
    *-JQ Microsistemas

    *-Soporte PostgreSQL

    *-www.jqmicrosistemas.com
    *-809-849-8087
    *-------------------------------------------------------*







    ________________________________
    Date: Tue, 23 Jun 2009 09:39:48 -0400
    Subject: Re: [pgsql-es-ayuda] php no se conecta con pgsql
    From: lucas1850@gmail.com
    To: josemanuelruizbaena@gmail.com
    CC: pgsql-es-ayuda@postgresql.org

    Hola que tal, gracias por responder,

    revisando el log de apache aparece:

    PHP Warning: PHP Startup: Unable to load dynamic library
    'C:/Servidor/PHP/ext/php_pgsql.dll' - El sistema operativo no puede ejecutar
    %1.\r\n in Unknown on line 0


    pero tengo el php_pgsql.dll en la carpeta ext,

    gracias de antemano por la ayuda,
    saludos

    El 23 de junio de 2009 03:15, José Manuel Ruiz> escribió:



    El 23 de junio de 2009 00:14, Carlos Mendez> escribió:



    Hola como estan,

    estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de
    acceder la phppgadmin me sale el mensaje:
    Su versión de PHP no tiene el soporte correcto de bases de datos.

    ya descomente el php_pgsql.dll pero no pasa nada antes se solucionaba
    adicionando una variable de entorno donde estaba el pgsql pero ahora ni con
    eso, cuando habilito otras extensiones como gd me aparecen en el phpinfo
    pero no el pgsql



    tengo win xp sp3, apache 2.63 open_ssl,

    cualquier ayuda sera bienvenida,
    gracias de antemano,
    saludos



    Además de descomentar "php_pgsql.dll" observa que está accesible para que
    apache pueda cargar la librería.

    Si te da muchos problemas y quieres una solución rápida XAMPP tiene un
    módulo de PostgreSQL, yo lo he probado en Linux y funciona perfecto. No sé
    si en M$ Window$ XP $P3 funcionará.



    --
    "Comparte lo que sabes, aprende lo que no sepas"
    Todo por el conocimiento libre

    Linux user number 441469

    Me gustaría cambiar el mundo, pero no tengo el código fuente !

    Me limito a dejar mi granito de arena en
    http://blog.josemanuelruizbaena.com




    _________________________________________________________________
    See how Windows® connects the people, information, and fun that are part
    of your life
    http://clk.atdmt.com/MRT/go/119463819/direct/01/--
    TIP 9: visita nuestro canal de IRC #postgresql-es en irc.freenode.net
  • Carlos Mendez at Jun 24, 2009 at 7:26 pm
    Hola como estan,

    me baje el apache no el open_ssl y el php 5.2.10 borre todo y empece de
    nuevo y funciono, segun lo que veo, tal vez este equivocado pero el apache
    open_ssl necesite otra configuracion no lo se pero si alguien puede dar
    ideas sobre esto seria excelente

    saludos.

    El 23 de junio de 2009 15:49, Carlos Mendez <lucas1850@gmail.com> escribió:
    Gracias a todos por responder,

    si tengo el libpq.dll en system32,
    y ya puse tambien el php_pgsql en la carpeta PHP pero no sucede nada,
    tendria algo que ver que el apache sea el apache openssl, por otra parte no
    entiendo lo de poner el php_pgsql.dll en /PHP

    Gracias de antemano por la ayuda,
    saludos



    El 23 de junio de 2009 12:02, PgRadar <pgradar@radar.com.py> escribió:

    La mejor solución que encontré hasta ahora a esa situación que da mucho
    malestar con el PHP es:
    incluir el archivo php_pgsql.dll en el directorio X:\PHP\

    X:\PHP\php_pgsql.dll


    La otra solución que te ofrece Edwin también es factible pero es más
    críptica desde mi punto de vista

    Saludos


    ----- Original Message ----- From: "Edwin Quijada" <
    listas_quijada@hotmail.com>
    To: <lucas1850@gmail.com>; <josemanuelruizbaena@gmail.com>
    Cc: <pgsql-es-ayuda@postgresql.org>
    Sent: Tuesday, June 23, 2009 11:16 AM
    Subject: RE: [pgsql-es-ayuda] php no se conecta con pgsql


    revisa que tengas libpq en system32



    *-------------------------------------------------------*
    *-Edwin Quijada
    *-Developer DataBase
    *-JQ Microsistemas

    *-Soporte PostgreSQL

    *-www.jqmicrosistemas.com
    *-809-849-8087
    *-------------------------------------------------------*







    ________________________________
    Date: Tue, 23 Jun 2009 09:39:48 -0400
    Subject: Re: [pgsql-es-ayuda] php no se conecta con pgsql
    From: lucas1850@gmail.com
    To: josemanuelruizbaena@gmail.com
    CC: pgsql-es-ayuda@postgresql.org

    Hola que tal, gracias por responder,

    revisando el log de apache aparece:

    PHP Warning: PHP Startup: Unable to load dynamic library
    'C:/Servidor/PHP/ext/php_pgsql.dll' - El sistema operativo no puede ejecutar
    %1.\r\n in Unknown on line 0


    pero tengo el php_pgsql.dll en la carpeta ext,

    gracias de antemano por la ayuda,
    saludos

    El 23 de junio de 2009 03:15, José Manuel Ruiz> escribió:



    El 23 de junio de 2009 00:14, Carlos Mendez> escribió:



    Hola como estan,

    estoy tratando de conectar php 5.2.9-2 y pgsql 8.3.7 pero al tratar de
    acceder la phppgadmin me sale el mensaje:
    Su versión de PHP no tiene el soporte correcto de bases de datos.

    ya descomente el php_pgsql.dll pero no pasa nada antes se solucionaba
    adicionando una variable de entorno donde estaba el pgsql pero ahora ni con
    eso, cuando habilito otras extensiones como gd me aparecen en el phpinfo
    pero no el pgsql



    tengo win xp sp3, apache 2.63 open_ssl,

    cualquier ayuda sera bienvenida,
    gracias de antemano,
    saludos



    Además de descomentar "php_pgsql.dll" observa que está accesible para
    que apache pueda cargar la librería.

    Si te da muchos problemas y quieres una solución rápida XAMPP tiene un
    módulo de PostgreSQL, yo lo he probado en Linux y funciona perfecto. No sé
    si en M$ Window$ XP $P3 funcionará.



    --
    "Comparte lo que sabes, aprende lo que no sepas"
    Todo por el conocimiento libre

    Linux user number 441469

    Me gustaría cambiar el mundo, pero no tengo el código fuente !

    Me limito a dejar mi granito de arena en
    http://blog.josemanuelruizbaena.com




    _________________________________________________________________
    See how Windows® connects the people, information, and fun that are part
    of your life
    http://clk.atdmt.com/MRT/go/119463819/direct/01/--
    TIP 9: visita nuestro canal de IRC #postgresql-es en irc.freenode.net

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-es-ayuda @
categoriespostgresql
postedJun 22, '09 at 10:14p
activeJun 24, '09 at 7:26p
posts11
users8
websitepostgresql.org.es
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase