The following bug has been logged online:

Bug reference: 5039
Logged by: Kamil Roman
Email address: kamil.lech.roman@gmail.com
PostgreSQL version: 8.3.7
Operating system: Windows XP
Description: 'i' flag i in regexp_replace ignored for polish letters
Details:

select regexp_replace('LUBŻKOĄŚĆĘŁŃÓ','[ośżźćęąłńó]',
'_','ig');

returns 'LUBŻK_ĄŚĆĘŁŃÓ' and it should return LUB_K_______

Search Discussions

  • Robert Haas at Oct 22, 2009 at 4:30 pm

    On Sat, Sep 5, 2009 at 5:42 AM, Kamil Roman wrote:
    The following bug has been logged online:

    Bug reference:      5039
    Logged by:          Kamil Roman
    Email address:      kamil.lech.roman@gmail.com
    PostgreSQL version: 8.3.7
    Operating system:   Windows XP
    Description:        'i' flag i in regexp_replace ignored for polish letters
    Details:

    select  regexp_replace('LUBŻKOĄŚĆĘŁŃÓ','[ośżźćęąłńó]',
    '_','ig');

    returns 'LUBŻK_ĄŚĆĘŁŃÓ' and it should return LUB_K_______
    I haven't seen a response to this. Anyone think this might be a bug?

    ...Robert
  • Tom Lane at Oct 22, 2009 at 6:39 pm

    Robert Haas writes:
    On Sat, Sep 5, 2009 at 5:42 AM, Kamil Roman wrote:
    Description:        'i' flag i in regexp_replace ignored for polish letters
    I haven't seen a response to this. Anyone think this might be a bug?
    If he's using a multibyte character set (UTF8 most likely) there is
    pretty much 0 hope of it working. The existing TODO entry for this
    links to
    http://archives.postgresql.org/pgsql-hackers/2008-12/msg00433.php

    regards, tom lane
  • Kamil Roman at Oct 23, 2009 at 8:14 am
    Hello,
    yes, I have been using UTF-8. Shouldn't this behaviour be at least
    documented in the postgresql documentation? I am aware that it is a bug, but
    if it is not likely to be fixed soon IMHO it should be documented somehow.

    Regards,
    Kamil Roman

    2009/10/22 Tom Lane <tgl@sss.pgh.pa.us>
    Robert Haas <robertmhaas@gmail.com> writes:
    On Sat, Sep 5, 2009 at 5:42 AM, Kamil Roman wrote:
    Description: 'i' flag i in regexp_replace ignored for polish
    letters
    I haven't seen a response to this. Anyone think this might be a bug?
    If he's using a multibyte character set (UTF8 most likely) there is
    pretty much 0 hope of it working. The existing TODO entry for this
    links to
    http://archives.postgresql.org/pgsql-hackers/2008-12/msg00433.php

    regards, tom lane

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-bugs @
categoriespostgresql
postedSep 5, '09 at 9:42a
activeOct 23, '09 at 8:14a
posts4
users3
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2021 Grokbase