FAQ
The following bug has been logged online:

Bug reference: 4612
Logged by: Mark Hayen
Email address: mark.hayen@atosorigin.com
PostgreSQL version: 8.3.5
Operating system: Ubuntu 8.10
Description: lc_numeric setting ignored
Details:

When setting the LC_NUMERIC to nl_NL.UTF-8 systemvariable at both the OS
level and the database itself (postgresql.conf), the database refuses to
accept a decimal comma.

psql output:

dimpact=# show lc_numeric;
lc_numeric
-------------
nl_NL.UTF-8
(1 row)

dimpact=# select totaalbedragaanslag from import.aanslag;
totaalbedragaanslag
---------------------
33.33
(1 row)

Search Discussions

  • Bruce Momjian at Jan 13, 2009 at 3:48 am
    LC_NUMERIC only controls formatting functions, not raw input; from the
    manual entry on lc_numeric:

    Sets the locale to use for formatting numbers, for example
    with the <function>to_char</function> family of
    functions. Acceptable values are system-dependent; see <xref
    linkend="locale"> for more information. If this variable is
    set to the empty string (which is the default) then the value
    is inherited from the execution environment of the server in a
    system-dependent way.


    ---------------------------------------------------------------------------

    Mark Hayen wrote:
    The following bug has been logged online:

    Bug reference: 4612
    Logged by: Mark Hayen
    Email address: mark.hayen@atosorigin.com
    PostgreSQL version: 8.3.5
    Operating system: Ubuntu 8.10
    Description: lc_numeric setting ignored
    Details:

    When setting the LC_NUMERIC to nl_NL.UTF-8 systemvariable at both the OS
    level and the database itself (postgresql.conf), the database refuses to
    accept a decimal comma.

    psql output:

    dimpact=# show lc_numeric;
    lc_numeric
    -------------
    nl_NL.UTF-8
    (1 row)

    dimpact=# select totaalbedragaanslag from import.aanslag;
    totaalbedragaanslag
    ---------------------
    33.33
    (1 row)

    --
    Sent via pgsql-bugs mailing list (pgsql-bugs@postgresql.org)
    To make changes to your subscription:
    http://www.postgresql.org/mailpref/pgsql-bugs
    --
    Bruce Momjian <bruce@momjian.us> http://momjian.us
    EnterpriseDB http://enterprisedb.com

    + If your life is a hard drive, Christ can be your backup. +
  • Mark Hayen at Jan 13, 2009 at 10:10 am
    He Bruce,

    Thank you for replying.
    Does this mean that there is no way to do a "\copy from" using CSV files
    containing decimals with
    a comma?

    Mark Hayen
  • Bruce Momjian at Jan 14, 2009 at 3:24 am

    Mark Hayen wrote:
    He Bruce,

    Thank you for replying.
    Does this mean that there is no way to do a "\copy from" using CSV files
    containing decimals with
    a comma?
    That is correct, sorry.

    --
    Bruce Momjian <bruce@momjian.us> http://momjian.us
    EnterpriseDB http://enterprisedb.com

    + If your life is a hard drive, Christ can be your backup. +

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-bugs @
categoriespostgresql
postedJan 12, '09 at 10:58p
activeJan 14, '09 at 3:24a
posts4
users2
websitepostgresql.org
irc#postgresql

2 users in discussion

Mark Hayen: 2 posts Bruce Momjian: 2 posts

People

Translate

site design / logo © 2021 Grokbase