Hi all,

sometimes i have a curios problem with my Zope.
Without any errors in any logs Zope could not authenticate himself with
postgres.
The error message is that there is a wrong password.
After a restart of Zope everything works fine until the eror occurs
again.

My sysop has traced the protcols before and after the error.
Zope sends some data and then a crypted password with the salt.
If the error is occured the password that Zope sends is crypted wrong.
After a restart of Zope the password is right crypted.

Could anybody help or explain me this problem, it is very important for
the further use of Zope
for our websites.

Thanks as

Search Discussions

  • Miguel Gonzalez at Dec 13, 2001 at 12:51 pm
    Dear all,

    I am accessing my Red Hat linux box through PuTTY and I am
    experiencing the following problem using the psql interface of
    PostgreSQL. For instance I cannot use the backspace key or I cannot
    access to the command history of PostgreSQL using the arrow keys like
    i could do in a terminal if I am working in the server. Does anyone
    knows the settings? I have been trying different ones, but I cannot
    figure out how to do it.

    Many thanks in advance

    Miguel
  • Miguel Gonzalez at Dec 13, 2001 at 3:53 pm
    Sorry for the missing info. The PuTTY Version is 0.51.


    Thursday, December 13, 2001, 2:13:54 PM, usted escribió:

    v> which verison of putty u installed?

    v> vasu
    v> ----- Original Message -----
    v> From: Miguel Gonzalez <iafmgc@unileon.es>
    v> To: <pgsql-admin@postgresql.org>
    v> Sent: Thursday, December 13, 2001 6:22 PM
    v> Subject: [ADMIN] Settings using PuTTy

    Dear all,

    I am accessing my Red Hat linux box through PuTTY and I am
    experiencing the following problem using the psql interface of
    PostgreSQL. For instance I cannot use the backspace key or I cannot
    access to the command history of PostgreSQL using the arrow keys like
    i could do in a terminal if I am working in the server. Does anyone
    knows the settings? I have been trying different ones, but I cannot
    figure out how to do it.

    Many thanks in advance

    Miguel


    ---------------------------(end of broadcast)---------------------------
    TIP 6: Have you searched our list archives?

    http://archives.postgresql.org


    --
    Saludos,
    Miguel mailto:iafmgc@unileon.es
  • Lamar Owen at Dec 13, 2001 at 5:03 pm

    On Thursday 13 December 2001 07:52 am, Miguel Gonzalez wrote:
    I am accessing my Red Hat linux box through PuTTY and I am
    experiencing the following problem using the psql interface of
    PostgreSQL. For instance I cannot use the backspace key or I cannot
    access to the command history of PostgreSQL using the arrow keys like
    i could do in a terminal if I am working in the server. Does anyone
    knows the settings? I have been trying different ones, but I cannot
    figure out how to do it.
    Does the command history and backspace properly work for a local xterm? I
    ask that because PuTTY (which I use regularly) emulates an xterm, not a
    straight tty.

    If a local xterm works but PuTTY doesn't, check your emulator settings in
    PuTTY itself, to see what it's trying to send with backspace. I have used
    PuTTY to access psql with backspace and history working properly on my RedHat
    PostgreSQL box a number of times.

    However, there was a problem with the version of readline used at one point
    in time -- you might be running up against this buglet.
    --
    Lamar Owen
    WGCR Internet Radio
    1 Peter 4:11
  • Miguel Gonzalez at Dec 13, 2001 at 5:14 pm
    Hola Lamar,

    Thursday, December 13, 2001, 6:02:15 PM, usted escribió:

    yes the command history and backspace works perfectly in the local
    terminal (text terminal i dont have X)

    how can I check the emulator settings? Which ones should I have?

    Thanks for your help

    Miguel

    LO> On Thursday 13 December 2001 07:52 am, Miguel Gonzalez wrote:
    I am accessing my Red Hat linux box through PuTTY and I am
    experiencing the following problem using the psql interface of
    PostgreSQL. For instance I cannot use the backspace key or I cannot
    access to the command history of PostgreSQL using the arrow keys like
    i could do in a terminal if I am working in the server. Does anyone
    knows the settings? I have been trying different ones, but I cannot
    figure out how to do it.
    LO> Does the command history and backspace properly work for a local xterm? I
    LO> ask that because PuTTY (which I use regularly) emulates an xterm, not a
    LO> straight tty.

    LO> If a local xterm works but PuTTY doesn't, check your emulator settings in
    LO> PuTTY itself, to see what it's trying to send with backspace. I have used
    LO> PuTTY to access psql with backspace and history working properly on my RedHat
    LO> PostgreSQL box a number of times.

    LO> However, there was a problem with the version of readline used at one point
    LO> in time -- you might be running up against this buglet.



    --
    Saludos,
    Miguel mailto:iafmgc@unileon.es
  • Lamar Owen at Dec 13, 2001 at 10:51 pm

    On Thursday 13 December 2001 12:14 pm, Miguel Gonzalez wrote:
    yes the command history and backspace works perfectly in the local
    terminal (text terminal i dont have X)
    how can I check the emulator settings? Which ones should I have?
    I'll have to reboot into windoze to check -- but I _did_ a few hours ago
    (while booted into windoze to run a network virus scan) check to see if my
    PuTTY installation would work with my 7.2b3 RPM installation on RedHat 7.1.
    History and backspace worked perfectly.
    --
    Lamar Owen
    WGCR Internet Radio
    1 Peter 4:11
  • Bruce Momjian at Dec 14, 2001 at 12:38 am
    My only guess is that you are using 8-bit arrow keys. Not sure how to
    check that.


    ---------------------------------------------------------------------------
    On Thursday 13 December 2001 12:14 pm, Miguel Gonzalez wrote:
    yes the command history and backspace works perfectly in the local
    terminal (text terminal i dont have X)
    how can I check the emulator settings? Which ones should I have?
    I'll have to reboot into windoze to check -- but I _did_ a few hours ago
    (while booted into windoze to run a network virus scan) check to see if my
    PuTTY installation would work with my 7.2b3 RPM installation on RedHat 7.1.
    History and backspace worked perfectly.
    --
    Lamar Owen
    WGCR Internet Radio
    1 Peter 4:11

    ---------------------------(end of broadcast)---------------------------
    TIP 2: you can get off all lists at once with the unregister command
    (send "unregister YourEmailAddressHere" to majordomo@postgresql.org)
    --
    Bruce Momjian | http://candle.pha.pa.us
    pgman@candle.pha.pa.us | (610) 853-3000
    + If your life is a hard drive, | 830 Blythe Avenue
    + Christ can be your backup. | Drexel Hill, Pennsylvania 19026
  • Boban Acimovic at Dec 13, 2001 at 5:28 pm
    BTW, I am using OpenSSH server (Solaris 6, 7, 8) and client (Linux - KDE
    - konsole) and I have the same problem with psql. So, this is not
    specific to PuTTy. This must be possible to fix completely with TTY
    settings, but I never had time to check this further out. Besides, I am
    not using psql so often.

    I didn't figure out how to get backspace and arrow keys to work
    correctly, but I can help you to be able to delete at least.

    In .bashrc (this file is in the home directory of your user on remote
    machine) add this line:

    stty erase ^?

    This will make Ctrl-h to behave just like backspace. This is old UNIX
    delete key used by vi as well. The right solution is to fix psql to
    behave just like other modern UNIX console software.

    Regards,
    Boban Acimovic
    www.mbl.is

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppgsql-admin @
categoriespostgresql
postedNov 23, '01 at 9:54a
activeDec 14, '01 at 12:38a
posts8
users5
websitepostgresql.org
irc#postgresql

People

Translate

site design / logo © 2022 Grokbase