Grokbase Groups Pig user August 2011
FAQ
Hello,
I found pig-0.8.1 included classes of Hbase-0.90.0.
My question is:
1. If I replace Hbase-0.90.3 with Hbase-0.90.0, could pig-0.8.1 work normally?
2. why Hbase class files are included in pig-0.8.1 jar ball?
Thank you.

Search Discussions

  • Bill Graham at Aug 7, 2011 at 4:12 pm
    Yes, you can a different version of HBase provided it's >= 0.89.

    2011/8/7 lulynn_2008 <lulynn_2008@163.com>
    Hello,
    I found pig-0.8.1 included classes of Hbase-0.90.0.
    My question is:
    1. If I replace Hbase-0.90.3 with Hbase-0.90.0, could pig-0.8.1 work
    normally?
    2. why Hbase class files are included in pig-0.8.1 jar ball?
    Thank you.
  • Dmitriy Ryaboy at Aug 7, 2011 at 9:55 pm
    To answer question 2: because people got extremely confused and upset when
    we told them they have to actually put hbase on their classpath to talk to
    hbase.... They want it to work out of the box.

    On Sun, Aug 7, 2011 at 9:11 AM, Bill Graham wrote:

    Yes, you can a different version of HBase provided it's >= 0.89.

    2011/8/7 lulynn_2008 <lulynn_2008@163.com>
    Hello,
    I found pig-0.8.1 included classes of Hbase-0.90.0.
    My question is:
    1. If I replace Hbase-0.90.3 with Hbase-0.90.0, could pig-0.8.1 work
    normally?
    2. why Hbase class files are included in pig-0.8.1 jar ball?
    Thank you.
  • Lulynn_2008 at Aug 8, 2011 at 2:08 am
    Dmitriy Ryaboy,
    Thank you for your quick response.



    At 2011-08-08 05:54:53,"Dmitriy Ryaboy" wrote:
    To answer question 2: because people got extremely confused and upset when
    we told them they have to actually put hbase on their classpath to talk to
    hbase.... They want it to work out of the box.

    On Sun, Aug 7, 2011 at 9:11 AM, Bill Graham wrote:

    Yes, you can a different version of HBase provided it's >= 0.89.

    2011/8/7 lulynn_2008 <lulynn_2008@163.com>
    Hello,
    I found pig-0.8.1 included classes of Hbase-0.90.0.
    My question is:
    1. If I replace Hbase-0.90.3 with Hbase-0.90.0, could pig-0.8.1 work
    normally?
    2. why Hbase class files are included in pig-0.8.1 jar ball?
    Thank you.
  • Lulynn_2008 at Aug 8, 2011 at 2:07 am
    Bill Graham,
    Thank you for your quick response.



    At 2011-08-08 00:11:54,"Bill Graham" wrote:
    Yes, you can a different version of HBase provided it's >= 0.89.

    2011/8/7 lulynn_2008 <lulynn_2008@163.com>
    Hello,
    I found pig-0.8.1 included classes of Hbase-0.90.0.
    My question is:
    1. If I replace Hbase-0.90.3 with Hbase-0.90.0, could pig-0.8.1 work
    normally?
    2. why Hbase class files are included in pig-0.8.1 jar ball?
    Thank you.
  • Nick Dimiduk at Jun 12, 2012 at 1:22 am
    1. The HBase client from any 0.90.x should be compatible across all 0.90.x
    versions.
    2. No idea.
    On Sun, Aug 7, 2011 at 8:56 AM, lulynn_2008 wrote:

    Hello,
    I found pig-0.8.1 included classes of Hbase-0.90.0.
    My question is:
    1. If I replace Hbase-0.90.3 with Hbase-0.90.0, could pig-0.8.1 work
    normally?
    2. why Hbase class files are included in pig-0.8.1 jar ball?
    Thank you.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categoriespig, hadoop
postedAug 7, '11 at 3:58p
activeJun 12, '12 at 1:22a
posts6
users4
websitepig.apache.org

People

Translate

site design / logo © 2022 Grokbase