Grokbase Groups Pig user July 2011
FAQ
Does pig work with 0.20.203? I'm getting this error when run pig and cant figure out why:

ERROR 2999: Unexpected internal error. Failed to create DataStorage

Will it work if I use version 0.9.0?

--
Ross Nordeen
Computer Networking And Systems Administration
Michigan Technological University
http://www.linkedin.com/in/rjnordee

Search Discussions

  • Alan Gates at Jul 15, 2011 at 9:53 pm
    The issue is that Pig is packaged with Hadoop 0.20.2 client, which won't work with 0.20.203. But if you take that jar out and replace it with 0.20.203 client, it works.

    Take a look at https://issues.apache.org/jira/browse/PIG-2148 for an idea of how to change your pig script to use that jar instead. You will need to change your PIG_CLASSPATH to contain all of the jars that Pig normally gets from the fatjar. There are about ten of them.

    Alan.
    On Jul 15, 2011, at 2:34 PM, Ross Nordeen wrote:

    Does pig work with 0.20.203? I'm getting this error when run pig and cant figure out why:

    ERROR 2999: Unexpected internal error. Failed to create DataStorage

    Will it work if I use version 0.9.0?

    --
    Ross Nordeen
    Computer Networking And Systems Administration
    Michigan Technological University
    http://www.linkedin.com/in/rjnordee

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categoriespig, hadoop
postedJul 15, '11 at 9:35p
activeJul 15, '11 at 9:53p
posts2
users2
websitepig.apache.org

2 users in discussion

Ross Nordeen: 1 post Alan Gates: 1 post

People

Translate

site design / logo © 2021 Grokbase