Grokbase Groups Pig user March 2011
FAQ
Hello there,

I want to write a UDF in java so I tried to add pig to eclipse but I got
always thousands of errors most of them are like this one

*The declared package "org.apache.pig.piggybank.test.evaluation" does not
match the expected package
"contrib.piggybank.java.src.test.java.org.apache.pig.piggybank.test.evaluation"
*

I followed the steps explained here

http://wiki.apache.org/pig/Eclipse_Environment

But I got alwayse the same errors

waiting for your help please

Regards

Baraa

Search Discussions

  • Daniel Dai at Mar 22, 2011 at 5:39 pm
    If all you need is to write a UDF, you only need to add pig.jar into
    library of your eclipse project. The wiki page is to set up the
    environment to develop Pig core code.

    Daniel
    On 03/22/2011 06:51 AM, Baraa Mohamad wrote:
    Hello there,

    I want to write a UDF in java so I tried to add pig to eclipse but I got
    always thousands of errors most of them are like this one

    *The declared package "org.apache.pig.piggybank.test.evaluation" does not
    match the expected package
    "contrib.piggybank.java.src.test.java.org.apache.pig.piggybank.test.evaluation"
    *

    I followed the steps explained here

    http://wiki.apache.org/pig/Eclipse_Environment

    But I got alwayse the same errors

    waiting for your help please

    Regards

    Baraa
  • Baraa Mohamad at Mar 22, 2011 at 6:24 pm
    thanks I'll try that :) but maybe I'll need to develope Pig core code :)

    Best regards

    Baraa
    On Tue, Mar 22, 2011 at 6:38 PM, Daniel Dai wrote:

    If all you need is to write a UDF, you only need to add pig.jar into
    library of your eclipse project. The wiki page is to set up the environment
    to develop Pig core code.

    Daniel

    On 03/22/2011 06:51 AM, Baraa Mohamad wrote:

    Hello there,

    I want to write a UDF in java so I tried to add pig to eclipse but I got
    always thousands of errors most of them are like this one

    *The declared package "org.apache.pig.piggybank.test.evaluation" does not
    match the expected package

    "contrib.piggybank.java.src.test.java.org.apache.pig.piggybank.test.evaluation"
    *

    I followed the steps explained here

    http://wiki.apache.org/pig/Eclipse_Environment

    But I got alwayse the same errors

    waiting for your help please

    Regards

    Baraa

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categoriespig, hadoop
postedMar 22, '11 at 1:52p
activeMar 22, '11 at 6:24p
posts3
users2
websitepig.apache.org

2 users in discussion

Baraa Mohamad: 2 posts Daniel Dai: 1 post

People

Translate

site design / logo © 2021 Grokbase