FAQ
I am developing a new UDF for loading Json data. It differs from those
currently available because it tries to construct the supplied nested maps
and arrays as Pig data structures rather than a single flat map.

Anyway, I am sometimes getting this error which I don't understand.

2011-02-05 13:04:46,397 [main] INFO
org.apache.pig.backend.hadoop.executionengine.HExecutionEngine -
pig.usenewlogicalplan is set to true. New logical plan will be used.
2011-02-05 13:04:46,426 [main] ERROR org.apache.pig.tools.grunt.Grunt -
ERROR 2042: Error in new logical plan. Try -Dpig.usenewlogicalplan=false.

When I get it I can't really be sure if it is a problem in my UDF, in my
script, or a bug in Pig itself.

Any ideas for what I can do to learn more and perhaps prepare a sensible bug
report...

Incidentally if I put " -Dpig.usenewlogicalplan=false " on the command line
my script then works fine. I just don't understand why it is failing, and
what to do about it. Is the "new logical plan" beta code pushed into
production?

Alex

Search Discussions

  • Daniel Dai at Feb 8, 2011 at 6:53 am
    There could be a bug in new logical plan. First, try to check out from
    the latest Pig 0.8 from
    https://svn.apache.org/repos/asf/pig/branches/branch-0.8, see if the
    issue go away. If not, please report the bug by creating a Jira.

    Daniel

    Alex McLintock wrote:
    I am developing a new UDF for loading Json data. It differs from those
    currently available because it tries to construct the supplied nested maps
    and arrays as Pig data structures rather than a single flat map.

    Anyway, I am sometimes getting this error which I don't understand.

    2011-02-05 13:04:46,397 [main] INFO
    org.apache.pig.backend.hadoop.executionengine.HExecutionEngine -
    pig.usenewlogicalplan is set to true. New logical plan will be used.
    2011-02-05 13:04:46,426 [main] ERROR org.apache.pig.tools.grunt.Grunt -
    ERROR 2042: Error in new logical plan. Try -Dpig.usenewlogicalplan=false.

    When I get it I can't really be sure if it is a problem in my UDF, in my
    script, or a bug in Pig itself.

    Any ideas for what I can do to learn more and perhaps prepare a sensible bug
    report...

    Incidentally if I put " -Dpig.usenewlogicalplan=false " on the command line
    my script then works fine. I just don't understand why it is failing, and
    what to do about it. Is the "new logical plan" beta code pushed into
    production?

    Alex

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupuser @
categoriespig, hadoop
postedFeb 5, '11 at 1:13p
activeFeb 8, '11 at 6:53a
posts2
users2
websitepig.apache.org

2 users in discussion

Daniel Dai: 1 post Alex McLintock: 1 post

People

Translate

site design / logo © 2021 Grokbase