Grokbase Groups Pig dev January 2013
FAQ
[ https://issues.apache.org/jira/browse/PIG-3031?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Cheolsoo Park updated PIG-3031:
-------------------------------

Assignee: Zhijie Shen

I will commit the patch after running tests.
Update Pig to use a newer version of joda-time
----------------------------------------------

Key: PIG-3031
URL: https://issues.apache.org/jira/browse/PIG-3031
Project: Pig
Issue Type: Bug
Reporter: Jonathan Coveney
Assignee: Zhijie Shen
Fix For: 0.12

Attachments: PIG-3031.patch


The current version is 1.6, which is quite old (~4 years at this point). Is there any reason not to bring us up to a newer version? I tried to compile the 1.6 source and it didn't work because dependencies are outdated, and so on. Also, the interfaces have matured.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Search Discussions

  • Jonathan Coveney (JIRA) at Jan 22, 2013 at 6:52 pm
    [ https://issues.apache.org/jira/browse/PIG-3031?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13559871#comment-13559871 ]

    Jonathan Coveney commented on PIG-3031:
    ---------------------------------------

    Sounds good, thanks y'all.
    Update Pig to use a newer version of joda-time
    ----------------------------------------------

    Key: PIG-3031
    URL: https://issues.apache.org/jira/browse/PIG-3031
    Project: Pig
    Issue Type: Bug
    Reporter: Jonathan Coveney
    Assignee: Zhijie Shen
    Fix For: 0.12

    Attachments: PIG-3031.patch


    The current version is 1.6, which is quite old (~4 years at this point). Is there any reason not to bring us up to a newer version? I tried to compile the 1.6 source and it didn't work because dependencies are outdated, and so on. Also, the interfaces have matured.
    --
    This message is automatically generated by JIRA.
    If you think it was sent incorrectly, please contact your JIRA administrators
    For more information on JIRA, see: http://www.atlassian.com/software/jira
  • Cheolsoo Park (JIRA) at Jan 23, 2013 at 7:59 pm
    [ https://issues.apache.org/jira/browse/PIG-3031?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13561028#comment-13561028 ]

    Cheolsoo Park commented on PIG-3031:
    ------------------------------------

    Unfortunately, there is a failure:
    {code}
    Testcase: testConversionBetweenDateTimeAndString took 0.041 sec
    Caused an ERROR
    The datetime zone id 'asia/singapore' is not recognised
    java.lang.IllegalArgumentException: The datetime zone id 'asia/singapore' is not recognised
    at org.joda.time.DateTimeZone.forID(DateTimeZone.java:223)
    at org.apache.pig.builtin.ToDate3ARGS.exec(ToDate3ARGS.java:21)
    at org.apache.pig.test.TestBuiltin.testConversionBetweenDateTimeAndString(TestBuiltin.java:408)
    {code}
    Update Pig to use a newer version of joda-time
    ----------------------------------------------

    Key: PIG-3031
    URL: https://issues.apache.org/jira/browse/PIG-3031
    Project: Pig
    Issue Type: Bug
    Reporter: Jonathan Coveney
    Assignee: Zhijie Shen
    Fix For: 0.12

    Attachments: PIG-3031.patch


    The current version is 1.6, which is quite old (~4 years at this point). Is there any reason not to bring us up to a newer version? I tried to compile the 1.6 source and it didn't work because dependencies are outdated, and so on. Also, the interfaces have matured.
    --
    This message is automatically generated by JIRA.
    If you think it was sent incorrectly, please contact your JIRA administrators
    For more information on JIRA, see: http://www.atlassian.com/software/jira
  • Zhijie Shen (JIRA) at Jan 23, 2013 at 8:07 pm
    [ https://issues.apache.org/jira/browse/PIG-3031?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13561043#comment-13561043 ]

    Zhijie Shen commented on PIG-3031:
    ----------------------------------

    Hi Cheolsoo,

    Which version are you going to upgrade to? 2.1? I'd like to investigate the problem.

    Thanks,
    Zhijie
    Update Pig to use a newer version of joda-time
    ----------------------------------------------

    Key: PIG-3031
    URL: https://issues.apache.org/jira/browse/PIG-3031
    Project: Pig
    Issue Type: Bug
    Reporter: Jonathan Coveney
    Assignee: Zhijie Shen
    Fix For: 0.12

    Attachments: PIG-3031.patch


    The current version is 1.6, which is quite old (~4 years at this point). Is there any reason not to bring us up to a newer version? I tried to compile the 1.6 source and it didn't work because dependencies are outdated, and so on. Also, the interfaces have matured.
    --
    This message is automatically generated by JIRA.
    If you think it was sent incorrectly, please contact your JIRA administrators
    For more information on JIRA, see: http://www.atlassian.com/software/jira
  • Cheolsoo Park (JIRA) at Jan 23, 2013 at 8:09 pm
    [ https://issues.apache.org/jira/browse/PIG-3031?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13561045#comment-13561045 ]

    Cheolsoo Park commented on PIG-3031:
    ------------------------------------

    Yes, I used the patch that you provided on this jira. Thanks for taking a look at it.
    Update Pig to use a newer version of joda-time
    ----------------------------------------------

    Key: PIG-3031
    URL: https://issues.apache.org/jira/browse/PIG-3031
    Project: Pig
    Issue Type: Bug
    Reporter: Jonathan Coveney
    Assignee: Zhijie Shen
    Fix For: 0.12

    Attachments: PIG-3031.patch


    The current version is 1.6, which is quite old (~4 years at this point). Is there any reason not to bring us up to a newer version? I tried to compile the 1.6 source and it didn't work because dependencies are outdated, and so on. Also, the interfaces have matured.
    --
    This message is automatically generated by JIRA.
    If you think it was sent incorrectly, please contact your JIRA administrators
    For more information on JIRA, see: http://www.atlassian.com/software/jira
  • Zhijie Shen (JIRA) at Jan 24, 2013 at 6:41 am
    [ https://issues.apache.org/jira/browse/PIG-3031?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

    Zhijie Shen updated PIG-3031:
    -----------------------------

    Attachment: PIG-3031_1.patch

    Hi Cheolsoo,

    The problem is that DateTimeZone#forID becomes case-insensitively when receiving the timezone ID. See the following url:

    http://joda-time.sourceforge.net/upgradeto200.html

    And please try the newest patch.

    In addition, I think it should be good to include the following link:

    http://joda-time.sourceforge.net/timezones.html

    somewhere in the Pig manual, such that users can know what timezone IDs they can input.

    Thanks,
    Zhijie


    Update Pig to use a newer version of joda-time
    ----------------------------------------------

    Key: PIG-3031
    URL: https://issues.apache.org/jira/browse/PIG-3031
    Project: Pig
    Issue Type: Bug
    Reporter: Jonathan Coveney
    Assignee: Zhijie Shen
    Fix For: 0.12

    Attachments: PIG-3031_1.patch, PIG-3031.patch


    The current version is 1.6, which is quite old (~4 years at this point). Is there any reason not to bring us up to a newer version? I tried to compile the 1.6 source and it didn't work because dependencies are outdated, and so on. Also, the interfaces have matured.
    --
    This message is automatically generated by JIRA.
    If you think it was sent incorrectly, please contact your JIRA administrators
    For more information on JIRA, see: http://www.atlassian.com/software/jira
  • Cheolsoo Park (JIRA) at Jan 24, 2013 at 8:03 pm
    [ https://issues.apache.org/jira/browse/PIG-3031?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

    Cheolsoo Park updated PIG-3031:
    -------------------------------

    Attachment: PIG-3031_2.patch

    +1.

    Thank you for the explanation Zhijie! The test passes for me too.

    I added that link to the doc for the ToDate built-in function.
    {code}
    Please see <a href="http://joda-time.sourceforge.net/timezones.html">the Joda-Time doc</a> for available timezone IDs.
    {code}
    Update Pig to use a newer version of joda-time
    ----------------------------------------------

    Key: PIG-3031
    URL: https://issues.apache.org/jira/browse/PIG-3031
    Project: Pig
    Issue Type: Bug
    Reporter: Jonathan Coveney
    Assignee: Zhijie Shen
    Fix For: 0.12

    Attachments: PIG-3031_1.patch, PIG-3031_2.patch, PIG-3031.patch


    The current version is 1.6, which is quite old (~4 years at this point). Is there any reason not to bring us up to a newer version? I tried to compile the 1.6 source and it didn't work because dependencies are outdated, and so on. Also, the interfaces have matured.
    --
    This message is automatically generated by JIRA.
    If you think it was sent incorrectly, please contact your JIRA administrators
    For more information on JIRA, see: http://www.atlassian.com/software/jira
  • Cheolsoo Park (JIRA) at Jan 25, 2013 at 12:13 am
    [ https://issues.apache.org/jira/browse/PIG-3031?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

    Cheolsoo Park resolved PIG-3031.
    --------------------------------

    Resolution: Fixed

    Committed to trunk. Thanks Zhijie!
    Update Pig to use a newer version of joda-time
    ----------------------------------------------

    Key: PIG-3031
    URL: https://issues.apache.org/jira/browse/PIG-3031
    Project: Pig
    Issue Type: Bug
    Reporter: Jonathan Coveney
    Assignee: Zhijie Shen
    Fix For: 0.12

    Attachments: PIG-3031_1.patch, PIG-3031_2.patch, PIG-3031.patch


    The current version is 1.6, which is quite old (~4 years at this point). Is there any reason not to bring us up to a newer version? I tried to compile the 1.6 source and it didn't work because dependencies are outdated, and so on. Also, the interfaces have matured.
    --
    This message is automatically generated by JIRA.
    If you think it was sent incorrectly, please contact your JIRA administrators
    For more information on JIRA, see: http://www.atlassian.com/software/jira

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categoriespig, hadoop
postedJan 20, '13 at 8:18p
activeJan 25, '13 at 12:13a
posts8
users1
websitepig.apache.org

1 user in discussion

Cheolsoo Park (JIRA): 8 posts

People

Translate

site design / logo © 2021 Grokbase