Grokbase Groups Pig dev May 2010
FAQ
Hi everyone, does anybody know which JLine version I should use? I tried to
use the version jline-0_9_5 and I get an error while I tried to compile it
using ant
I also tried using Eclipse but it says that my jline library doesn't have a
methos setDefaultPrompt.
Thanks in advance.

Renato M.

[echo] *** Building Main Sources ***
[echo] *** To compile with all warnings enabled, supply
-Dall.warnings=1 on command line ***
[echo] *** If all.warnings property is supplied,
compile-sources-all-warnings target will be executed ***
[echo] *** Else, compile-sources (which only warns about deprecations)
target will be executed ***

compile-sources:
[javac] Compiling 601 source files to
/home/rmogrovejo/workspace/pig-0.7.0/build/classes
[javac]
/home/rmogrovejo/workspace/pig-0.7.0/src/org/apache/pig/Main.java:397:
cannot find symbol
[javac] symbol : method setDefaultPrompt(java.lang.String)
[javac] location: class jline.ConsoleReader
[javac] reader.setDefaultPrompt("grunt> ");
[javac] ^
[javac]
/home/rmogrovejo/workspace/pig-0.7.0/src/org/apache/pig/tools/grunt/GruntParser.java:213:
cannot find symbol
[javac] symbol : method setDefaultPrompt(java.lang.String)
[javac] location: class jline.ConsoleReader
[javac] mConsoleReader.setDefaultPrompt("grunt> ");
[javac] ^
[javac]
/home/rmogrovejo/workspace/pig-0.7.0/src-gen/org/apache/pig/tools/pigscript/parser/PigScriptParserTokenManager.java:28:
cannot find symbol
[javac] symbol : method setDefaultPrompt(java.lang.String)
[javac] location: class jline.ConsoleReader
[javac] consoleReader.setDefaultPrompt(">> ");
[javac] ^
[javac] Note: Some input files use or override a deprecated API.
[javac] Note: Recompile with -Xlint:deprecation for details.
[javac] Note: Some input files use unchecked or unsafe operations.
[javac] Note: Recompile with -Xlint:unchecked for details.
[javac] 3 errors

Search Discussions

  • Renato Marroquín Mogrovejo at May 24, 2010 at 2:50 am
    Hi everyone, I fixed using this version of the JLine library --->
    jline-0.9.94
    I dunno why I downloaded a previous one, but I would like know which the
    actual used version is.
    Thanks again.

    Renato M.
  • Jeff Zhang at May 24, 2010 at 5:05 am
    After you run "ant jar", the jline 0.94 will be in build/ivy/lib/Pig
    You don't need to download jline by yourself.



    On Mon, May 24, 2010 at 10:49 AM, Renato Marroquín Mogrovejo
    wrote:
    Hi everyone, I fixed using this version of the JLine library --->
    jline-0.9.94
    I dunno why I downloaded a previous one, but I would like know which the
    actual used version is.
    Thanks again.

    Renato M.


    --
    Best Regards

    Jeff Zhang
  • Renato Marroquín Mogrovejo at May 24, 2010 at 5:11 am
    Thanks Jeff, do I need to do this? I mean I downloaded it and put it on my
    jvm/lib/ext, then I run "ant" and it worked fine :)
    Hey do you know if we can run PIG in mapreduce mode inside eclipse? I
    haven't been able to even though I have my env variables set, and I
    configured the run properties in the IDE. Thanks again.

    Renato M.

    2010/5/24 Jeff Zhang <zjffdu@gmail.com>
    After you run "ant jar", the jline 0.94 will be in build/ivy/lib/Pig
    You don't need to download jline by yourself.



    On Mon, May 24, 2010 at 10:49 AM, Renato Marroquín Mogrovejo
    wrote:
    Hi everyone, I fixed using this version of the JLine library --->
    jline-0.9.94
    I dunno why I downloaded a previous one, but I would like know which the
    actual used version is.
    Thanks again.

    Renato M.


    --
    Best Regards

    Jeff Zhang
  • Jeff Zhang at May 24, 2010 at 5:31 am
    You don't need to download jline by yourself. In eclipse, you only
    need to run "ant jar", and then put all the jar under lib and
    build/ivy/lib/Pig to the classpath. And also put the pig.jar to the
    classpath. Then You should be able to run pig script in eclipse using
    the embedded mode, but I'm afraid you can't run it using cli mode, the
    jline seems not work well in eclipse.



    On Mon, May 24, 2010 at 1:11 PM, Renato Marroquín Mogrovejo
    wrote:
    Thanks Jeff, do I need to do this? I mean I downloaded it and put it on my
    jvm/lib/ext, then I run "ant" and it worked fine :)
    Hey do you know if we can run PIG in mapreduce mode inside eclipse? I
    haven't been able to even though I have my env variables set, and I
    configured the run properties in the IDE. Thanks again.

    Renato M.

    2010/5/24 Jeff Zhang <zjffdu@gmail.com>
    After you run "ant jar", the jline 0.94 will be in build/ivy/lib/Pig
    You don't need to download jline by yourself.



    On Mon, May 24, 2010 at 10:49 AM, Renato Marroquín Mogrovejo
    wrote:
    Hi everyone, I fixed using this version of the JLine library --->
    jline-0.9.94
    I dunno why I downloaded a previous one, but I would like know which the
    actual used version is.
    Thanks again.

    Renato M.


    --
    Best Regards

    Jeff Zhang


    --
    Best Regards

    Jeff Zhang

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupdev @
categoriespig, hadoop
postedMay 24, '10 at 2:11a
activeMay 24, '10 at 5:31a
posts5
users2
websitepig.apache.org

People

Translate

site design / logo © 2022 Grokbase