FAQ
When compiled with #ifdef ZTS, the setitimer calls in
zend_unset_timeout show up as a performance hotspot even when I'd set
max_execution_time and max_input_time to 0 in php.ini.

I've attached a patch for review that avoids invoking
zend_unset_timeout (and thereby the expensive setitimer call within)
when timeouts have been disabled via settings in php.ini

Thanks,
Arvi

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-internals @
categoriesphp
postedOct 30, '09 at 10:12a
activeOct 30, '09 at 10:12a
posts1
users1
websitephp.net

1 user in discussion

Arvind Srinivasan: 1 post

People

Translate

site design / logo © 2022 Grokbase