FAQ
I have a problem that the PHP configure seems to automatically disable
pthreads when I compile on cross platfrom.
Host: i686-pentium-linux
Target: ppc-powerquicc-linux

More details about the target machine:
PowerQuicc II MPC8248

My configure file is as follows:
'./configure' \
'--cache-file=config.cache' \
'--disable-debug' \
'--enable-memory-limit' \
'--enable-pic' \
'--enable-safe-mode' \
'--enable-sockets' \
'--enable-track-vars' \
'--enable-trans-sid' \
'--enable-wddx' \
'--sysconfdir=/home/yoav/export/etc/appWeb' \
'--with-exec-dir=/home/yoav/export/etc/appWeb/exec' \
'--with-regex=system' \
'--with-pear' \
'--with-xml' \
'--with-xmlrpc' \
'--enable-bcmath' \
'--enable-calendar' \
'--enable-force-cgi-redirect' \
'--enable-ftp' \
'--enable-inline-optimization' \
'--enable-magic-quotes' \
'--disable-rpath' \
'--with-zlib' \
'--with-db' \
'--enable-embed=shared' \
'--with-gnu-ld' \
'--prefix=/home/yoav/export/etc/php5' \
'--target=ppc-powerquicc-linux' \
'--enable-maintainer-zts' \
'--with-tsrm-pthreads'

Using ZTS as an application I would like to use (AppWeb) required it and
I must have a multi threaded version of PHP.
Looking at the configure file it seems that PHP automatically chooses to
disable pthreads once it detects it's a cross platform compilation.

Thanks,

Yoav.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-internals @
categoriesphp
postedFeb 14, '06 at 3:32p
activeFeb 14, '06 at 3:32p
posts1
users1
websitephp.net

1 user in discussion

Artzi, Yoav \(Yoav\): 1 post

People

Translate

site design / logo © 2021 Grokbase