FAQ
Hi All,

I have updated the php to latest HEAD from then on compiling
zend_execute.c keeps hanging.

This is the compile command I could see,

/bin/sh /root/kamesh/work/php-src/libtool --silent --preserve-dup-deps
--mode=compile /root/kamesh/work/php-src/meta_ccld -IZend/
-I/root/kamesh/work/php-src/Zend/ -DPHP_ATOM_INC
-I/root/kamesh/work/php-src/include -I/root/kamesh/work/php-src/main
-I/root/kamesh/work/php-src -I/root/kamesh/work/php-src/Zend
-I/usr/include/libxml2 -D_REENTRANT -I/root/kamesh/work/php-src/TSRM
-g -O2 -pthread -DZTS -prefer-pic -c
/root/kamesh/work/php-src/Zend/zend_execute.c -o Zend/zend_execute.lo

With regards
Kamesh Jayachandran

Search Discussions

  • Kamesh Jayachandran at Sep 25, 2004 at 2:17 pm
    Hi Andi,
    This problem seems to be there with the zend_compile.h version 1.293,
    zend_execute.c version 1.680, zend_opcode.c version 1.108 and
    zend_execute_API.c version 1.299.

    This compilation problem does not exist in Non-ZTS mode, but exist in
    ZTS mode only.

    I have just reverted the versions just 1 down and My problem(ZTS build)
    is solved.
    With regards
    Kamesh Jayachandran
    On Sat, 25 Sep 2004 05:18:14 -0700, "Kamesh Jayachandran"
    <kameshj@fastmail.fm> said:
    Hi All,

    I have updated the php to latest HEAD from then on compiling
    zend_execute.c keeps hanging.

    This is the compile command I could see,

    /bin/sh /root/kamesh/work/php-src/libtool --silent --preserve-dup-deps
    --mode=compile /root/kamesh/work/php-src/meta_ccld -IZend/
    -I/root/kamesh/work/php-src/Zend/ -DPHP_ATOM_INC
    -I/root/kamesh/work/php-src/include -I/root/kamesh/work/php-src/main
    -I/root/kamesh/work/php-src -I/root/kamesh/work/php-src/Zend
    -I/usr/include/libxml2 -D_REENTRANT -I/root/kamesh/work/php-src/TSRM
    -g -O2 -pthread -DZTS -prefer-pic -c
    /root/kamesh/work/php-src/Zend/zend_execute.c -o Zend/zend_execute.lo

    With regards
    Kamesh Jayachandran

    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
  • Andi Gutmans at Sep 28, 2004 at 2:13 am
    What platform are you on? What compiler? (Netware?)
    Try and edit zend_vm.h:
    #ifndef ZEND_VM_OLD_EXECUTOR
    /*# define ZEND_VM_KIND ZEND_VM_KIND_CALL */

    And uncomment the second line (forces PHP to use the function call handlers).
    Let me know what happens.
    Andi
    At 05:18 AM 9/25/2004 -0700, Kamesh Jayachandran wrote:
    Hi All,

    I have updated the php to latest HEAD from then on compiling
    zend_execute.c keeps hanging.

    This is the compile command I could see,

    /bin/sh /root/kamesh/work/php-src/libtool --silent --preserve-dup-deps
    --mode=compile /root/kamesh/work/php-src/meta_ccld -IZend/
    -I/root/kamesh/work/php-src/Zend/ -DPHP_ATOM_INC
    -I/root/kamesh/work/php-src/include -I/root/kamesh/work/php-src/main
    -I/root/kamesh/work/php-src -I/root/kamesh/work/php-src/Zend
    -I/usr/include/libxml2 -D_REENTRANT -I/root/kamesh/work/php-src/TSRM
    -g -O2 -pthread -DZTS -prefer-pic -c
    /root/kamesh/work/php-src/Zend/zend_execute.c -o Zend/zend_execute.lo

    With regards
    Kamesh Jayachandran

    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
  • Kamesh Jayachandran at Sep 28, 2004 at 6:10 am
    Hi Andi,
    I had a problem in compiling the zend_execute.c.
    My CPU was used upto 100% for 10 minutes while compiling zend_execute.c,
    After 10 minutes zend_execute.c got compiled.
    The same code when compiled with -O1 optimisations compiles pretty fast.

    I use gcc 3.3.1, trying to compile for Linux.

    With regards
    Kamesh Jayachandran


    On Mon, 27 Sep 2004 19:11:53 -0700, "Andi Gutmans" <andi@zend.com> said:
    What platform are you on? What compiler? (Netware?)
    Try and edit zend_vm.h:
    #ifndef ZEND_VM_OLD_EXECUTOR
    /*# define ZEND_VM_KIND ZEND_VM_KIND_CALL */

    And uncomment the second line (forces PHP to use the function call
    handlers).
    Let me know what happens.
    Andi
    At 05:18 AM 9/25/2004 -0700, Kamesh Jayachandran wrote:
    Hi All,

    I have updated the php to latest HEAD from then on compiling
    zend_execute.c keeps hanging.

    This is the compile command I could see,

    /bin/sh /root/kamesh/work/php-src/libtool --silent --preserve-dup-deps
    --mode=compile /root/kamesh/work/php-src/meta_ccld -IZend/
    -I/root/kamesh/work/php-src/Zend/ -DPHP_ATOM_INC
    -I/root/kamesh/work/php-src/include -I/root/kamesh/work/php-src/main
    -I/root/kamesh/work/php-src -I/root/kamesh/work/php-src/Zend
    -I/usr/include/libxml2 -D_REENTRANT -I/root/kamesh/work/php-src/TSRM
    -g -O2 -pthread -DZTS -prefer-pic -c
    /root/kamesh/work/php-src/Zend/zend_execute.c -o Zend/zend_execute.lo

    With regards
    Kamesh Jayachandran

    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
  • Wez Furlong at Sep 28, 2004 at 7:31 am
    There is no problem there...

    You configured PHP with the --enable-inline-optimization switch,
    right? Turn it off if you don't want an optimized executor.

    --Wez.


    On Mon, 27 Sep 2004 23:10:07 -0700, Kamesh Jayachandran
    wrote:
    Hi Andi,
    I had a problem in compiling the zend_execute.c.
    My CPU was used upto 100% for 10 minutes while compiling zend_execute.c,
    After 10 minutes zend_execute.c got compiled.
    The same code when compiled with -O1 optimisations compiles pretty fast.

    I use gcc 3.3.1, trying to compile for Linux.

    With regards
    Kamesh Jayachandran




    On Mon, 27 Sep 2004 19:11:53 -0700, "Andi Gutmans" <andi@zend.com> said:
    What platform are you on? What compiler? (Netware?)
    Try and edit zend_vm.h:
    #ifndef ZEND_VM_OLD_EXECUTOR
    /*# define ZEND_VM_KIND ZEND_VM_KIND_CALL */

    And uncomment the second line (forces PHP to use the function call
    handlers).
    Let me know what happens.
    Andi
    At 05:18 AM 9/25/2004 -0700, Kamesh Jayachandran wrote:
    Hi All,

    I have updated the php to latest HEAD from then on compiling
    zend_execute.c keeps hanging.

    This is the compile command I could see,

    /bin/sh /root/kamesh/work/php-src/libtool --silent --preserve-dup-deps
    --mode=compile /root/kamesh/work/php-src/meta_ccld -IZend/
    -I/root/kamesh/work/php-src/Zend/ -DPHP_ATOM_INC
    -I/root/kamesh/work/php-src/include -I/root/kamesh/work/php-src/main
    -I/root/kamesh/work/php-src -I/root/kamesh/work/php-src/Zend
    -I/usr/include/libxml2 -D_REENTRANT -I/root/kamesh/work/php-src/TSRM
    -g -O2 -pthread -DZTS -prefer-pic -c
    /root/kamesh/work/php-src/Zend/zend_execute.c -o Zend/zend_execute.lo

    With regards
    Kamesh Jayachandran

    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
  • Kamesh Jayachandran at Sep 28, 2004 at 8:01 am
    Hi Wez,

    Yes there is no problem. I got scared after my CPU getting hog for
    continous 5 minutes on a single file.

    Ultimately It compiles after around 10 minutes.

    FYI: I did not configure explicitly with --enable-inline-optimization
    switch.

    With regards
    Kamesh Jayachandran
    On Tue, 28 Sep 2004 08:30:26 +0100, "Wez Furlong" <kingwez@gmail.com>
    said:
    There is no problem there...

    You configured PHP with the --enable-inline-optimization switch,
    right? Turn it off if you don't want an optimized executor.

    --Wez.


    On Mon, 27 Sep 2004 23:10:07 -0700, Kamesh Jayachandran
    wrote:
    Hi Andi,
    I had a problem in compiling the zend_execute.c.
    My CPU was used upto 100% for 10 minutes while compiling zend_execute.c,
    After 10 minutes zend_execute.c got compiled.
    The same code when compiled with -O1 optimisations compiles pretty fast.

    I use gcc 3.3.1, trying to compile for Linux.

    With regards
    Kamesh Jayachandran




    On Mon, 27 Sep 2004 19:11:53 -0700, "Andi Gutmans" <andi@zend.com> said:
    What platform are you on? What compiler? (Netware?)
    Try and edit zend_vm.h:
    #ifndef ZEND_VM_OLD_EXECUTOR
    /*# define ZEND_VM_KIND ZEND_VM_KIND_CALL */

    And uncomment the second line (forces PHP to use the function call
    handlers).
    Let me know what happens.
    Andi
    At 05:18 AM 9/25/2004 -0700, Kamesh Jayachandran wrote:
    Hi All,

    I have updated the php to latest HEAD from then on compiling
    zend_execute.c keeps hanging.

    This is the compile command I could see,

    /bin/sh /root/kamesh/work/php-src/libtool --silent --preserve-dup-deps
    --mode=compile /root/kamesh/work/php-src/meta_ccld -IZend/
    -I/root/kamesh/work/php-src/Zend/ -DPHP_ATOM_INC
    -I/root/kamesh/work/php-src/include -I/root/kamesh/work/php-src/main
    -I/root/kamesh/work/php-src -I/root/kamesh/work/php-src/Zend
    -I/usr/include/libxml2 -D_REENTRANT -I/root/kamesh/work/php-src/TSRM
    -g -O2 -pthread -DZTS -prefer-pic -c
    /root/kamesh/work/php-src/Zend/zend_execute.c -o Zend/zend_execute.lo

    With regards
    Kamesh Jayachandran

    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
  • Andi Gutmans at Sep 28, 2004 at 6:49 pm
    It's actually changed and you need to use --disable-inline-optimization to
    disable inline optimizations.

    Andi
    At 01:01 AM 9/28/2004 -0700, Kamesh Jayachandran wrote:
    Hi Wez,

    Yes there is no problem. I got scared after my CPU getting hog for
    continous 5 minutes on a single file.

    Ultimately It compiles after around 10 minutes.

    FYI: I did not configure explicitly with --enable-inline-optimization
    switch.

    With regards
    Kamesh Jayachandran
    On Tue, 28 Sep 2004 08:30:26 +0100, "Wez Furlong" <kingwez@gmail.com>
    said:
    There is no problem there...

    You configured PHP with the --enable-inline-optimization switch,
    right? Turn it off if you don't want an optimized executor.

    --Wez.


    On Mon, 27 Sep 2004 23:10:07 -0700, Kamesh Jayachandran
    wrote:
    Hi Andi,
    I had a problem in compiling the zend_execute.c.
    My CPU was used upto 100% for 10 minutes while compiling zend_execute.c,
    After 10 minutes zend_execute.c got compiled.
    The same code when compiled with -O1 optimisations compiles pretty fast.

    I use gcc 3.3.1, trying to compile for Linux.

    With regards
    Kamesh Jayachandran




    On Mon, 27 Sep 2004 19:11:53 -0700, "Andi Gutmans" <andi@zend.com> said:
    What platform are you on? What compiler? (Netware?)
    Try and edit zend_vm.h:
    #ifndef ZEND_VM_OLD_EXECUTOR
    /*# define ZEND_VM_KIND ZEND_VM_KIND_CALL */

    And uncomment the second line (forces PHP to use the function call
    handlers).
    Let me know what happens.
    Andi
    At 05:18 AM 9/25/2004 -0700, Kamesh Jayachandran wrote:
    Hi All,

    I have updated the php to latest HEAD from then on compiling
    zend_execute.c keeps hanging.

    This is the compile command I could see,

    /bin/sh /root/kamesh/work/php-src/libtool --silent --preserve-dup-deps
    --mode=compile /root/kamesh/work/php-src/meta_ccld -IZend/
    -I/root/kamesh/work/php-src/Zend/ -DPHP_ATOM_INC
    -I/root/kamesh/work/php-src/include -I/root/kamesh/work/php-src/main
    -I/root/kamesh/work/php-src -I/root/kamesh/work/php-src/Zend
    -I/usr/include/libxml2 -D_REENTRANT -I/root/kamesh/work/php-src/TSRM
    -g -O2 -pthread -DZTS -prefer-pic -c
    /root/kamesh/work/php-src/Zend/zend_execute.c -o Zend/zend_execute.lo

    With regards
    Kamesh Jayachandran

    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php
  • Andi Gutmans at Sep 28, 2004 at 6:42 pm
    I am running gcc 3.3.3 and don't have this problem.
    Any chance you are hitting swap space?
    It's definitely taking much more memory now as there's lots of inlining
    going on.

    Andi
    At 11:10 PM 9/27/2004 -0700, Kamesh Jayachandran wrote:
    Hi Andi,
    I had a problem in compiling the zend_execute.c.
    My CPU was used upto 100% for 10 minutes while compiling zend_execute.c,
    After 10 minutes zend_execute.c got compiled.
    The same code when compiled with -O1 optimisations compiles pretty fast.

    I use gcc 3.3.1, trying to compile for Linux.

    With regards
    Kamesh Jayachandran


    On Mon, 27 Sep 2004 19:11:53 -0700, "Andi Gutmans" <andi@zend.com> said:
    What platform are you on? What compiler? (Netware?)
    Try and edit zend_vm.h:
    #ifndef ZEND_VM_OLD_EXECUTOR
    /*# define ZEND_VM_KIND ZEND_VM_KIND_CALL */

    And uncomment the second line (forces PHP to use the function call
    handlers).
    Let me know what happens.
    Andi
    At 05:18 AM 9/25/2004 -0700, Kamesh Jayachandran wrote:
    Hi All,

    I have updated the php to latest HEAD from then on compiling
    zend_execute.c keeps hanging.

    This is the compile command I could see,

    /bin/sh /root/kamesh/work/php-src/libtool --silent --preserve-dup-deps
    --mode=compile /root/kamesh/work/php-src/meta_ccld -IZend/
    -I/root/kamesh/work/php-src/Zend/ -DPHP_ATOM_INC
    -I/root/kamesh/work/php-src/include -I/root/kamesh/work/php-src/main
    -I/root/kamesh/work/php-src -I/root/kamesh/work/php-src/Zend
    -I/usr/include/libxml2 -D_REENTRANT -I/root/kamesh/work/php-src/TSRM
    -g -O2 -pthread -DZTS -prefer-pic -c
    /root/kamesh/work/php-src/Zend/zend_execute.c -o Zend/zend_execute.lo

    With regards
    Kamesh Jayachandran

    --
    PHP Internals - PHP Runtime Development Mailing List
    To unsubscribe, visit: http://www.php.net/unsub.php

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-internals @
categoriesphp
postedSep 25, '04 at 12:18p
activeSep 28, '04 at 6:49p
posts8
users3
websitephp.net

People

Translate

site design / logo © 2022 Grokbase