FAQ
Buenos días.

Tanto si cambio las variables …

php_value upload_max_filesize 100M
php_value post_max_size 100M
php_value max_execution_time 1000
php_value max_input_time 1000

… en el /etc/php5/apache2/php.ini como en el /etc/php5/cli/php.ini, … tras
reiniciar … no veo reflejado el cambio en el phpinfo(). Me obliga a
cambiarlas en el .htaccess.
¿Cuál es el problema?

Search Discussions

  • Alex A. Solano at Sep 23, 2011 at 8:29 am
    Pero es que esas no son las variables del php.ini sino del .htaccess

    Para cambiarlas en el php.ini has de cambiar:

    upload_max_filesize = 2M
    post_max_size = 8M
    ...

    sin el php_value delante.

    Saludos
    Alex.


    El 23 de septiembre de 2011 10:09, Gorka <gorkaphp@yahoo.es> escribió:
    Buenos días.

    Tanto si cambio las variables …

    php_value upload_max_filesize 100M
    php_value post_max_size 100M
    php_value max_execution_time 1000
    php_value max_input_time 1000

    … en el /etc/php5/apache2/php.ini como en el /etc/php5/cli/php.ini, … tras
    reiniciar … no veo reflejado el cambio en el phpinfo(). Me obliga a
    cambiarlas en el .htaccess.
    ¿Cuál es el problema?







    --
    PHP Spanish Localization Talk Mailing List (http://www.php.net/)
    To unsubscribe, visit: http://www.php.net/unsub.php
  • David Fraga at Sep 23, 2011 at 8:57 am
    El .htaccess prevalece sobre php.ini, de otra forma no tendría sentido.
    Así puedes tener una configuración global en un servidor y en cada
    directorio de una web, unas especificaciones distintas según convenga.

    El 23/09/11 10:09, Gorka escribió:
    Buenos días.

    Tanto si cambio las variables …

    php_value upload_max_filesize 100M
    php_value post_max_size 100M
    php_value max_execution_time 1000
    php_value max_input_time 1000

    … en el /etc/php5/apache2/php.ini como en el /etc/php5/cli/php.ini, … tras
    reiniciar … no veo reflejado el cambio en el phpinfo(). Me obliga a
    cambiarlas en el .htaccess.
    ¿Cuál es el problema?





  • Gorka at Sep 23, 2011 at 10:53 am
    Lo sé. Utilizo el .htacces sólo porque no me funciona simplemente cambiando
    las variables del php.ini ...

    upload_max_filesize 100M
    post_max_size 100M
    max_execution_time 1000
    max_input_time 1000

    Antes no lo tenía, es sólo provisional. Me gustaría quitar no utilizar
    .htaccess
    ¿Dónde puede estar el problema?
    -----Mensaje original-----
    De: David Fraga
    Enviado el: viernes, 23 de septiembre de 2011 10:57
    Para: php-es@lists.php.net
    Asunto: Re: [PHP-ES] Cambios en php.ini sin efecto

    El .htaccess prevalece sobre php.ini, de otra forma no tendría sentido.
    Así puedes tener una configuración global en un servidor y en cada
    directorio de una web, unas especificaciones distintas según convenga.

    El 23/09/11 10:09, Gorka escribió:
    Buenos días.

    Tanto si cambio las variables …

    php_value upload_max_filesize 100M
    php_value post_max_size 100M
    php_value max_execution_time 1000
    php_value max_input_time 1000

    … en el /etc/php5/apache2/php.ini como en el /etc/php5/cli/php.ini, …
    tras
    reiniciar … no veo reflejado el cambio en el phpinfo(). Me obliga a
    cambiarlas en el .htaccess.
    ¿Cuál es el problema?





    --
    PHP Spanish Localization Talk Mailing List (http://www.php.net/)
    To unsubscribe, visit: http://www.php.net/unsub.php
  • David Fraga at Sep 23, 2011 at 11:05 am
    ¿Qué servidor estás usando? ¿usas Plesk?

    El 23/09/11 12:53, Gorka escribió:
    Lo sé. Utilizo el .htacces sólo porque no me funciona simplemente cambiando
    las variables del php.ini ...

    upload_max_filesize 100M
    post_max_size 100M
    max_execution_time 1000
    max_input_time 1000

    Antes no lo tenía, es sólo provisional. Me gustaría quitar no utilizar
    .htaccess
    ¿Dónde puede estar el problema?
  • Eduardo Huertas at Sep 23, 2011 at 1:31 pm

    El día 23 de septiembre de 2011 12:53, Gorka escribió:
    Lo sé. Utilizo el .htacces sólo porque no me funciona simplemente cambiando
    las variables del php.ini ...

    upload_max_filesize 100M
    post_max_size 100M
    max_execution_time 1000
    max_input_time 1000

    Antes no lo tenía, es sólo provisional. Me gustaría quitar no utilizar
    .htaccess
    ¿Dónde puede estar el problema?
    ¿Has reiniciado apache?
  • Gorka at Sep 23, 2011 at 3:22 pm

    Lo sé. Utilizo el .htacces sólo porque no me funciona simplemente
    cambiando las variables del php.ini ...

    upload_max_filesize 100M
    post_max_size 100M
    max_execution_time 1000
    max_input_time 1000

    Antes no lo tenía, es sólo provisional. Me gustaría quitar no utilizar
    .htaccess ¿Dónde puede estar el problema?
    ¿Has reiniciado apache?
    No uso Plesk. Uso apache2 sobre Debian Squeeze.
    Si, he reiniciado apache varias veces.
  • Eduardo Huertas at Sep 23, 2011 at 4:23 pm

    El día 23 de septiembre de 2011 17:22, Gorka escribió:
    ¿Has reiniciado apache?
    No uso Plesk. Uso apache2 sobre Debian Squeeze.
    Si, he reiniciado apache varias veces.
    Pues por lo que describes lo has hecho bien.

    Has editado el archivo /etc/php5/apache2/php.ini modificando los
    valores de las variables que has especificado y luego has reiniciado
    el servidor

    Debería funcionar.

    Supongo que has quitado el archivo .htaccess en la prueba. No se me
    ocurren muchas más cosas...

    Si se me ocurre algo te aviso.
  • Eduardo Huertas at Sep 23, 2011 at 4:40 pm
    El día 23 de septiembre de 2011 18:23, Eduardo Huertas
    <e.huertas@gmail.com> escribió:
    El día 23 de septiembre de 2011 17:22, Gorka <gorkaphp@yahoo.es> escribió:
    ¿Has reiniciado apache?
    No uso Plesk. Uso apache2 sobre Debian Squeeze.
    Si, he reiniciado apache varias veces.
    Pues por lo que describes lo has hecho bien.

    Has editado el archivo /etc/php5/apache2/php.ini modificando los
    valores de las variables que has especificado y luego has reiniciado
    el servidor

    Debería funcionar.

    Supongo que has quitado el archivo .htaccess en la prueba. No se me
    ocurren muchas más cosas...

    Si se me ocurre algo te aviso.
    Se me ha ocurrido :D

    Prueba ejecutar en una terminal el comando apachectl configtest
    Si las configuraciones son correctas debería devolverte un bonito "Syntax OK"

    A ver si hay suerte
  • Gorka at Sep 27, 2011 at 6:53 am

    Pues por lo que describes lo has hecho bien.

    Has editado el archivo /etc/php5/apache2/php.ini modificando los
    valores de las variables que has especificado y luego has reiniciado
    el servidor

    Debería funcionar.

    Supongo que has quitado el archivo .htaccess en la prueba. No se me
    ocurren muchas más cosas...

    Si se me ocurre algo te aviso.
    Se me ha ocurrido :D

    Prueba ejecutar en una terminal el comando apachectl configtest
    Si las configuraciones son correctas debería devolverte un bonito "Syntax
    OK"

    A ver si hay suerte
    Pues me devuelve "Syntax OK".
    Según se mire, no ha habido suertecilla.
    No me lo puedo creer. Si esto es 2+2=4. He hecho todo tal y como comentas y
    sigo sin ver los valores de las variables cambiados en el phpinfo(). Debería
    funcionar.
    ¿Alguna idea más?
  • Eduardo Huertas at Sep 27, 2011 at 11:13 am

    El día 27 de septiembre de 2011 08:53, Gorka escribió:
    Pues me devuelve "Syntax OK".
    Según se mire, no ha habido suertecilla.
    No me lo puedo creer. Si esto es 2+2=4. He hecho todo tal y como comentas y
    sigo sin ver los valores de las variables cambiados en el phpinfo(). Debería
    funcionar.
    ¿Alguna idea más?
    A ver, esto es una tontería... pero igual te sirve
    Cuando sacas el phpinfo mira lo siguiente.

    Configuration File (php.ini) Path
    Loaded Configuration File
    Scan this dir for additional .ini files
    Additional .ini files parsed

    A ver qué te devuelven, por si hubiese que revisar algun .ini adicional.

    Suerte.
  • Gorka at Sep 28, 2011 at 4:06 pm

    Pues me devuelve "Syntax OK".
    Según se mire, no ha habido suertecilla.
    No me lo puedo creer. Si esto es 2+2=4. He hecho todo tal y como
    comentas y sigo sin ver los valores de las variables cambiados en el
    phpinfo(). Debería funcionar.
    ¿Alguna idea más?
    A ver, esto es una tontería... pero igual te sirve Cuando sacas el phpinfo mira
    lo siguiente.

    Configuration File (php.ini) Path
    /etc/php5/apache2
    Loaded Configuration File
    /etc/php5/apache2/php.ini
    Aquí es donde tengo, por ejemplo, ...
    upload_max_filesize = 24M
    ... pero en el phpinfo() me sigue saliendo ...
    upload_max_filesize 2M
    Scan this dir for additional .ini files
    /etc/php5/apache2/conf.d
    Aquí hay varios ficheros, pero ninguno de ellos es php.ini ...
    gd.ini mcrypt.ini mssql.ini mysqli.ini mysql.ini pdo_dblib.ini pdo.ini
    pdo_mysql.ini suhosin.ini
    Additional .ini files parsed
    /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/mcrypt.ini,
    /etc/php5/apache2/conf.d/mssql.ini, /etc/php5/apache2/conf.d/mysql.ini,
    /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini,
    /etc/php5/apache2/conf.d/pdo_dblib.ini,
    /etc/php5/apache2/conf.d/pdo_mysql.ini, /etc/php5/apache2/conf.d/suhosin.ini
    Ninguno de estos repositorios es php.ini.
    A ver qué te devuelven, por si hubiese que revisar algun .ini adicional.
    Una búsqueda de la variable en /etc/ me da lo siguiente ...
    # grep -r upload_max_filesize ./
    ./php5/cli/php.ini:upload_max_filesize = 24M
    ./php5/apache2/php.ini:upload_max_filesize = 24M
    Coincidencia en el fichero binario ./alternatives/php

    La última línea no sé qué es, pero vamos, ... que no parece haber más
    php.ini, ¿verdad?
    ¿Por qué se empeña entonces en mantener ...
    upload_max_filesize 2M
    ?
  • Gorka at Sep 29, 2011 at 10:19 am

    Pues me devuelve "Syntax OK".
    Según se mire, no ha habido suertecilla.
    No me lo puedo creer. Si esto es 2+2=4. He hecho todo tal y como
    comentas y sigo sin ver los valores de las variables cambiados en el
    phpinfo(). Debería funcionar.
    ¿Alguna idea más?
    A ver, esto es una tontería... pero igual te sirve Cuando sacas el
    phpinfo mira
    lo siguiente.

    Configuration File (php.ini) Path
    /etc/php5/apache2
    Loaded Configuration File
    /etc/php5/apache2/php.ini
    Aquí es donde tengo, por ejemplo, ...
    upload_max_filesize = 24M
    ... pero en el phpinfo() me sigue saliendo ...
    upload_max_filesize 2M
    Scan this dir for additional .ini files
    /etc/php5/apache2/conf.d
    Aquí hay varios ficheros, pero ninguno de ellos es php.ini ...
    gd.ini mcrypt.ini mssql.ini mysqli.ini mysql.ini pdo_dblib.ini pdo.ini
    pdo_mysql.ini suhosin.ini
    Additional .ini files parsed
    /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/mcrypt.ini,
    /etc/php5/apache2/conf.d/mssql.ini, /etc/php5/apache2/conf.d/mysql.ini,
    /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini,
    /etc/php5/apache2/conf.d/pdo_dblib.ini,
    /etc/php5/apache2/conf.d/pdo_mysql.ini,
    /etc/php5/apache2/conf.d/suhosin.ini
    Ninguno de estos repositorios es php.ini.
    A ver qué te devuelven, por si hubiese que revisar algun .ini adicional.
    Una búsqueda de la variable en /etc/ me da lo siguiente ...
    # grep -r upload_max_filesize ./
    ./php5/cli/php.ini:upload_max_filesize = 24M
    ./php5/apache2/php.ini:upload_max_filesize = 24M Coincidencia en el
    fichero binario ./alternatives/php

    La última línea no sé qué es, pero vamos, ... que no parece haber más
    php.ini, ¿verdad?
    ¿Por qué se empeña entonces en mantener ...
    upload_max_filesize 2M
    ?
    En /etc/apache2/sites-enabled/000-default he puesto, para probar, lo mínimo
    posible ...

    <VirtualHost *:80>
    ServerName 10.0.0.100
    DocumentRoot /var/www/
    ServerAdmin webmaster@localhost
    DirectoryIndex index.php index.html index.htm default.html default.htm
    <Directory /var/www/>
    Options -Indexes FollowSymLinks -MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    TransferLog /var/log/apache2/10.0.0.100-access.log
    ErrorLog /var/log/apache2/10.0.0.100-error.log
    </VirtualHost>

    ... y sigue igual.

    En fin. Si algún día consigo solucionar este misterio lo publicaré, por si
    le sirve a alguien más.
    Hasta entonces, un saludo y ... Alex, David, Eduardo, ... gracias a todos
    igualmente.
  • Gorka at Oct 7, 2011 at 2:14 pm

    Pues me devuelve "Syntax OK".
    Según se mire, no ha habido suertecilla.
    No me lo puedo creer. Si esto es 2+2=4. He hecho todo tal y como
    comentas y sigo sin ver los valores de las variables cambiados en
    el phpinfo(). Debería funcionar.
    ¿Alguna idea más?
    A ver, esto es una tontería... pero igual te sirve Cuando sacas el
    phpinfo mira
    lo siguiente.

    Configuration File (php.ini) Path
    /etc/php5/apache2
    Loaded Configuration File
    /etc/php5/apache2/php.ini
    Aquí es donde tengo, por ejemplo, ...
    upload_max_filesize = 24M
    ... pero en el phpinfo() me sigue saliendo ...
    upload_max_filesize 2M
    Scan this dir for additional .ini files
    /etc/php5/apache2/conf.d
    Aquí hay varios ficheros, pero ninguno de ellos es php.ini ...
    gd.ini mcrypt.ini mssql.ini mysqli.ini mysql.ini pdo_dblib.ini pdo.ini
    pdo_mysql.ini suhosin.ini
    Additional .ini files parsed
    /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/mcrypt.ini,
    /etc/php5/apache2/conf.d/mssql.ini,
    /etc/php5/apache2/conf.d/mysql.ini,
    /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini,
    /etc/php5/apache2/conf.d/pdo_dblib.ini,
    /etc/php5/apache2/conf.d/pdo_mysql.ini,
    /etc/php5/apache2/conf.d/suhosin.ini
    Ninguno de estos repositorios es php.ini.
    A ver qué te devuelven, por si hubiese que revisar algun .ini
    adicional.
    Una búsqueda de la variable en /etc/ me da lo siguiente ...
    # grep -r upload_max_filesize ./
    ./php5/cli/php.ini:upload_max_filesize = 24M
    ./php5/apache2/php.ini:upload_max_filesize = 24M Coincidencia en el
    fichero binario ./alternatives/php

    La última línea no sé qué es, pero vamos, ... que no parece haber más
    php.ini, ¿verdad?
    ¿Por qué se empeña entonces en mantener ...
    upload_max_filesize 2M
    ?
    En /etc/apache2/sites-enabled/000-default he puesto, para probar, lo
    mínimo posible ...

    <VirtualHost *:80>
    ServerName 10.0.0.100
    DocumentRoot /var/www/
    ServerAdmin webmaster@localhost
    DirectoryIndex index.php index.html index.htm default.html default.htm
    <Directory /var/www/>
    Options -Indexes FollowSymLinks -MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    TransferLog /var/log/apache2/10.0.0.100-access.log
    ErrorLog /var/log/apache2/10.0.0.100-error.log
    </VirtualHost>

    ... y sigue igual.

    En fin. Si algún día consigo solucionar este misterio lo publicaré, por si le sirve
    a alguien más.
    Hasta entonces, un saludo y ... Alex, David, Eduardo, ... gracias a todos
    igualmente.
    Pues ya lo he solucionado.
    Para quien se encuentre en la misma situación, ... finalmente desinstalé
    ciertos paquetes con ...
    apt-get --purge remove libapache2-mod-php5 php5-cli php5-common php5-gd
    ... y tras volverlos a instalar ... los cambios en el php.ini ya se
    reflejan.
    Puede que el problema tuviera algo que ver con el orden de instalación
    inicial.
    Solucionado.
    Un saludo.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-general-es @
categoriesphp
postedSep 23, '11 at 8:10a
activeOct 7, '11 at 2:14p
posts14
users4
websitephp.net

People

Translate

site design / logo © 2022 Grokbase