FAQ
Al hacer un restart del apache me da el siguiente error ...

Restarting web server: apache2[Fri Sep 23 10:05:38 2011] [warn]
NameVirtualHost *:80 has no VirtualHosts
... waiting [Fri Sep 23 10:05:39 2011] [warn] NameVirtualHost *:80 has no
VirtualHosts
.

Todo funciona, pero me gustaría quitar este mensaje. Se que tengo algo mal
definido, pero no alcanzo a saber qué.
Esto es lo que tengo en /etc/apache2/sites-enabled/000-default ...

#Listen 80

NameVirtualHost *:80

# PETICIONES POR DEFECTO.

<VirtualHost *:80>
DocumentRoot /var/www/desarrollo/
ServerAdmin webmaster@localhost
DirectoryIndex index.php index.html index.htm default.html default.htm
<Directory />
Options -FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/desarrollo/>
Options -Indexes -FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>
TransferLog /var/log/apache2/access.log
ErrorLog /var/log/apache2/error.log
</VirtualHost>

# MATCHINGS DE SERVERNAME.

<VirtualHost *:80>
ServerName www.laweb.com
DocumentRoot /var/www/publica/
ServerAdmin webmaster@localhost
DirectoryIndex index.php index.html index.htm default.html default.htm
<Directory />
Options -FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/publica/>
Options -Indexes -FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
Options Includes
AllowOverride All
</Directory>
TransferLog /var/log/apache2/www.laweb.com-access.log
ErrorLog /var/log/apache2/www.laweb.com-error.log
</VirtualHost>

<VirtualHost *:80>
ServerName www.laweb.es
DocumentRoot /var/www/publica/
ServerAdmin webmaster@localhost
DirectoryIndex index.php index.html index.htm default.html default.htm
<Directory />
Options -FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/publica/>
Options -Indexes -FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
Options Includes
AllowOverride All
</Directory>
TransferLog /var/log/apache2/www.laweb.es-access.log
ErrorLog /var/log/apache2/www.laweb.es-error.log
</VirtualHost>

<VirtualHost *:80>
ServerName 10.0.0.100
DocumentRoot /var/www/
ServerAdmin webmaster@localhost
DirectoryIndex index.php index.html index.htm default.html default.htm
<Directory />
Options -FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options -Indexes FollowSymLinks -MultiViews
AllowOverride None
Order allow,deny
allow from all
Options Includes
AllowOverride All
</Directory>
TransferLog /var/log/apache2/10.0.0.100-access.log
ErrorLog /var/log/apache2/10.0.0.100-error.log
</VirtualHost>

Search Discussions

  • Eduardo Huertas at Sep 23, 2011 at 1:48 pm

    2011/9/23 Gorka <gorkaphp@yahoo.es>:
    Al hacer un restart del apache me da el siguiente error ...

    Restarting web server: apache2[Fri Sep 23 10:05:38 2011] [warn]
    NameVirtualHost *:80 has no VirtualHosts
    ... waiting [Fri Sep 23 10:05:39 2011] [warn] NameVirtualHost *:80 has no
    VirtualHosts
    .

    Todo funciona, pero me gustaría quitar este mensaje. Se que tengo algo mal
    definido, pero no alcanzo a saber qué.
    Pégale un vistazo a esto a ver si te sirve de ayuda
    http://www.debian-administration.org/articles/412
  • Gorka at Sep 23, 2011 at 3:47 pm

    -----Mensaje original-----
    De: Eduardo Huertas
    Enviado el: viernes, 23 de septiembre de 2011 15:48
    Para: Gorka
    CC: PHP CA
    Asunto: Re: [PHP-ES] Error al reiniciar apache2

    2011/9/23 Gorka <gorkaphp@yahoo.es>:
    Al hacer un restart del apache me da el siguiente error ...

    Restarting web server: apache2[Fri Sep 23 10:05:38 2011] [warn]
    NameVirtualHost *:80 has no VirtualHosts
    ... waiting [Fri Sep 23 10:05:39 2011] [warn] NameVirtualHost *:80
    has no VirtualHosts .

    Todo funciona, pero me gustaría quitar este mensaje. Se que tengo algo
    mal definido, pero no alcanzo a saber qué.
    Pégale un vistazo a esto a ver si te sirve de ayuda
    http://www.debian-administration.org/articles/412
    Exacto, gracias.
    Parece que ahora sobra el ...

    NameVirtualHost *:80

    ... que poníamos antiguamente.
    Tras comentarlo ya no sale el error.
    Gracias Eduardo.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-general-es @
categoriesphp
postedSep 23, '11 at 8:19a
activeSep 23, '11 at 3:47p
posts3
users2
websitephp.net

2 users in discussion

Gorka: 2 posts Eduardo Huertas: 1 post

People

Translate

site design / logo © 2022 Grokbase