FAQ
Holoa amigos:

Se que este problema se ha discutido ya pero no acabo de entender...

Tengo un script para crear una session pero no me lo hace.. Tengo PHP
Version 4.3.11, y este es el script

<?php
session_start();
// Motor autentificación usuarios.
if (!isset($_SESSION["usuario_id"])){
// Cargar datos conexion y otras variables.
require ("config.conf");


// Conexión base de datos.
// si no se puede conectar a la BD salimos del scrip con error 0 y
// redireccionamos a la pagina de error.

$db_conexion= mysql_connect("$sql_host", "$sql_usuario", "$sql_pass") or
die(header ("Location: $redir?error_login=0"));
mysql_select_db("$sql_db");

// realizamos la consulta a la BD para insertar un usuario X
$usuario = mysql_query("Insert INTO cliente (cliente) VALUES ('p')");
$resultuser = mysql_query($sqluser);
//Asigno el valor del ultimo insertado
$idcliente = mysql_insert_id();

// incia sessiones
session_start();

// Paranoia: decimos al navegador que no "cachee" esta página.
session_cache_limiter('nocache,private');

// Asignamos variables de sesión con datos del Usuario para el uso en el
// resto de páginas autentificadas.

// definimos $usuarios_id como IDentificador del usuario en nuestra BD
de usuarios
$usuario_id = $idcliente;
//registramos las variables en la sesión:
session_register("usuario_id");

}
?>

Cuando quiero acceder a el valor $_SESSION["usuario_id"] no me da el valor
correctamente, ademas siempre entra a
if (!isset($_SESSION["usuario_id"])){, o sea que no crea la sesion... Estoy
haciendo muchas cosas mal???

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-general-es @
categoriesphp
postedSep 21, '06 at 3:37p
activeSep 21, '06 at 3:37p
posts1
users1
websitephp.net

1 user in discussion

Remy: 1 post

People

Translate

site design / logo © 2022 Grokbase