FAQ
Buenas.
Formatié una máquina que tenía instalado el wamp (paquete que tiene php,
apache, mysql y eso), y si bien lo puede instalar nuevamente, como esta
máquina está en red quiero configurar para que los otros puedan ejecutar
páginas que están en esta máquina y no lo logré.
Alguien conoce la configuración?.
Me parece que tiene que ver con cambiar algun rooteo pero no se que.
Sigo investigando, si alguien sabe algo y/o conoce este paquete, bienvenido
seran sus comentarios.

Emiliano J. Horcada

Search Discussions

  • Vladimir Hernandez at Nov 4, 2005 at 8:20 pm

    Quoting Emiliano Horcada <emilianohorcada@gmail.com>:

    Buenas.
    Formatié una máquina que tenía instalado el wamp (paquete que tiene php,
    apache, mysql y eso), y si bien lo puede instalar nuevamente, como esta
    máquina está en red quiero configurar para que los otros puedan ejecutar
    páginas que están en esta máquina y no lo logré.
    Alguien conoce la configuración?.
    Me parece que tiene que ver con cambiar algun rooteo pero no se que.
    Sigo investigando, si alguien sabe algo y/o conoce este paquete, bienvenido
    seran sus comentarios.

    Emiliano J. Horcada
    Hay que revisar en la configuración de Apache quiénes están permitidos y
    quiénes están prohibidos de ver las páginas. Si Localhost puede ver páginas
    dirige otra computadora en el browser a http://el_ip_del_servidor_wamp

    Claro, todo esto asumiendo que tu red no bloquea el puerto 80 (el proxy o
    router).


    --
    Vladimir Hernández
    http://linuxbaja.org/
  • Gustavo Narea at Nov 4, 2005 at 8:56 pm
    Hola.

    Yo sé una manera de hacerlo, pero te funcionará si lo que quieres es una
    intranet sin acceso a Internet.

    1.- A todas las máquinas, les pones *la misma* máscara de red. Por
    ejemplo: 255.255.0.0. En WinME lo haces en Panel de control > Red. En
    WinXP, Panel de control > Conexiones de Red (si no tienes una conexión,
    la agregas, y si sí tienes una conexión, la modificas).

    2.- A cada máquina le estableces una dirección IP *distinta*. Por
    ejemplo, a la máquina #1 le pones la IP 128.0.0.1, a la máquina #2 le
    pones 128.0.0.2, y así sucesivamente. Esto lo haces en la misma ventana
    donde modificaste la máscara de red.

    3.- Puedes acceder al servidor mediante la dirección IP que le asignaste
    al equipo donde instalaste el servidor. Por ejemplo: http://128.0.0.1/.

    4.- Listo para usar!

    Por cierto, si tienes equipos con GNU/Linux y no quieres usar las
    direcciones IP, puedes editar el archivo /etc/hosts y agregarle una
    línea como esta:
    miserver 128.0.0.1
    Si haces esto, cada vez que accedas al servidor, puedes usar
    http://miserver/ en lugar de http://128.0.0.1. No sé si esto lo puedes
    hacer en Windows.

    Esto lo he probado con computadoras usando Windows ME y XP, sin embargo,
    me parece que debe funcionar en otros sistemas.

    Cuéntame si te funciona!

    Saludos.

    Emiliano Horcada wrote:
    Buenas.
    Formatié una máquina que tenía instalado el wamp (paquete que tiene php,
    apache, mysql y eso), y si bien lo puede instalar nuevamente, como esta
    máquina está en red quiero configurar para que los otros puedan ejecutar
    páginas que están en esta máquina y no lo logré.
    Alguien conoce la configuración?.
    Me parece que tiene que ver con cambiar algun rooteo pero no se que.
    Sigo investigando, si alguien sabe algo y/o conoce este paquete, bienvenido
    seran sus comentarios.

    Emiliano J. Horcada
    --
    Best regards,

    Gustavo Narea.
    PHP Documentation - Spanish Translation Team.
    Valencia, Venezuela.
  • Gustavo Narea at Nov 4, 2005 at 9:09 pm
    No sé si ya la red está puesta y funcionando con otros servicios, por
    eso te mandé este mensaje.

    De todos modos, si la red funciona con otros servicios, pero no el web,
    haz lo que te sugirió Vladimir.

    Saludos!

    Gustavo Narea wrote:
    Hola.

    Yo sé una manera de hacerlo, pero te funcionará si lo que quieres es una
    intranet sin acceso a Internet.

    1.- A todas las máquinas, les pones *la misma* máscara de red. Por
    ejemplo: 255.255.0.0. En WinME lo haces en Panel de control > Red. En
    WinXP, Panel de control > Conexiones de Red (si no tienes una conexión,
    la agregas, y si sí tienes una conexión, la modificas).

    2.- A cada máquina le estableces una dirección IP *distinta*. Por
    ejemplo, a la máquina #1 le pones la IP 128.0.0.1, a la máquina #2 le
    pones 128.0.0.2, y así sucesivamente. Esto lo haces en la misma ventana
    donde modificaste la máscara de red.

    3.- Puedes acceder al servidor mediante la dirección IP que le asignaste
    al equipo donde instalaste el servidor. Por ejemplo: http://128.0.0.1/.

    4.- Listo para usar!

    Por cierto, si tienes equipos con GNU/Linux y no quieres usar las
    direcciones IP, puedes editar el archivo /etc/hosts y agregarle una
    línea como esta:
    miserver 128.0.0.1
    Si haces esto, cada vez que accedas al servidor, puedes usar
    http://miserver/ en lugar de http://128.0.0.1. No sé si esto lo puedes
    hacer en Windows.

    Esto lo he probado con computadoras usando Windows ME y XP, sin embargo,
    me parece que debe funcionar en otros sistemas.

    Cuéntame si te funciona!

    Saludos.

    Emiliano Horcada wrote:
    Buenas.
    Formatié una máquina que tenía instalado el wamp (paquete que tiene php,
    apache, mysql y eso), y si bien lo puede instalar nuevamente, como esta
    máquina está en red quiero configurar para que los otros puedan ejecutar
    páginas que están en esta máquina y no lo logré.
    Alguien conoce la configuración?.
    Me parece que tiene que ver con cambiar algun rooteo pero no se que.
    Sigo investigando, si alguien sabe algo y/o conoce este paquete,
    bienvenido
    seran sus comentarios.

    Emiliano J. Horcada
    --
    Best regards,

    Gustavo Narea.
    PHP Documentation - Spanish Translation Team.
    Valencia, Venezuela.
  • Gustavo Narea at Nov 4, 2005 at 9:20 pm

    Gustavo Narea wrote:
    Por cierto, si tienes equipos con GNU/Linux y no quieres usar las
    direcciones IP, puedes editar el archivo /etc/hosts y agregarle una
    línea como esta:
    miserver 128.0.0.1
    Si haces esto, cada vez que accedas al servidor, puedes usar
    http://miserver/ en lugar de http://128.0.0.1. No sé si esto lo puedes
    hacer en Windows.
    Supongo que la única manera de hacerlo es con un servidor DNS.

    --
    Best regards,

    Gustavo Narea.
    PHP Documentation - Spanish Translation Team.
    Valencia, Venezuela.
  • Marcos Ramírez at Nov 4, 2005 at 10:21 pm

    El Viernes 04 Noviembre 2005 22:19, Gustavo Narea escribió:
    Supongo que la única manera de hacerlo es con un servidor DNS.
    No recuerdo exactamente, por que hace años que no toco un win, pero _creo_ que
    se podía/puede hacer sin instalar servidores DNS, win asigna/ba nombres a
    cada maquina, igual que a la red, y te podias referir a las máquinas por sus
    nombres en el entorno de red...

    _supongo_ que valdrá, pero ya digo que no me haga/is mucho caso, que hace
    mucho que no toco, pero igual le sirve para orientarse (o para perderse más,
    pero ya he avisado).

    Ahora, si con "los otros" se refiere no solo a la red local, puede poner un
    dyndns de esos, y mira... así sería accesible desde dentro también (aunque
    tengan que salir para entrar xD).

    --
    Marcos Ramirez (www.marcos-ramirez.info) .:: Linux Registered User #349823 ::.
    Debian SID Kernel 2.6.10.

    Antes de preguntar nada, lee! y recuerda, Google es tu amigo, yo no.
    http://www.sindominio.net/ayuda/preguntas-inteligentes.html

    No acepto adjuntos en formato WORD/Office:
    http://breu.bulma.net/?l3192
  • Fernando Ortiz at Nov 4, 2005 at 10:47 pm
    Gustavo Narea escribió:

    Gustavo Narea wrote:
    Por cierto, si tienes equipos con GNU/Linux y no quieres usar las
    direcciones IP, puedes editar el archivo /etc/hosts y agregarle una
    línea como esta:
    miserver 128.0.0.1
    Si haces esto, cada vez que accedas al servidor, puedes usar
    http://miserver/ en lugar de http://128.0.0.1. No sé si esto lo
    puedes hacer en Windows.

    Supongo que la única manera de hacerlo es con un servidor DNS.
    En windoze tambien existe el archivo de hosts pero desafortundamente
    cada version a tiene en una ruta diferente:

    *Windows XP* = *C:\WINDOWS\SYSTEM32\DRIVERS\ETC*
    *Windows 2K* = *C:\WINNT\SYSTEM32\DRIVERS\ETC*
    *Win 98/ME* = *C:\WINDOWS*


    Como te dicen, en cada maquina cliente puedes poner el archivos hosts
    con los noombres que requieras.

    Saludos
  • Gustavo Narea at Nov 5, 2005 at 2:37 am
    Hola.

    Fernando Ortiz wrote:
    En windoze tambien existe el archivo de hosts pero desafortundamente
    cada version a tiene en una ruta diferente:

    *Windows XP* = *C:\WINDOWS\SYSTEM32\DRIVERS\ETC*
    *Windows 2K* = *C:\WINNT\SYSTEM32\DRIVERS\ETC*
    *Win 98/ME* = *C:\WINDOWS*
    Interesante. De verdad no lo sabía, ni me lo imaginaba. Yo pensaba que
    sólo lo podía hacer con GNU/Linux.

    Saludos!

    --
    Best regards,

    Gustavo Narea.
    PHP Documentation - Spanish Translation Team.
    Valencia, Venezuela.
  • Gustavo Narea at Nov 5, 2005 at 2:53 am
    Hola a todos.

    Estoy casi seguro de que lo que yo recomendé es para una red
    punto-a-punto *solamente*. Es así?

    No me imagino eso con un servidor y dos equipos más conectados (o más).

    De todos modos, mi especialidad no es la instalación de redes. Eso me lo
    aprendí cuando decidí a cambiarme a GNU/Linux: De esta manera pasé lo
    que tenía en mi computadora a otra computadora que tengo en mi casa
    mediante un cable cruzado. Seguramente hay una manera más "elegante" de
    hacerlo...

    Saludos!

    Gustavo Narea wrote:
    Hola.

    Yo sé una manera de hacerlo, pero te funcionará si lo que quieres es una
    intranet sin acceso a Internet.

    1.- A todas las máquinas, les pones *la misma* máscara de red. Por
    ejemplo: 255.255.0.0. En WinME lo haces en Panel de control > Red. En
    WinXP, Panel de control > Conexiones de Red (si no tienes una conexión,
    la agregas, y si sí tienes una conexión, la modificas).

    2.- A cada máquina le estableces una dirección IP *distinta*. Por
    ejemplo, a la máquina #1 le pones la IP 128.0.0.1, a la máquina #2 le
    pones 128.0.0.2, y así sucesivamente. Esto lo haces en la misma ventana
    donde modificaste la máscara de red.

    3.- Puedes acceder al servidor mediante la dirección IP que le asignaste
    al equipo donde instalaste el servidor. Por ejemplo: http://128.0.0.1/.

    4.- Listo para usar!

    Por cierto, si tienes equipos con GNU/Linux y no quieres usar las
    direcciones IP, puedes editar el archivo /etc/hosts y agregarle una
    línea como esta:
    miserver 128.0.0.1
    Si haces esto, cada vez que accedas al servidor, puedes usar
    http://miserver/ en lugar de http://128.0.0.1. No sé si esto lo puedes
    hacer en Windows.

    Esto lo he probado con computadoras usando Windows ME y XP, sin embargo,
    me parece que debe funcionar en otros sistemas.

    Cuéntame si te funciona!

    Saludos.

    Emiliano Horcada wrote:
    Buenas.
    Formatié una máquina que tenía instalado el wamp (paquete que tiene php,
    apache, mysql y eso), y si bien lo puede instalar nuevamente, como esta
    máquina está en red quiero configurar para que los otros puedan ejecutar
    páginas que están en esta máquina y no lo logré.
    Alguien conoce la configuración?.
    Me parece que tiene que ver con cambiar algun rooteo pero no se que.
    Sigo investigando, si alguien sabe algo y/o conoce este paquete,
    bienvenido
    seran sus comentarios.

    Emiliano J. Horcada
    --
    Best regards,

    Gustavo Narea.
    PHP Documentation - Spanish Translation Team.
    Valencia, Venezuela.
  • Emiliano Horcada at Nov 7, 2005 at 1:48 pm
    Me estoy debanando los sesos y no puedo hacer que esto funcione.
    Les comento lo que hice paso por paso a ver en que me equivoco.
    Tengo una red de 6 máquinas que funciona perfectamente. En una máquina tengo
    un gran directorio a la que las demás acceden para modificar los archivos.
    En esta máquina (que tiene de nombre venecia) quiero instalar php,
    phpmyadmin, mysql y apache claro. Entonces me bajo el paquete wamp (que ya
    lo he usado en otra máquina y me funcionó de maravilla) lo ejecuto,
    selecciono el directorio correcto y listo.
    Lo que ocurre es, en primera instancia, que en mi máquina, es decir en
    venecia, no me emula el php. Es decir que si ejecuto una página que tiene
    simplemente un: "echo 'hola'" no me muestra nada y el código fuente es el
    script.
    Por otro lado, las otras máquinas de la red pueden entrar a la página
    principal del wamp tipeando en el explorador: 'venecia/' pero luego tampoco
    les emula el php y no pueden ver las bases de datos del PHPMyAdmin. El
    PHPMyAdmin se mustra sin estilos y sin los iconos, como si estuviera mal
    direccionado, y de hecho si hago click derecho sobre las imagenes y me fijo
    su ruta encuentro que están mal direccionadas, busca en localhost, es decir,
    busca en la máquina en la que está corriendo la página cuando en realidad
    debería buscar siempre en venecia.
    Se entiende el inconveniente?.
    Para lo que sirva debo decir que estoy en XP y que tengo deshabilitado el
    firewall y todas esas porquerias.

    Que cuerno pasa???.


    Emiliano J. Horcada




    On 11/4/05, Gustavo Narea wrote:

    Hola a todos.

    Estoy casi seguro de que lo que yo recomendé es para una red
    punto-a-punto *solamente*. Es así?

    No me imagino eso con un servidor y dos equipos más conectados (o más).

    De todos modos, mi especialidad no es la instalación de redes. Eso me lo
    aprendí cuando decidí a cambiarme a GNU/Linux: De esta manera pasé lo
    que tenía en mi computadora a otra computadora que tengo en mi casa
    mediante un cable cruzado. Seguramente hay una manera más "elegante" de
    hacerlo...

    Saludos!

    Gustavo Narea wrote:
    Hola.

    Yo sé una manera de hacerlo, pero te funcionará si lo que quieres es una
    intranet sin acceso a Internet.

    1.- A todas las máquinas, les pones *la misma* máscara de red. Por
    ejemplo: 255.255.0.0 <http://255.255.0.0>. En WinME lo haces en Panel de
    control > Red. En
    WinXP, Panel de control > Conexiones de Red (si no tienes una conexión,
    la agregas, y si sí tienes una conexión, la modificas).

    2.- A cada máquina le estableces una dirección IP *distinta*. Por
    ejemplo, a la máquina #1 le pones la IP 128.0.0.1 <http://128.0.0.1>, a
    la máquina #2 le
    pones 128.0.0.2 <http://128.0.0.2>, y así sucesivamente. Esto lo haces
    en la misma ventana
    donde modificaste la máscara de red.

    3.- Puedes acceder al servidor mediante la dirección IP que le asignaste
    al equipo donde instalaste el servidor. Por ejemplo: http://128.0.0.1/.

    4.- Listo para usar!

    Por cierto, si tienes equipos con GNU/Linux y no quieres usar las
    direcciones IP, puedes editar el archivo /etc/hosts y agregarle una
    línea como esta:
    miserver 128.0.0.1 <http://128.0.0.1>
    Si haces esto, cada vez que accedas al servidor, puedes usar
    http://miserver/ en lugar de http://128.0.0.1. No sé si esto lo puedes
    hacer en Windows.

    Esto lo he probado con computadoras usando Windows ME y XP, sin embargo,
    me parece que debe funcionar en otros sistemas.

    Cuéntame si te funciona!

    Saludos.

    Emiliano Horcada wrote:
    Buenas.
    Formatié una máquina que tenía instalado el wamp (paquete que tiene
    php,
    apache, mysql y eso), y si bien lo puede instalar nuevamente, como esta
    máquina está en red quiero configurar para que los otros puedan
    ejecutar
    páginas que están en esta máquina y no lo logré.
    Alguien conoce la configuración?.
    Me parece que tiene que ver con cambiar algun rooteo pero no se que.
    Sigo investigando, si alguien sabe algo y/o conoce este paquete,
    bienvenido
    seran sus comentarios.

    Emiliano J. Horcada
    --
    Best regards,

    Gustavo Narea.
    PHP Documentation - Spanish Translation Team.
    Valencia, Venezuela.

    --
    PHP Spanish Localization Talk Mailing List (http://www.php.net/)
    To unsubscribe, visit: http://www.php.net/unsub.php
  • Emiliano Horcada at Nov 7, 2005 at 1:49 pm
    Aclaro, lo de la emulación del php está solucionado, fue una tontera mia.
    Estaba intentandolo con <? ?> y era necesario poner <?php ?> simplemente. La
    costumbre nomás.
    Los demás problemas persisten.


    Emiliano J. Horcada
    On 11/7/05, Emiliano Horcada wrote:

    Me estoy debanando los sesos y no puedo hacer que esto funcione.
    Les comento lo que hice paso por paso a ver en que me equivoco.
    Tengo una red de 6 máquinas que funciona perfectamente. En una máquina
    tengo un gran directorio a la que las demás acceden para modificar los
    archivos. En esta máquina (que tiene de nombre venecia) quiero instalar php,
    phpmyadmin, mysql y apache claro. Entonces me bajo el paquete wamp (que ya
    lo he usado en otra máquina y me funcionó de maravilla) lo ejecuto,
    selecciono el directorio correcto y listo.
    Lo que ocurre es, en primera instancia, que en mi máquina, es decir en
    venecia, no me emula el php. Es decir que si ejecuto una página que tiene
    simplemente un: "echo 'hola'" no me muestra nada y el código fuente es el
    script.
    Por otro lado, las otras máquinas de la red pueden entrar a la página
    principal del wamp tipeando en el explorador: 'venecia/' pero luego tampoco
    les emula el php y no pueden ver las bases de datos del PHPMyAdmin. El
    PHPMyAdmin se mustra sin estilos y sin los iconos, como si estuviera mal
    direccionado, y de hecho si hago click derecho sobre las imagenes y me fijo
    su ruta encuentro que están mal direccionadas, busca en localhost, es decir,
    busca en la máquina en la que está corriendo la página cuando en realidad
    debería buscar siempre en venecia.
    Se entiende el inconveniente?.
    Para lo que sirva debo decir que estoy en XP y que tengo deshabilitado el
    firewall y todas esas porquerias.

    Que cuerno pasa???.


    Emiliano J. Horcada




    On 11/4/05, Gustavo Narea wrote:

    Hola a todos.

    Estoy casi seguro de que lo que yo recomendé es para una red
    punto-a-punto *solamente*. Es así?

    No me imagino eso con un servidor y dos equipos más conectados (o más).

    De todos modos, mi especialidad no es la instalación de redes. Eso me lo

    aprendí cuando decidí a cambiarme a GNU/Linux: De esta manera pasé lo
    que tenía en mi computadora a otra computadora que tengo en mi casa
    mediante un cable cruzado. Seguramente hay una manera más "elegante" de
    hacerlo...

    Saludos!

    Gustavo Narea wrote:
    Hola.

    Yo sé una manera de hacerlo, pero te funcionará si lo que quieres es una
    intranet sin acceso a Internet.

    1.- A todas las máquinas, les pones *la misma* máscara de red. Por
    ejemplo: 255.255.0.0 <http://255.255.0.0>. En WinME lo haces en Panel
    de control > Red. En
    WinXP, Panel de control > Conexiones de Red (si no tienes una conexión,
    la agregas, y si sí tienes una conexión, la modificas).

    2.- A cada máquina le estableces una dirección IP *distinta*. Por
    ejemplo, a la máquina #1 le pones la IP 128.0.0.1 <http://128.0.0.1>,
    a la máquina #2 le
    pones 128.0.0.2 <http://128.0.0.2>, y así sucesivamente. Esto lo haces
    en la misma ventana
    donde modificaste la máscara de red.

    3.- Puedes acceder al servidor mediante la dirección IP que le asignaste
    al equipo donde instalaste el servidor. Por ejemplo: http://128.0.0.1/ .
    4.- Listo para usar!

    Por cierto, si tienes equipos con GNU/Linux y no quieres usar las
    direcciones IP, puedes editar el archivo /etc/hosts y agregarle una
    línea como esta:
    miserver 128.0.0.1 <http://128.0.0.1>
    Si haces esto, cada vez que accedas al servidor, puedes usar
    http://miserver/ en lugar de http://128.0.0.1. No sé si esto lo puedes
    hacer en Windows.

    Esto lo he probado con computadoras usando Windows ME y XP, sin embargo,
    me parece que debe funcionar en otros sistemas.

    Cuéntame si te funciona!

    Saludos.

    Emiliano Horcada wrote:
    Buenas.
    Formatié una máquina que tenía instalado el wamp (paquete que tiene
    php,
    apache, mysql y eso), y si bien lo puede instalar nuevamente, como
    esta
    máquina está en red quiero configurar para que los otros puedan
    ejecutar
    páginas que están en esta máquina y no lo logré.
    Alguien conoce la configuración?.
    Me parece que tiene que ver con cambiar algun rooteo pero no se que.
    Sigo investigando, si alguien sabe algo y/o conoce este paquete,
    bienvenido
    seran sus comentarios.

    Emiliano J. Horcada
    --
    Best regards,

    Gustavo Narea.
    PHP Documentation - Spanish Translation Team.
    Valencia, Venezuela.

    --
    PHP Spanish Localization Talk Mailing List (http://www.php.net/)
    To unsubscribe, visit: http://www.php.net/unsub.php
  • Eduardo Huertas at Nov 7, 2005 at 4:49 pm

    El 7/11/05, Emiliano Horcada<emilianohorcada@gmail.com> escribió:
    Los demás problemas persisten.
    Me parece que sólo te queda configurar el phpMyAdmin,

    Bueno, vete al directorio del phpMyAdmin y buscas un archivos que se
    llama config.inc.php

    Lo abres, y buscas la linea $cfg['PmaAbsoluteUri'] = ''; (es la linea
    36 más o menos, puede variar).

    En vez de dejarlo en blanco puedes poner http://venecia/phpMyAdmin (o
    el directorio que correponda) y ya deberia funcionarte todo correcto.

    Saludos y suerte
  • Emiliano Horcada at Nov 7, 2005 at 5:03 pm
    Ni más ni menos. Funcionó.
    Gracias!

    Emiliano J. Horcada
    On 11/7/05, Eduardo Huertas wrote:

    El 7/11/05, Emiliano Horcada<emilianohorcada@gmail.com> escribió:
    Los demás problemas persisten.
    Me parece que sólo te queda configurar el phpMyAdmin,

    Bueno, vete al directorio del phpMyAdmin y buscas un archivos que se
    llama config.inc.php

    Lo abres, y buscas la linea $cfg['PmaAbsoluteUri'] = ''; (es la linea
    36 más o menos, puede variar).

    En vez de dejarlo en blanco puedes poner http://venecia/phpMyAdmin (o
    el directorio que correponda) y ya deberia funcionarte todo correcto.

    Saludos y suerte

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-general-es @
categoriesphp
postedNov 4, '05 at 7:12p
activeNov 7, '05 at 5:03p
posts13
users6
websitephp.net

People

Translate

site design / logo © 2021 Grokbase