FAQ
Hola Gente !,

Este es mi primer mensaje a la lista, y probablemente sea un offtopic,
pero necesito ayuda !...

Tengo PHP 4.0.2 instalado sobre apache en un servidor windows 2000
advance server. Todo funciona bien excepto las sesiones. Cuando intento
iniciar una sesion ( session_start() ) me tira el siguiente error :

Warning: open(/tmp\sess_8037822619a7f4d5f730772adf8e661d, O_RDWR)
failed: m (2) in c:\wwwroot\affiliate\nuevo\menu_up.php on line 1

He cambiado 20 veces los settings de la variable session.save_path pero
el error sigue siendo el mismo, como si no estuviera leyendo el php.ini.

Que puedo estar haciendo mal ?... HELP !!!.. muchas gracias !!!

Sebastian

Search Discussions

  • Manuel Fuentes at Jul 12, 2002 at 9:02 pm
    ¿Podrías poner un poco de código fuente del script por favor donde tienes el
    session_start?

    Manuel Fuentes


    Hola Gente !,

    Este es mi primer mensaje a la lista, y probablemente sea un offtopic,
    pero necesito ayuda !...

    Tengo PHP 4.0.2 instalado sobre apache en un servidor windows 2000
    advance server. Todo funciona bien excepto las sesiones. Cuando intento
    iniciar una sesion ( session_start() ) me tira el siguiente error :

    Warning: open(/tmp\sess_8037822619a7f4d5f730772adf8e661d, O_RDWR)
    failed: m (2) in c:\wwwroot\affiliate\nuevo\menu_up.php on line 1

    He cambiado 20 veces los settings de la variable session.save_path pero
    el error sigue siendo el mismo, como si no estuviera leyendo el php.ini.

    Que puedo estar haciendo mal ?... HELP !!!.. muchas gracias !!!

    Sebastian




    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Leonardo Land at Jul 12, 2002 at 9:15 pm
    El script no tiene nada que ver sino que esta directamente ligado a la
    configuración de PHP sobre Windows.. que a mi siempre me pareció (la
    instalacion de apache y php) como ponerle un aleron de formula uno en un
    Escarabajo (en este caso un escarabajo 2000) =P

    Saludos


    On Vie 12 Jul 2002 18:18, Manuel Fuentes wrote:
    ¿Podrías poner un poco de código fuente del script por favor donde tienes el
    session_start?

    Manuel Fuentes


    Hola Gente !,

    Este es mi primer mensaje a la lista, y probablemente sea un offtopic,
    pero necesito ayuda !...

    Tengo PHP 4.0.2 instalado sobre apache en un servidor windows 2000
    advance server. Todo funciona bien excepto las sesiones. Cuando intento
    iniciar una sesion ( session_start() ) me tira el siguiente error :

    Warning: open(/tmp\sess_8037822619a7f4d5f730772adf8e661d, O_RDWR)
    failed: m (2) in c:\wwwroot\affiliate\nuevo\menu_up.php on line 1

    He cambiado 20 veces los settings de la variable session.save_path pero
    el error sigue siendo el mismo, como si no estuviera leyendo el php.ini.

    Que puedo estar haciendo mal ?... HELP !!!.. muchas gracias !!!

    Sebastian




    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com

    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com



    --
    Leonardo Land
    NK Studios S.R.L.
    Crespo 2417 Portero 3 Oficina "c"
    ICQ: 32576212
    Santa Fe - Santa Fe
    Argentina
    54-342-4530322
    www.nkstudios.net
    www.nkhosting.com
  • Sebastian Davicco at Jul 12, 2002 at 9:44 pm
    El script funciona bien, lo que da error es al iniciar la sesion :

    <?php session_start(); ?>

    esa es la primera linea del script, ya que recorda que no tiene que
    haber headers antes de invocar esta funcion.

    Con respecto al PHP.INI trate de hacerlo, pero parece que el modulo de
    apache que carga el php no lee el php.ini. Como puedo verificar si lo
    lee ?, y el caso de que no lo lea, como puedo hacer que lo haga ?

    Alguna otra idea ??



    -----Original Message-----
    From: Leonardo Land
    Sent: Friday, July 12, 2002 2:35 PM
    To: lista@phpes.com
    Subject: Re: [PHP-ES] Problema con Sesiones

    El script no tiene nada que ver sino que esta directamente ligado a la
    configuración de PHP sobre Windows.. que a mi siempre me pareció (la
    instalacion de apache y php) como ponerle un aleron de formula uno en un

    Escarabajo (en este caso un escarabajo 2000) =P

    Saludos


    On Vie 12 Jul 2002 18:18, Manuel Fuentes wrote:
    ¿Podrías poner un poco de código fuente del script por favor donde
    tienes el
    session_start?

    Manuel Fuentes


    Hola Gente !,

    Este es mi primer mensaje a la lista, y probablemente sea un offtopic,
    pero necesito ayuda !...

    Tengo PHP 4.0.2 instalado sobre apache en un servidor windows 2000
    advance server. Todo funciona bien excepto las sesiones. Cuando intento
    iniciar una sesion ( session_start() ) me tira el siguiente error :

    Warning: open(/tmp\sess_8037822619a7f4d5f730772adf8e661d, O_RDWR)
    failed: m (2) in c:\wwwroot\affiliate\nuevo\menu_up.php on line 1

    He cambiado 20 veces los settings de la variable session.save_path pero
    el error sigue siendo el mismo, como si no estuviera leyendo el php.ini.
    Que puedo estar haciendo mal ?... HELP !!!.. muchas gracias !!!

    Sebastian




    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com

    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com



    --
    Leonardo Land
    NK Studios S.R.L.
    Crespo 2417 Portero 3 Oficina "c"
    ICQ: 32576212
    Santa Fe - Santa Fe
    Argentina
    54-342-4530322
    www.nkstudios.net
    www.nkhosting.com



    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Manuel Fuentes at Jul 12, 2002 at 10:24 pm
    Si.... mea culpa. Pensaba que no habias llamado al session_start desde la
    primera línea.

    Puede parecer estupida este consejo, pero... has puesto en el
    session.save_path la ruta completa para entornos windows? c:\tmp por ejemplo

    O lo que es más estupido :) Existe c:\tmp? al iniciar la sesión se crea el
    archivo temporal, pero no el directorio. No se si además te servirá darle
    privilegios de escritura en el directorio a todos los niveles

    Probá a ver,

    Un saludo
    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Sebastian Davicco at Jul 12, 2002 at 10:37 pm
    Tranqui, para nada estupida la apreciacion, pero si me asegure de poner
    la ruta completa y que el folder existiera... pero como te digo, el
    error sigue siendo el mismo despues del cambio, como si no estuviera
    leyendo el php.ini, y para asegurarme que no leyera otro php.ini
    distinto al que yo habia modificado, hice una copia el el folder de
    instalacion de php y otra en winnt/system32.

    Ya no se para donde disparar !!!



    -----Original Message-----
    From: Manuel Fuentes
    Sent: Friday, July 12, 2002 3:40 PM
    To: lista@phpes.com
    Subject: RE: [PHP-ES] Problema con Sesiones

    Si.... mea culpa. Pensaba que no habias llamado al session_start desde
    la
    primera línea.

    Puede parecer estupida este consejo, pero... has puesto en el
    session.save_path la ruta completa para entornos windows? c:\tmp por
    ejemplo

    O lo que es más estupido :) Existe c:\tmp? al iniciar la sesión se crea
    el
    archivo temporal, pero no el directorio. No se si además te servirá
    darle
    privilegios de escritura en el directorio a todos los niveles

    Probá a ver,

    Un saludo
    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com



    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Matias at Jul 12, 2002 at 10:44 pm
    Fijate que el directorio no tenga atributo de solo lectura.
    A mi me paso lo mismo pero en LINUX. Le cambie los permisos al directorio y
    funciono perfectamente.

    Matías



    ----- Original Message -----
    From: "Sebastian Davicco" <sad@neonetcr.com>
    To: <lista@phpes.com>
    Sent: Friday, July 12, 2002 8:55 PM
    Subject: RE: [PHP-ES] Problema con Sesiones

    Tranqui, para nada estupida la apreciacion, pero si me asegure de poner
    la ruta completa y que el folder existiera... pero como te digo, el
    error sigue siendo el mismo despues del cambio, como si no estuviera
    leyendo el php.ini, y para asegurarme que no leyera otro php.ini
    distinto al que yo habia modificado, hice una copia el el folder de
    instalacion de php y otra en winnt/system32.

    Ya no se para donde disparar !!!



    -----Original Message-----
    From: Manuel Fuentes
    Sent: Friday, July 12, 2002 3:40 PM
    To: lista@phpes.com
    Subject: RE: [PHP-ES] Problema con Sesiones

    Si.... mea culpa. Pensaba que no habias llamado al session_start desde
    la
    primera línea.

    Puede parecer estupida este consejo, pero... has puesto en el
    session.save_path la ruta completa para entornos windows? c:\tmp por
    ejemplo

    O lo que es más estupido :) Existe c:\tmp? al iniciar la sesión se crea
    el
    archivo temporal, pero no el directorio. No se si además te servirá
    darle
    privilegios de escritura en el directorio a todos los niveles

    Probá a ver,

    Un saludo
    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com



    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com






    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Sebastian Davicco at Jul 12, 2002 at 11:06 pm
    El problema es que en Windows no tengo forma de definirle permisos a un
    folder, no tengo un CHMOD ni nada por el estilo como para definirle ese
    permiso mas que el Sharing, pero eso es otra cosa, se te ocurre alguna
    manera de verificarle los permisos ?

    -----Original Message-----
    From: Matias
    Sent: Friday, July 12, 2002 3:59 PM
    To: lista@phpes.com
    Subject: Re: [PHP-ES] Problema con Sesiones

    Fijate que el directorio no tenga atributo de solo lectura.
    A mi me paso lo mismo pero en LINUX. Le cambie los permisos al
    directorio y
    funciono perfectamente.

    Matías



    ----- Original Message -----
    From: "Sebastian Davicco" <sad@neonetcr.com>
    To: <lista@phpes.com>
    Sent: Friday, July 12, 2002 8:55 PM
    Subject: RE: [PHP-ES] Problema con Sesiones

    Tranqui, para nada estupida la apreciacion, pero si me asegure de poner
    la ruta completa y que el folder existiera... pero como te digo, el
    error sigue siendo el mismo despues del cambio, como si no estuviera
    leyendo el php.ini, y para asegurarme que no leyera otro php.ini
    distinto al que yo habia modificado, hice una copia el el folder de
    instalacion de php y otra en winnt/system32.

    Ya no se para donde disparar !!!



    -----Original Message-----
    From: Manuel Fuentes
    Sent: Friday, July 12, 2002 3:40 PM
    To: lista@phpes.com
    Subject: RE: [PHP-ES] Problema con Sesiones

    Si.... mea culpa. Pensaba que no habias llamado al session_start desde
    la
    primera línea.

    Puede parecer estupida este consejo, pero... has puesto en el
    session.save_path la ruta completa para entornos windows? c:\tmp por
    ejemplo

    O lo que es más estupido :) Existe c:\tmp? al iniciar la sesión se crea
    el
    archivo temporal, pero no el directorio. No se si además te servirá
    darle
    privilegios de escritura en el directorio a todos los niveles

    Probá a ver,

    Un saludo
    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com



    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com






    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com


    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Julio Herrera - Directo at Jul 12, 2002 at 11:21 pm
    Prueba borrando los dos php.ini y arranca el apache, si te manda un error
    entonces por uno primero, si te rula entonces ese es que tienes que
    modificar si no te rula es por que es el otro y ese es el que debes
    modificar, ahora si al borrar los php.ini te funciona de igual forma el php
    es por que te esta tomando otro, que podria estar en el mismo directorio del
    php, a mi me paso lo mismo hasta que me di cuenta que tomaba el del
    directorio del php. Ahora el directorio debe ser un directorio normal, el
    php es igual que cualquier otro programa en windows, entonces windows le
    permite grabar informacion, yo tengo un XP y me funciona sin problemas las
    sessiones.

    Julio

    ----- Original Message -----
    From: "Sebastian Davicco" <sad@neonetcr.com>
    To: <lista@phpes.com>
    Sent: Friday, July 12, 2002 8:24 PM
    Subject: RE: [PHP-ES] Problema con Sesiones

    El problema es que en Windows no tengo forma de definirle permisos a un
    folder, no tengo un CHMOD ni nada por el estilo como para definirle ese
    permiso mas que el Sharing, pero eso es otra cosa, se te ocurre alguna
    manera de verificarle los permisos ?

    -----Original Message-----
    From: Matias
    Sent: Friday, July 12, 2002 3:59 PM
    To: lista@phpes.com
    Subject: Re: [PHP-ES] Problema con Sesiones

    Fijate que el directorio no tenga atributo de solo lectura.
    A mi me paso lo mismo pero en LINUX. Le cambie los permisos al
    directorio y
    funciono perfectamente.

    Matías



    ----- Original Message -----
    From: "Sebastian Davicco" <sad@neonetcr.com>
    To: <lista@phpes.com>
    Sent: Friday, July 12, 2002 8:55 PM
    Subject: RE: [PHP-ES] Problema con Sesiones

    Tranqui, para nada estupida la apreciacion, pero si me asegure de poner
    la ruta completa y que el folder existiera... pero como te digo, el
    error sigue siendo el mismo despues del cambio, como si no estuviera
    leyendo el php.ini, y para asegurarme que no leyera otro php.ini
    distinto al que yo habia modificado, hice una copia el el folder de
    instalacion de php y otra en winnt/system32.

    Ya no se para donde disparar !!!



    -----Original Message-----
    From: Manuel Fuentes
    Sent: Friday, July 12, 2002 3:40 PM
    To: lista@phpes.com
    Subject: RE: [PHP-ES] Problema con Sesiones

    Si.... mea culpa. Pensaba que no habias llamado al session_start desde
    la
    primera línea.

    Puede parecer estupida este consejo, pero... has puesto en el
    session.save_path la ruta completa para entornos windows? c:\tmp por
    ejemplo

    O lo que es más estupido :) Existe c:\tmp? al iniciar la sesión se crea
    el
    archivo temporal, pero no el directorio. No se si además te servirá
    darle
    privilegios de escritura en el directorio a todos los niveles

    Probá a ver,

    Un saludo
    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com



    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com






    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com


    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com






    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Sebastian Davicco at Jul 12, 2002 at 11:53 pm
    Ok julio, aca hay algo que me asusta... Borre todos los php.ini que
    existian en mi maquina (los busque haciendo un search), pare los
    servicios de apache, los volvi a iniciar y siguio funcionando todo bien.
    Pense que tal vez podia haber quedado algo en memoria (windows suele
    hacer eso), asi que reinicie la maquina y php siguio funcionando. Para
    testear de otra manera, corri la funcion phpinfo(); y para mi sorpresa
    aparece entre otras cosas lo siguiente:

    Configuration File (php.ini) Path c:\winnt

    Busco en ese folder y no esta el php.ini, es mas volvi a hacer un search
    global y el archivo ya no existe en toda la maquina !!!.. Si esto no es
    magia no se que es !!!.. me estoy volviendo loco !!!!!...Alguna otra
    idea ????



    -----Original Message-----
    From: Julio Herrera - Directo
    Sent: Friday, July 12, 2002 4:34 PM
    To: lista@phpes.com
    Subject: Re: [PHP-ES] Problema con Sesiones

    Prueba borrando los dos php.ini y arranca el apache, si te manda un
    error
    entonces por uno primero, si te rula entonces ese es que tienes que
    modificar si no te rula es por que es el otro y ese es el que debes
    modificar, ahora si al borrar los php.ini te funciona de igual forma el
    php
    es por que te esta tomando otro, que podria estar en el mismo directorio
    del
    php, a mi me paso lo mismo hasta que me di cuenta que tomaba el del
    directorio del php. Ahora el directorio debe ser un directorio normal,
    el
    php es igual que cualquier otro programa en windows, entonces windows le
    permite grabar informacion, yo tengo un XP y me funciona sin problemas
    las
    sessiones.

    Julio

    ----- Original Message -----
    From: "Sebastian Davicco" <sad@neonetcr.com>
    To: <lista@phpes.com>
    Sent: Friday, July 12, 2002 8:24 PM
    Subject: RE: [PHP-ES] Problema con Sesiones

    El problema es que en Windows no tengo forma de definirle permisos a un
    folder, no tengo un CHMOD ni nada por el estilo como para definirle ese
    permiso mas que el Sharing, pero eso es otra cosa, se te ocurre alguna
    manera de verificarle los permisos ?

    -----Original Message-----
    From: Matias
    Sent: Friday, July 12, 2002 3:59 PM
    To: lista@phpes.com
    Subject: Re: [PHP-ES] Problema con Sesiones

    Fijate que el directorio no tenga atributo de solo lectura.
    A mi me paso lo mismo pero en LINUX. Le cambie los permisos al
    directorio y
    funciono perfectamente.

    Matías



    ----- Original Message -----
    From: "Sebastian Davicco" <sad@neonetcr.com>
    To: <lista@phpes.com>
    Sent: Friday, July 12, 2002 8:55 PM
    Subject: RE: [PHP-ES] Problema con Sesiones

    Tranqui, para nada estupida la apreciacion, pero si me asegure de poner
    la ruta completa y que el folder existiera... pero como te digo, el
    error sigue siendo el mismo despues del cambio, como si no estuviera
    leyendo el php.ini, y para asegurarme que no leyera otro php.ini
    distinto al que yo habia modificado, hice una copia el el folder de
    instalacion de php y otra en winnt/system32.

    Ya no se para donde disparar !!!



    -----Original Message-----
    From: Manuel Fuentes
    Sent: Friday, July 12, 2002 3:40 PM
    To: lista@phpes.com
    Subject: RE: [PHP-ES] Problema con Sesiones

    Si.... mea culpa. Pensaba que no habias llamado al session_start
    desde
    la
    primera línea.

    Puede parecer estupida este consejo, pero... has puesto en el
    session.save_path la ruta completa para entornos windows? c:\tmp por
    ejemplo

    O lo que es más estupido :) Existe c:\tmp? al iniciar la sesión se crea
    el
    archivo temporal, pero no el directorio. No se si además te servirá
    darle
    privilegios de escritura en el directorio a todos los niveles

    Probá a ver,

    Un saludo
    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com


    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com





    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com


    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com






    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com

    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Andres Ferrando at Jul 15, 2002 at 3:11 pm
    es el path donde está confiigurado el php para buscarlo, si no lo
    encuentra, no lo usa, y listo!
    Ok julio, aca hay algo que me asusta... Borre todos los php.ini que
    existian en mi maquina (los busque haciendo un search), pare los
    servicios de apache, los volvi a iniciar y siguio funcionando todo bien.
    Pense que tal vez podia haber quedado algo en memoria (windows suele
    hacer eso), asi que reinicie la maquina y php siguio funcionando. Para
    testear de otra manera, corri la funcion phpinfo(); y para mi sorpresa
    aparece entre otras cosas lo siguiente:

    Configuration File (php.ini) Path c:\winnt

    Busco en ese folder y no esta el php.ini, es mas volvi a hacer un search
    global y el archivo ya no existe en toda la maquina !!!.. Si esto no es
    magia no se que es !!!.. me estoy volviendo loco !!!!!...Alguna otra
    idea ????
    --
    Andres Ferrando <anferr@mecon.gov.ar>
  • Nachoramos at Jul 13, 2002 at 5:00 pm
    Dispara hacia LAMP


    Antiguaguate.com


    Mensaje citado por Sebastian Davicco <sad@neonetcr.com>:
    Tranqui, para nada estupida la apreciacion, pero si me asegure de poner
    la ruta completa y que el folder existiera... pero como te digo, el
    error sigue siendo el mismo despues del cambio, como si no estuviera
    leyendo el php.ini, y para asegurarme que no leyera otro php.ini
    distinto al que yo habia modificado, hice una copia el el folder de
    instalacion de php y otra en winnt/system32.

    Ya no se para donde disparar !!!


    -----Original Message-----
    From: Manuel Fuentes
    Sent: Friday, July 12, 2002 3:40 PM
    To: lista@phpes.com
    Subject: RE: [PHP-ES] Problema con Sesiones

    Si.... mea culpa. Pensaba que no habias llamado al session_start desde
    la
    primera línea.

    Puede parecer estupida este consejo, pero... has puesto en el
    session.save_path la ruta completa para entornos windows? c:\tmp por
    ejemplo

    O lo que es más estupido :) Existe c:\tmp? al iniciar la sesión se crea
    el
    archivo temporal, pero no el directorio. No se si además te servirá
    darle
    privilegios de escritura en el directorio a todos los niveles

    Probá a ver,

    Un saludo
    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com



    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com






    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com
  • Leonardo Land at Jul 12, 2002 at 9:13 pm
    Hola!

    En el php.ini hay una sección sobre sesiones donde debés especificar el PATH
    donde debe almacenar las sesiones... deberías cambiarlo a la ubicación de tu
    directorio temporal, como por ejemplo c:\temp/.

    Saludos!!


    On Vie 12 Jul 2002 19:14, Sebastian Davicco wrote:
    Hola Gente !,

    Este es mi primer mensaje a la lista, y probablemente sea un offtopic,
    pero necesito ayuda !...

    Tengo PHP 4.0.2 instalado sobre apache en un servidor windows 2000
    advance server. Todo funciona bien excepto las sesiones. Cuando intento
    iniciar una sesion ( session_start() ) me tira el siguiente error :

    Warning: open(/tmp\sess_8037822619a7f4d5f730772adf8e661d, O_RDWR)
    failed: m (2) in c:\wwwroot\affiliate\nuevo\menu_up.php on line 1

    He cambiado 20 veces los settings de la variable session.save_path pero
    el error sigue siendo el mismo, como si no estuviera leyendo el php.ini.

    Que puedo estar haciendo mal ?... HELP !!!.. muchas gracias !!!

    Sebastian




    ---------------------------------------------------------------------
    Archivo On-line: http://www.phpes.com/
    via news: news://news.phpes.com/
    Manual PHP en español: http://www.php.net/manual/es/
    Para dar de baja la suscripción, mande un mensaje a:
    lista-unsubscribe@phpes.com



    --
    Leonardo Land
    NK Studios S.R.L.
    Crespo 2417 Portero 3 Oficina "c"
    ICQ: 32576212
    Santa Fe - Santa Fe
    Argentina
    54-342-4530322
    www.nkstudios.net
    www.nkhosting.com

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-general-es @
categoriesphp
postedJul 12, '02 at 8:56p
activeJul 15, '02 at 3:11p
posts13
users7
websitephp.net

People

Translate

site design / logo © 2022 Grokbase