FAQ
Hi!

I sent some contributions to italian documentation via edit.php.net logging
with my Google account. I want to continue to work on italian traslation of
the doc.

I've correctly downloaded files via svn without problems (I used it in
other projects), but I need help to install PhD. I tried:

$ sudo pear install doc.php.net/PhD
>

and variants (--all-deps, --onlyreqdeps) but it says:

phpdocs/PhD requires PHP extension "sqlite3"
phpdocs/PhD can optionally use package "phpdocs/PhD_PHP"
phpdocs/PhD can optionally use package "phpdocs/PhD_PEAR"
phpdocs/PhD can optionally use package "phpdocs/PhD_IDE"
phpdocs/PhD can optionally use PHP extension "posix"
phpdocs/PhD can optionally use PHP extension "haru"
phpdocs/PhD_Generic requires package "phpdocs/PhD" (version >= 0.9.0)
phpdocs/PhD_Generic can optionally use PHP extension "haru"
No valid packages found
install failed

so I thought that the problem was sqlite3 extension that is not installed,
therefore I tried to install it with pecl, but I got a lot of C compilation
errors.

What's wrong?


Thank you :)


Federico Reghenzani

Search Discussions

  • Hannes Magnusson at Mar 25, 2014 at 4:51 pm

    On Tue, Mar 25, 2014 at 8:29 AM, Federico Reghenzani wrote:
    Hi!

    I sent some contributions to italian documentation via edit.php.net logging
    with my Google account. I want to continue to work on italian traslation of
    the doc.

    I've correctly downloaded files via svn without problems (I used it in other
    projects), but I need help to install PhD. I tried:
    $ sudo pear install doc.php.net/PhD

    and variants (--all-deps, --onlyreqdeps) but it says:
    phpdocs/PhD requires PHP extension "sqlite3"
    phpdocs/PhD can optionally use package "phpdocs/PhD_PHP"
    phpdocs/PhD can optionally use package "phpdocs/PhD_PEAR"
    phpdocs/PhD can optionally use package "phpdocs/PhD_IDE"
    phpdocs/PhD can optionally use PHP extension "posix"
    phpdocs/PhD can optionally use PHP extension "haru"
    phpdocs/PhD_Generic requires package "phpdocs/PhD" (version >= 0.9.0)
    phpdocs/PhD_Generic can optionally use PHP extension "haru"
    No valid packages found
    install failed

    so I thought that the problem was sqlite3 extension that is not installed,
    therefore I tried to install it with pecl, but I got a lot of C compilation
    errors.

    What's wrong?

    The pecl/sqlite3 extension is not maintained. You need the sqlite3
    extension that comes with PHP.

    Depending on how you installed PHP, you either need to recompile it
    with --with-sqlite3 or if you installed it via your distro you can
    "apt-get/yum install php-sqlite3" or something similar.

    -Hannes

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-doc @
categoriesphp
postedMar 25, '14 at 3:29p
activeMar 25, '14 at 4:51p
posts2
users2
websitedoc.php.net

People

Translate

site design / logo © 2019 Grokbase