FAQ
From: nandesu at gmail dot com
Operating system: SuSE Enterprise 9
PHP version: 4.4.0
PHP Bug Type: Compile Failure
Bug description: configure: error: The pfpro extension requires version 2 or 3 of the SDK

Description:
------------
PHP-4.4.0 will not even configure with verisign's PayFlowPro
on SuSE Linux Enterprise 9. However, it works just fine (exact
same tarballs) in Slackware-10.x.

Reproduce code:
---------------
./configure --with-apxs=/usr/local/apache/bin/apxs --enable-bcmath
--with-curl --with-mysql=/usr/local/mysql --with-mcrypt=/usr/local/lib
--with-openssl=/usr/local/ssl --without-pear --disable-cgi --with-gd
--with-zlib --with-jpeg-dir=/usr/local/lib --with-pfpro --enable-xml

Expected result:
----------------
I expect it to read:
checking for pfproInit in -lpfpro... yes
So I can go on about my life. ~grins

Actual result:
--------------
checking for Verisign Payflow Pro support... yes
checking for pfproInit in -lpfpro... no
checking for PNInit in -lpfpro... no
configure: error: The pfpro extension requires version 2 or 3
of the SDK

Search Discussions

  • Johannes at Oct 1, 2005 at 8:30 am
    ID: 34696
    Updated by: johannes@php.net
    Reported By: nandesu at gmail dot com
    -Status: Open
    +Status: Feedback
    Bug Type: Compile Failure
    Operating System: SuSE Enterprise 9
    PHP Version: 4.4.0
    New Comment:

    Please try using this CVS snapshot:

    http://snaps.php.net/php4-STABLE-latest.tar.gz

    For Windows:

    http://snaps.php.net/win32/php4-win32-STABLE-latest.zip


    Previous Comments:
    ------------------------------------------------------------------------

    [2005-10-01 01:03:07] nandesu at gmail dot com

    Description:
    ------------
    PHP-4.4.0 will not even configure with verisign's PayFlowPro
    on SuSE Linux Enterprise 9. However, it works just fine (exact
    same tarballs) in Slackware-10.x.

    Reproduce code:
    ---------------
    ./configure --with-apxs=/usr/local/apache/bin/apxs --enable-bcmath
    --with-curl --with-mysql=/usr/local/mysql --with-mcrypt=/usr/local/lib
    --with-openssl=/usr/local/ssl --without-pear --disable-cgi --with-gd
    --with-zlib --with-jpeg-dir=/usr/local/lib --with-pfpro --enable-xml

    Expected result:
    ----------------
    I expect it to read:
    checking for pfproInit in -lpfpro... yes
    So I can go on about my life. ~grins

    Actual result:
    --------------
    checking for Verisign Payflow Pro support... yes
    checking for pfproInit in -lpfpro... no
    checking for PNInit in -lpfpro... no
    configure: error: The pfpro extension requires version 2 or 3
    of the SDK


    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=34696&edit=1
  • Nandesu at gmail dot com at Oct 1, 2005 at 5:11 pm
    ID: 34696
    User updated by: nandesu at gmail dot com
    Reported By: nandesu at gmail dot com
    -Status: Feedback
    +Status: Open
    Bug Type: Compile Failure
    Operating System: SuSE Enterprise 9
    PHP Version: 4.4.0
    New Comment:

    Still bombs at the same spot.
    I have the files pfpro.h and libpfpro.so copied to /usr/local/
    lib and /usr/local/include respectively. I have also tried
    pointing to my verisign untared location. (i.e., --pfpro=/
    usr/local/verisign/payflowpro/linux) and still not a go.

    Any other suggestions are greatly appreciated!


    Previous Comments:
    ------------------------------------------------------------------------

    [2005-10-01 10:30:23] johannes@php.net

    Please try using this CVS snapshot:

    http://snaps.php.net/php4-STABLE-latest.tar.gz

    For Windows:

    http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

    ------------------------------------------------------------------------

    [2005-10-01 01:03:07] nandesu at gmail dot com

    Description:
    ------------
    PHP-4.4.0 will not even configure with verisign's PayFlowPro
    on SuSE Linux Enterprise 9. However, it works just fine (exact
    same tarballs) in Slackware-10.x.

    Reproduce code:
    ---------------
    ./configure --with-apxs=/usr/local/apache/bin/apxs --enable-bcmath
    --with-curl --with-mysql=/usr/local/mysql --with-mcrypt=/usr/local/lib
    --with-openssl=/usr/local/ssl --without-pear --disable-cgi --with-gd
    --with-zlib --with-jpeg-dir=/usr/local/lib --with-pfpro --enable-xml

    Expected result:
    ----------------
    I expect it to read:
    checking for pfproInit in -lpfpro... yes
    So I can go on about my life. ~grins

    Actual result:
    --------------
    checking for Verisign Payflow Pro support... yes
    checking for pfproInit in -lpfpro... no
    checking for PNInit in -lpfpro... no
    configure: error: The pfpro extension requires version 2 or 3
    of the SDK


    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=34696&edit=1
  • Sniper at Oct 1, 2005 at 10:16 pm
    ID: 34696
    Updated by: sniper@php.net
    Reported By: nandesu at gmail dot com
    -Status: Open
    +Status: Bogus
    Bug Type: Compile Failure
    Operating System: SuSE Enterprise 9
    PHP Version: 4.4.0
    New Comment:

    Passing path with /lib in it to any PHP configure option is not
    supported. f.e. --with-mcrypt=/usr/local/lib is wrong.
    Try with this configure line:

    # rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    If that doesn't work, reopen.



    Previous Comments:
    ------------------------------------------------------------------------

    [2005-10-01 19:11:39] nandesu at gmail dot com

    Still bombs at the same spot.
    I have the files pfpro.h and libpfpro.so copied to /usr/local/
    lib and /usr/local/include respectively. I have also tried
    pointing to my verisign untared location. (i.e., --pfpro=/
    usr/local/verisign/payflowpro/linux) and still not a go.

    Any other suggestions are greatly appreciated!

    ------------------------------------------------------------------------

    [2005-10-01 10:30:23] johannes@php.net

    Please try using this CVS snapshot:

    http://snaps.php.net/php4-STABLE-latest.tar.gz

    For Windows:

    http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

    ------------------------------------------------------------------------

    [2005-10-01 01:03:07] nandesu at gmail dot com

    Description:
    ------------
    PHP-4.4.0 will not even configure with verisign's PayFlowPro
    on SuSE Linux Enterprise 9. However, it works just fine (exact
    same tarballs) in Slackware-10.x.

    Reproduce code:
    ---------------
    ./configure --with-apxs=/usr/local/apache/bin/apxs --enable-bcmath
    --with-curl --with-mysql=/usr/local/mysql --with-mcrypt=/usr/local/lib
    --with-openssl=/usr/local/ssl --without-pear --disable-cgi --with-gd
    --with-zlib --with-jpeg-dir=/usr/local/lib --with-pfpro --enable-xml

    Expected result:
    ----------------
    I expect it to read:
    checking for pfproInit in -lpfpro... yes
    So I can go on about my life. ~grins

    Actual result:
    --------------
    checking for Verisign Payflow Pro support... yes
    checking for pfproInit in -lpfpro... no
    checking for PNInit in -lpfpro... no
    configure: error: The pfpro extension requires version 2 or 3
    of the SDK


    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=34696&edit=1
  • Nandesu at gmail dot com at Oct 2, 2005 at 2:43 am
    ID: 34696
    User updated by: nandesu at gmail dot com
    Reported By: nandesu at gmail dot com
    -Status: Bogus
    +Status: Open
    Bug Type: Compile Failure
    Operating System: SuSE Enterprise 9
    PHP Version: 4.4.0
    New Comment:

    rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    Still bombs out at the same spot in php-4.4.0, php-4.3.10,
    php-4.3.11, and php4-STABLE-200510011444.

    I don't understand what is so different about SuSE
    Enterprise 9 (x86) that would cause this.

    Any new suggestions are greatly appreciated.


    Previous Comments:
    ------------------------------------------------------------------------

    [2005-10-02 00:16:02] sniper@php.net

    Passing path with /lib in it to any PHP configure option is not
    supported. f.e. --with-mcrypt=/usr/local/lib is wrong.
    Try with this configure line:

    # rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    If that doesn't work, reopen.


    ------------------------------------------------------------------------

    [2005-10-01 19:11:39] nandesu at gmail dot com

    Still bombs at the same spot.
    I have the files pfpro.h and libpfpro.so copied to /usr/local/
    lib and /usr/local/include respectively. I have also tried
    pointing to my verisign untared location. (i.e., --pfpro=/
    usr/local/verisign/payflowpro/linux) and still not a go.

    Any other suggestions are greatly appreciated!

    ------------------------------------------------------------------------

    [2005-10-01 10:30:23] johannes@php.net

    Please try using this CVS snapshot:

    http://snaps.php.net/php4-STABLE-latest.tar.gz

    For Windows:

    http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

    ------------------------------------------------------------------------

    [2005-10-01 01:03:07] nandesu at gmail dot com

    Description:
    ------------
    PHP-4.4.0 will not even configure with verisign's PayFlowPro
    on SuSE Linux Enterprise 9. However, it works just fine (exact
    same tarballs) in Slackware-10.x.

    Reproduce code:
    ---------------
    ./configure --with-apxs=/usr/local/apache/bin/apxs --enable-bcmath
    --with-curl --with-mysql=/usr/local/mysql --with-mcrypt=/usr/local/lib
    --with-openssl=/usr/local/ssl --without-pear --disable-cgi --with-gd
    --with-zlib --with-jpeg-dir=/usr/local/lib --with-pfpro --enable-xml

    Expected result:
    ----------------
    I expect it to read:
    checking for pfproInit in -lpfpro... yes
    So I can go on about my life. ~grins

    Actual result:
    --------------
    checking for Verisign Payflow Pro support... yes
    checking for pfproInit in -lpfpro... no
    checking for PNInit in -lpfpro... no
    configure: error: The pfpro extension requires version 2 or 3
    of the SDK


    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=34696&edit=1
  • Sniper at Oct 2, 2005 at 11:01 am
    ID: 34696
    Updated by: sniper@php.net
    Reported By: nandesu at gmail dot com
    -Status: Open
    +Status: Feedback
    Bug Type: Compile Failure
    Operating System: SuSE Enterprise 9
    PHP Version: 4.4.0
    New Comment:

    What can you find in config.log when this happens??



    Previous Comments:
    ------------------------------------------------------------------------

    [2005-10-02 04:43:38] nandesu at gmail dot com

    rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    Still bombs out at the same spot in php-4.4.0, php-4.3.10,
    php-4.3.11, and php4-STABLE-200510011444.

    I don't understand what is so different about SuSE
    Enterprise 9 (x86) that would cause this.

    Any new suggestions are greatly appreciated.

    ------------------------------------------------------------------------

    [2005-10-02 00:16:02] sniper@php.net

    Passing path with /lib in it to any PHP configure option is not
    supported. f.e. --with-mcrypt=/usr/local/lib is wrong.
    Try with this configure line:

    # rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    If that doesn't work, reopen.


    ------------------------------------------------------------------------

    [2005-10-01 19:11:39] nandesu at gmail dot com

    Still bombs at the same spot.
    I have the files pfpro.h and libpfpro.so copied to /usr/local/
    lib and /usr/local/include respectively. I have also tried
    pointing to my verisign untared location. (i.e., --pfpro=/
    usr/local/verisign/payflowpro/linux) and still not a go.

    Any other suggestions are greatly appreciated!

    ------------------------------------------------------------------------

    [2005-10-01 10:30:23] johannes@php.net

    Please try using this CVS snapshot:

    http://snaps.php.net/php4-STABLE-latest.tar.gz

    For Windows:

    http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

    ------------------------------------------------------------------------

    [2005-10-01 01:03:07] nandesu at gmail dot com

    Description:
    ------------
    PHP-4.4.0 will not even configure with verisign's PayFlowPro
    on SuSE Linux Enterprise 9. However, it works just fine (exact
    same tarballs) in Slackware-10.x.

    Reproduce code:
    ---------------
    ./configure --with-apxs=/usr/local/apache/bin/apxs --enable-bcmath
    --with-curl --with-mysql=/usr/local/mysql --with-mcrypt=/usr/local/lib
    --with-openssl=/usr/local/ssl --without-pear --disable-cgi --with-gd
    --with-zlib --with-jpeg-dir=/usr/local/lib --with-pfpro --enable-xml

    Expected result:
    ----------------
    I expect it to read:
    checking for pfproInit in -lpfpro... yes
    So I can go on about my life. ~grins

    Actual result:
    --------------
    checking for Verisign Payflow Pro support... yes
    checking for pfproInit in -lpfpro... no
    checking for PNInit in -lpfpro... no
    configure: error: The pfpro extension requires version 2 or 3
    of the SDK


    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=34696&edit=1
  • Nandesu at gmail dot com at Oct 3, 2005 at 3:42 am
    ID: 34696
    User updated by: nandesu at gmail dot com
    Reported By: nandesu at gmail dot com
    -Status: Feedback
    +Status: Open
    Bug Type: Compile Failure
    Operating System: SuSE Enterprise 9
    PHP Version: 4.4.0
    New Comment:

    Is it possible it's the version of GCC or glib that is being
    used on SuSE? (gcc version 3.3.3 (SuSE Linux))

    Here's the end of config.log where that error is occurring:

    configure:76326: checking for Verisign Payflow Pro support
    configure:76486: checking for pfproInit in -lpfpro
    configure:76505: gcc -o conftest -g -O2 -Wl,-rpath,/usr/
    local/lib -L/usr/local/lib conftest.c -lpfpro -lresolv
    -lm -ldl -lnsl 1>&5
    /usr/local/lib/libpfpro.so: undefined reference to
    `__ctype_b'
    /usr/local/lib/libpfpro.so: undefined reference to
    `__ctype_tolower'
    collect2: ld returned 1 exit status
    configure: failed program was:
    #line 76494 "configure"
    #include "confdefs.h"
    /* Override any gcc2 internal prototype to avoid an error.
    */
    /* We use char because int might match the return type of a
    gcc2
    builtin and then its argument prototype would still
    apply. */
    char pfproInit();

    int main() {
    pfproInit()
    ; return 0; }
    configure:76615: checking for PNInit in -lpfpro
    configure:76634: gcc -o conftest -g -O2 -Wl,-rpath,/usr/
    local/lib -L/usr/local/lib conftest.c -lpfpro -lresolv
    -lm -ldl -lnsl 1>&5
    /usr/local/lib/libpfpro.so: undefined reference to
    `__ctype_b'
    /usr/local/lib/libpfpro.so: undefined reference to
    `__ctype_tolower'
    collect2: ld returned 1 exit status
    configure: failed program was:
    #line 76623 "configure"
    #include "confdefs.h"
    /* Override any gcc2 internal prototype to avoid an error.
    */
    /* We use char because int might match the return type of a
    gcc2
    builtin and then its argument prototype would still
    apply. */
    char PNInit();

    int main() {
    PNInit()
    ; return 0; }


    Previous Comments:
    ------------------------------------------------------------------------

    [2005-10-02 13:01:39] sniper@php.net

    What can you find in config.log when this happens??


    ------------------------------------------------------------------------

    [2005-10-02 04:43:38] nandesu at gmail dot com

    rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    Still bombs out at the same spot in php-4.4.0, php-4.3.10,
    php-4.3.11, and php4-STABLE-200510011444.

    I don't understand what is so different about SuSE
    Enterprise 9 (x86) that would cause this.

    Any new suggestions are greatly appreciated.

    ------------------------------------------------------------------------

    [2005-10-02 00:16:02] sniper@php.net

    Passing path with /lib in it to any PHP configure option is not
    supported. f.e. --with-mcrypt=/usr/local/lib is wrong.
    Try with this configure line:

    # rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    If that doesn't work, reopen.


    ------------------------------------------------------------------------

    [2005-10-01 19:11:39] nandesu at gmail dot com

    Still bombs at the same spot.
    I have the files pfpro.h and libpfpro.so copied to /usr/local/
    lib and /usr/local/include respectively. I have also tried
    pointing to my verisign untared location. (i.e., --pfpro=/
    usr/local/verisign/payflowpro/linux) and still not a go.

    Any other suggestions are greatly appreciated!

    ------------------------------------------------------------------------

    [2005-10-01 10:30:23] johannes@php.net

    Please try using this CVS snapshot:

    http://snaps.php.net/php4-STABLE-latest.tar.gz

    For Windows:

    http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/34696

    --
    Edit this bug report at http://bugs.php.net/?id=34696&edit=1
  • Sniper at Oct 3, 2005 at 5:08 am
    ID: 34696
    Updated by: sniper@php.net
    Reported By: nandesu at gmail dot com
    -Status: Open
    +Status: Bogus
    Bug Type: Compile Failure
    Operating System: SuSE Enterprise 9
    PHP Version: 4.4.0
    New Comment:

    No idea if it's GCC issue or not, but complain to SuSE, this is not PHP
    bug.



    Previous Comments:
    ------------------------------------------------------------------------

    [2005-10-03 05:41:50] nandesu at gmail dot com

    Is it possible it's the version of GCC or glib that is being
    used on SuSE? (gcc version 3.3.3 (SuSE Linux))

    Here's the end of config.log where that error is occurring:

    configure:76326: checking for Verisign Payflow Pro support
    configure:76486: checking for pfproInit in -lpfpro
    configure:76505: gcc -o conftest -g -O2 -Wl,-rpath,/usr/
    local/lib -L/usr/local/lib conftest.c -lpfpro -lresolv
    -lm -ldl -lnsl 1>&5
    /usr/local/lib/libpfpro.so: undefined reference to
    `__ctype_b'
    /usr/local/lib/libpfpro.so: undefined reference to
    `__ctype_tolower'
    collect2: ld returned 1 exit status
    configure: failed program was:
    #line 76494 "configure"
    #include "confdefs.h"
    /* Override any gcc2 internal prototype to avoid an error.
    */
    /* We use char because int might match the return type of a
    gcc2
    builtin and then its argument prototype would still
    apply. */
    char pfproInit();

    int main() {
    pfproInit()
    ; return 0; }
    configure:76615: checking for PNInit in -lpfpro
    configure:76634: gcc -o conftest -g -O2 -Wl,-rpath,/usr/
    local/lib -L/usr/local/lib conftest.c -lpfpro -lresolv
    -lm -ldl -lnsl 1>&5
    /usr/local/lib/libpfpro.so: undefined reference to
    `__ctype_b'
    /usr/local/lib/libpfpro.so: undefined reference to
    `__ctype_tolower'
    collect2: ld returned 1 exit status
    configure: failed program was:
    #line 76623 "configure"
    #include "confdefs.h"
    /* Override any gcc2 internal prototype to avoid an error.
    */
    /* We use char because int might match the return type of a
    gcc2
    builtin and then its argument prototype would still
    apply. */
    char PNInit();

    int main() {
    PNInit()
    ; return 0; }

    ------------------------------------------------------------------------

    [2005-10-02 13:01:39] sniper@php.net

    What can you find in config.log when this happens??


    ------------------------------------------------------------------------

    [2005-10-02 04:43:38] nandesu at gmail dot com

    rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    Still bombs out at the same spot in php-4.4.0, php-4.3.10,
    php-4.3.11, and php4-STABLE-200510011444.

    I don't understand what is so different about SuSE
    Enterprise 9 (x86) that would cause this.

    Any new suggestions are greatly appreciated.

    ------------------------------------------------------------------------

    [2005-10-02 00:16:02] sniper@php.net

    Passing path with /lib in it to any PHP configure option is not
    supported. f.e. --with-mcrypt=/usr/local/lib is wrong.
    Try with this configure line:

    # rm config.cache && ./configure --disable-all --disable-cgi
    --with-pfpro

    If that doesn't work, reopen.


    ------------------------------------------------------------------------

    [2005-10-01 19:11:39] nandesu at gmail dot com

    Still bombs at the same spot.
    I have the files pfpro.h and libpfpro.so copied to /usr/local/
    lib and /usr/local/include respectively. I have also tried
    pointing to my verisign untared location. (i.e., --pfpro=/
    usr/local/verisign/payflowpro/linux) and still not a go.

    Any other suggestions are greatly appreciated!

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://bugs.php.net/34696

    --
    Edit this bug report at http://bugs.php.net/?id=34696&edit=1

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-bugs @
categoriesphp
postedSep 30, '05 at 11:03p
activeOct 3, '05 at 5:08a
posts8
users3
websitephp.net

People

Translate

site design / logo © 2022 Grokbase