FAQ
From: peter at guts dot nl
Operating system: FreeBSD
PHP version: 4.3.2
PHP Bug Type: Compile Failure
Bug description: pfpro module requires -pthread on FreeBSD

Description:
------------
running configure --with-pfpro on FreeBSD reports 'need SDK 2 or 3'. The
SDK I downloaded was version 3. config.log showed linking errors regarding
pthread.

CFLAGS=pthread ./configure .... worked.

Reproduce code:
---------------
run ./configure --with-pfpro=/path/to/lib on FreeBSD

Expected result:
----------------
configure running without errors

Actual result:
--------------
configure reporting that SDK 2 or 3 is required.

Search Discussions

  • Peter at guts dot nl at Aug 8, 2003 at 10:43 am
    ID: 24983
    User updated by: peter at guts dot nl
    Reported By: peter at guts dot nl
    Status: Open
    Bug Type: Compile Failure
    Operating System: FreeBSD
    PHP Version: 4.3.2
    New Comment:

    I meant 'CFLAGS=-pthread'


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-08-08 05:25:10] peter at guts dot nl

    Description:
    ------------
    running configure --with-pfpro on FreeBSD reports 'need SDK 2 or 3'.
    The SDK I downloaded was version 3. config.log showed linking errors
    regarding pthread.

    CFLAGS=pthread ./configure .... worked.

    Reproduce code:
    ---------------
    run ./configure --with-pfpro=/path/to/lib on FreeBSD

    Expected result:
    ----------------
    configure running without errors

    Actual result:
    --------------
    configure reporting that SDK 2 or 3 is required.


    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=24983&edit=1
  • Sniper at Aug 13, 2003 at 10:33 am
    ID: 24983
    Updated by: sniper@php.net
    Reported By: peter at guts dot nl
    -Status: Open
    +Status: Wont fix
    Bug Type: Verisign Payflow Pro related
    Operating System: FreeBSD
    PHP Version: 4.3.2
    New Comment:

    As you can easily workaround this, we're not going to waste any time
    trying to add some hacks around it.


    Previous Comments:
    ------------------------------------------------------------------------

    [2003-08-08 05:42:59] peter at guts dot nl

    I meant 'CFLAGS=-pthread'

    ------------------------------------------------------------------------

    [2003-08-08 05:25:10] peter at guts dot nl

    Description:
    ------------
    running configure --with-pfpro on FreeBSD reports 'need SDK 2 or 3'.
    The SDK I downloaded was version 3. config.log showed linking errors
    regarding pthread.

    CFLAGS=pthread ./configure .... worked.

    Reproduce code:
    ---------------
    run ./configure --with-pfpro=/path/to/lib on FreeBSD

    Expected result:
    ----------------
    configure running without errors

    Actual result:
    --------------
    configure reporting that SDK 2 or 3 is required.


    ------------------------------------------------------------------------


    --
    Edit this bug report at http://bugs.php.net/?id=24983&edit=1

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupphp-bugs @
categoriesphp
postedAug 8, '03 at 10:25a
activeAug 13, '03 at 10:33a
posts3
users2
websitephp.net

2 users in discussion

Peter at guts dot nl: 2 posts Sniper: 1 post

People

Translate

site design / logo © 2022 Grokbase