FAQ
Hi guys,

Found 163 packages with only package xml v1 format in latest release
Just in case anyone was interested, as most people should know by now,
pyrus will not be able to install v1 packages - not a big deal atm
since we don't even have a alpha out of pyrus but well - still good
practice to upgrade the packages.

I know that some of the packages in this list have a release pending,
archive_tar for example but if someone wants to just play around with
this list then it would be good but perhaps not email every single
maintainer :-)

First step is probably to find out which one of these is not
maintained and which is superseeded and such, I can probably pull that
off in my script if there is interest.

Archive_Tar
Archive_Zip
Auth_PrefManager2
Contact_Vcard_Build
Contact_Vcard_Parse
Crypt_HMAC
Crypt_RC4
Crypt_RSA
DB_ado
DB_odbtp
DB_Pager
DB_Sqlite_Tools
Event_Dispatcher
File_DICOM
File_DNS
File_Find
File_Fstab
File_IMC
File_Passwd
File_SMBPasswd
Gtk_MDB_Designer
Gtk_ScrollingLabel
HTML_Form
HTML_Javascript
HTML_Page
HTML_Page2
HTML_QuickForm_SelectFilter
HTML_Safe
HTML_Select
HTML_Select_Common
HTML_Table_Matrix
HTML_Template_Xipe
HTTP_Header
HTTP_Server
HTTP_SessionServer
HTTP_Upload
HTTP_WebDAV_Server
I18N
I18Nv2
I18N_UnicodeString
Image_3D
Image_Color2
Image_GIS
Image_Graph
Image_IPTC
Image_Puzzle
Image_Remote
Image_WBMP
Inline_C
LiveUser_Admin
Mail_IMAP
Mail_IMAPv2
Math_Basex
Math_BinaryUtils
Math_Complex
Math_Fibonacci
Math_Finance
Math_Histogram
Math_Integer
Math_Matrix
Math_Polynomial
Math_Quaternion
Math_RPN
Math_Stats
Math_TrigOp
Math_Vector
MDB
MDB2_Driver_fbsql
Message
MP3_Playlist
Net_Cyrus
Net_Dict
Net_Dig
Net_DNS
Net_GameServerQuery
Net_Geo
Net_GeoIP
Net_Growl
Net_HL7
Net_Ident
Net_IPv4
Net_IRC
Net_LMTP
Net_Monitor
Net_POP3
Net_Portscan
Net_SmartIRC
Net_SMPP
Net_SMPP_Client
Net_SMS
Pager_Sliding
PEAR_Delegator
PEAR_Frontend_Gtk
PEAR_PackageFileManager_Frontend
PEAR_PackageFileManager_Frontend_Web
PEAR_PackageFileManager_GUI_Gtk
PHPDoc
PHPUnit
PHPUnit2
RDF
RDF_N3
RDF_NTriple
RDF_RDQL
Science_Chemistry
ScriptReorganizer
Search_Mnogosearch
Services_Delicious
Services_DynDNS
Services_Ebay
Services_ExchangeRates
Services_Webservice
Services_YouTube
Spreadsheet_Excel_Writer
SQL_Parser
Stream_SHM
Stream_Var
Structures_Graph
System_Mount
System_ProcWatch
System_SharedMemory
System_Socket
Text_Huffman
Text_PathNavigator
Text_Statistics
Text_TeXHyphen
Text_Wiki_BBCode
Text_Wiki_Cowiki
Text_Wiki_Doku
Text_Wiki_Mediawiki
Text_Wiki_Tiki
Translation
Validate_AR
Validate_AT
Validate_BE
Validate_CH
Validate_DE
Validate_DK
Validate_ES
Validate_FR
Validate_IS
Validate_NL
Validate_NZ
Validate_PL
Validate_ZA
XML_CSSML
XML_FastCreate
XML_fo2pdf
XML_HTMLSax
XML_image2svg
XML_Indexing
XML_MXML
XML_NITF
XML_RDDL
XML_RPC
XML_RSS
XML_SaxFilters
XML_Statistics
XML_SVG
XML_svg2image
XML_Tree
XML_Wddx
XML_XSLT_Wrapper
XML_XUL

Search Discussions

  • Laurent Laville at Jan 3, 2009 at 10:15 am
    Hello Helgi,
    First step is probably to find out which one of these is not
    maintained and which is superseeded and such, I can probably pull that
    off in my script if there is interest.
    You can add to your exclude list

    HTML_Progress superceeded by HTML_Progress2(and no more maintained)

    Maintainer of both package
    Laurent
  • Daniel O'Connor at Jan 4, 2009 at 2:13 pm

    On Sat, Jan 3, 2009 at 8:45 PM, Laurent Laville wrote:

    Hello Helgi,
    First step is probably to find out which one of these is not
    maintained and which is superseeded and such, I can probably pull that
    off in my script if there is interest.
    Didn't Brett send a hassling email to pear dev sometime last year? Basically
    update-or-we'll-assume-orphaned?
    http://www.nabble.com/Please-update-package.xml-to-version-2-by-September-1st,-2008-td18554971.html


    Also; packages which are likely to get a release in the near future:
    http://wiki.php.net/pear/qa/bug_triage/2009-01-17

    - Services_ExchangeRates 0.6 - doconnor
    - Numbers_Words
    - Image_Graph - doconnor emailed on 27th
    - DB_DataObject - troehr emailed on 27th
    - MDB2 - troehr emailed on 27th
    - MDB2_Driver_mysql - doconnor emailed on 27th
    - Validate - troehr emailed on 27th
    - Image_Transform - troehr emailed on 27th, waiting for feedback from
    Philippe Jausions (appx Jan 1)
    - Image_Canvas - doconnor emailed on 27th
    - HTML_Page2 - troehr emailed on 27th
    - HTTP_WebDAV_Client - doconnor emailed on 27th
    - HTTP_WebDAV_Server - doconnor emailed on 27th
    - Net_SmartIRC - doconnor emailed on 27th
    - SQL_Parser - doconnor emailed on 27th
    - Spreadsheet_Excel_Writer - troehr emailed on 27th, doconnor suitably
    scared
    - Mail_Mime - avb and lifeforms (walter) are on it
    - Math_Finance - get it into cvs - doconnor

    ... so those will probably get fixed within the next month
  • Daniel O'Connor at Jan 4, 2009 at 4:53 pm
    http://wiki.php.net/pear/packages/migration is probably not a bad place to
    capture notes about this
  • Laurent Laville at Jan 4, 2009 at 5:16 pm

    Daniel O'Connor a écrit :
    http://wiki.php.net/pear/packages/migration is probably not a bad
    place to capture notes about this
    You should also consider to write a list for package that are no more
    maintained, so its unnecessary to migrate to package xml v2

    For me these packages are :

    - PEAR_PackageFileManager_Frontend
    - PEAR_PackageFileManager_Frontend_Web
    - HTML_Progress
  • Daniel O'Connor at Jan 4, 2009 at 5:26 pm

    On Mon, Jan 5, 2009 at 3:45 AM, Laurent Laville wrote:

    Daniel O'Connor a écrit :
    http://wiki.php.net/pear/packages/migration is probably not a bad place
    to capture notes about this
    You should also consider to write a list for package that are no more
    maintained, so its unnecessary to migrate to package xml v2

    For me these packages are :

    - PEAR_PackageFileManager_Frontend
    - PEAR_PackageFileManager_Frontend_Web
    - HTML_Progress
    I'm thinking a lot of the unmaintained ones will have to be done anyway.

    For instance, http://pear.php.net/package/XML_Tree is still heavily used by
    some stable packages, so they either have to get patched to use something
    else or XML_Tree ends up coming along for the ride.

    :(
  • Daniel O'Connor at Jan 4, 2009 at 6:31 pm
    Helgi, can you post something to the front page of PEAR, and pear-general?

    Its going to take us months to get this sorted out properly - I'm just
    cruising through unmaintained packages only at the moment, and it is time
    consuming.
    Additionally, a lot of these are wontfix-ish (low downloads, superceded,
    etc).

    If we put something up along the lines of:
    *Hey, pear users, we are potentially going to kill off these packages (
    http://wiki.php.net/pear/packages/migration)*

    ... that will cause a lot of noise but save people pain later on, and also
    prompt a lot of people to pay off code debt - both within pear and in
    userland.

    Giving people a very loud, very public heads up now will give us more leeway
    in wontfixing really old packages.
  • Daniel O'Connor at Jan 4, 2009 at 6:38 pm

    If we put something up along the lines of:
    *Hey, pear users, we are potentially going to kill off these packages (
    http://wiki.php.net/pear/packages/migration)*
    (and then in very small text, write "in 2010 ...")
  • Adam Ashley at Jan 5, 2009 at 2:14 am

    On Sat, Jan 3, 2009 at 6:05 PM, Helgi Þormar Þorbjörnsson wrote:
    Auth_PrefManager2
    You can remove Auth_PrefManager2 from the list. It has never had a
    working release and my intention is to throw all the current code out
    and start again once we have a fixed target for pyrus and php5
    development.

    Adam Ashley
  • Daniel O'Connor at Jan 5, 2009 at 9:00 am
    Helgi, I don't think pearweb knows where there are 2 files (package.xml,
    package2.xml) - for instance, with XML_XUL, it had both but was listed as
    still using package 1.0

    Annoying, and that means that some of these packages will already have been
    updated.
  • Helgi Þormar Þorbjörnsson at Jan 6, 2009 at 7:17 am

    On Mon, Jan 5, 2009 at 9:00 AM, Daniel O'Connor wrote:
    Helgi, I don't think pearweb knows where there are 2 files (package.xml,
    package2.xml) - for instance, with XML_XUL, it had both but was listed as
    still using package 1.0

    Annoying, and that means that some of these packages will already have been
    updated.
    It's a custom SQL query - Maybe the query is broken or maybe pearweb
    is indeed disgarding package2.xml when package.xml is around, I can
    look into that but given the website knows it's v2 then I reckon SQL
    would pick that up.

    - Helgi
  • Daniel O'Connor at Dec 10, 2011 at 12:47 am
    Can we re-run this query ti see what's left to do?

    2009/1/6 Helgi Þormar Þorbjörnsson <helgith@gmail.com>
    On Mon, Jan 5, 2009 at 9:00 AM, Daniel O'Connor
    wrote:
    Helgi, I don't think pearweb knows where there are 2 files (package.xml,
    package2.xml) - for instance, with XML_XUL, it had both but was listed as
    still using package 1.0

    Annoying, and that means that some of these packages will already have been
    updated.
    It's a custom SQL query - Maybe the query is broken or maybe pearweb
    is indeed disgarding package2.xml when package.xml is around, I can
    look into that but given the website knows it's v2 then I reckon SQL
    would pick that up.

    - Helgi

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-qa @
categoriesphp
postedJan 3, '09 at 9:06a
activeDec 10, '11 at 12:47a
posts12
users4
websitepear.php.net

People

Translate

site design / logo © 2021 Grokbase