FAQ
Edit report at https://pear.php.net/bugs/bug.php?id=18850&edit=1

  ID: 18850
  Updated by: cweiske@php.net
  Reported By: ohlesbeauxjours at yahoo dot fr
  Summary: Package made with Pyrus installed at the wrong place
                     with the old "pear" tool
  Status: Open
  Type: Bug
  Package: PEAR
  Operating System: WinXP SP2
  Package Version: 1.9.4
  PHP Version: 5.3.8
-Roadmap Versions:
+Roadmap Versions: 1.10.0
  New Comment:

-Roadmap Versions:
+Roadmap Versions: 1.10.0



Previous Comments:
------------------------------------------------------------------------

[2011-09-24 03:37:48] baptiste

So I changed the structure of my package to what is described in
http://pear.php.net/manual/en/pyrus.commands.make.php, and I keep
getting the same error message when I run "pyrus make" ("Invalid
package.xml ... does not validate", in spite of the fact that there is
no package.xml in my folder: that's precisely what I would like "pyrus
make" to generate!!)...

Until know I have not been able to execute the Pyrus commands "install",
"uninstall", "make" or "package". Each time there is a different problem
(see my other bugs). Maybe I am too dumb to use Pyrus, but I give up
with it for the moment.

------------------------------------------------------------------------

[2011-09-21 02:53:04] baptiste

This is what I get when I run "pyrus make" from inside my package:

Pyrus version 2.0.0a3 SHA-1: BE7EA9D171AE3873F1BBAF692EEE9165BB14BD5D
Using PEAR installation found at G:\Inetpub\librairies\PEAR\pear
Creating package.xml...PEAR2\Pyrus\PackageFile\Exception: Invalid
package.xml, does not validate against schema
  PEAR2\Pyrus\PackageFile\Exception: Line 3: Element
'{http://pear.php.net/dtd/package-2.1}channel': This element is not
expected. Expected is ( {http://pear.php.net/dtd/package-2.1}name ).

Should I change the structure of my package to what is described on
http://pear.php.net/manual/en/pyrus.commands.make.php ? (in particular,
I have no /src folder for now)

------------------------------------------------------------------------

[2011-09-20 15:30:11] saltybeagle

Have you tried packaging your package using the package_compatible.xml
file `pyrus make` generates?

You might try `pear package package_compatible.xml`, then installing
with PEAR.

------------------------------------------------------------------------

[2011-09-19 23:23:08] baptiste

Description:
------------
I just made a package with Pyrus (pyrus package package.xml). When I try
to install it with a "pear install", the install process says it's ok,
but the base folder of the package appears at the PEAR root directory,
instead of the category directory (PHP, in my example).



Test script:
---------------
pear install PHP_UML-1.6.0.tgz

Expected result:
----------------
Install ok with the folder UML in [pear dir]/PHP/

Actual result:
--------------
The folder UML is in [pear dir]/

Thus, when I launch the command line tool "phpuml -v", I get:
Warning: require_once(PHP/UML.php): failed to open stream: No such file
or directory in G:\Inetpub\librairies\PEAR\phpuml on line 27

Fatal error: require_once(): Failed opening required 'PHP/UML.php'
(include_path='G:\Inetpub\librairies\PEAR\pear') in
G:\Inetpub\librairies\PEAR\phpuml on line 27

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedMay 29, '14 at 7:06p
activeMay 29, '14 at 7:06p
posts1
users1
websitepear.php.net

1 user in discussion

Cweiske: 1 post

People

Translate

site design / logo © 2022 Grokbase