FAQ
Edit report at https://pear.php.net/bugs/bug.php?id=19505&edit=1

ID: 19505
Updated by: alan@roojs.com
Reported By: noel at arc2 dot co dot uk
Summary: Upgrading from 1.7.15 to 1.10.0 causes error due to
no links file
-Status: Open
+Status: Closed
Type: Bug
Package: DB_DataObject
Operating System: OSX 10.6.8
Package Version: 1.10.0
PHP Version: 5.3.8
-Assigned To:
+Assigned To: alan_k
Roadmap Versions:
New Comment:

-Status: Open
+Status: Closed
-Assigned To:
+Assigned To: alan_k
This bug has been fixed in SVN.

If this was a documentation problem, the fix will appear on pear.php.net
by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should
be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.




Previous Comments:
------------------------------------------------------------------------

[2012-07-12 10:32:54] noeldc

OK never mind. Was getting confused between two code-bases. Setting
proxy = 1 does work.

Tx!

------------------------------------------------------------------------

[2012-07-12 10:26:39] noeldc

What variable must I var_dump?

------------------------------------------------------------------------

[2012-07-12 10:23:21] alan_k

I've tested it here with tests/bug6953.php

Seems to work fine - it looks like it's not picking up your proxy
setting

try var_Dump'ing the value near line 1981 to check that it's trying to
use the
generator.

------------------------------------------------------------------------

[2012-07-12 09:31:15] noeldc

Just tried the version on your (with proxy = full and then with proxy =
1). No
change. Same error:

Menu: CONNECT: Checking for database specific ini ('') : database_ in
options
Menu: CONNECT: NEW CONNECTION TP DATABASE :
Menu: CONNECT: mysql://root:root@localhost/headspace_local
fdc0344bd4c91aff97a75e2d0628c197
Menu: CONNECT: a:1:
{s:32:"fdc0344bd4c91aff97a75e2d0628c197";O:8:"DB_mysql":8:
{s:10:"autocommit";b:1;s:8:"dbsyntax";s:5:"mysql";s:3:"dsn";a:9:
{s:7:"phptype";s:5:"mysql";s:8:"dbsyntax";s:5:"mysql";s:8:"username";s:4:"root"
;s:8:"password";s:4:"root";s:8:"protocol";s:3:"tcp";s:8:"hostspec";s:9:"localhost";s
:4:"port";b:0;s:6:"socket";b:0;s:8:"database";s:15:"headspace_local";}s:8:"featur
es";a:7:
{s:5:"limit";s:5:"alter";s:8:"new_link";s:5:"4.2.0";s:7:"numrows";b:1;s:8:"pconnec
t";b:1;s:7:"prepare";b:0;s:3:"ssl";b:0;s:12:"transactions";b:1;}s:9:"fetchmode";i:1
;s:22:"fetchmode_object_class";s:8:"stdClass";s:7:"options";a:8:
{s:16:"result_buffering";i:500;s:10:"persistent";b:0;s:3:"ssl";b:0;s:5:"debug";i:0;s
:14:"seqname_format";s:6:"%s_seq";s:8:"autofree";b:0;s:11:"portability";i:0;s:8:"
optimize";s:11:"performance";}s:13:"was_connected";b:1;}}
Menu: databaseStructure: Cant find database schema: headspace_local/menu

in links file data: Array
(
[headspace_local] => Array
(
)

)

Menu: ERROR: Unable to load schema for database and table (turn
debugging up to
5 for full error message)
DB_DataObject Error: Unable to load schema for database and table (turn

debugging up to 5 for full error message)

------------------------------------------------------------------------

[2012-07-12 04:51:04] alan_k

Can you test this - the decision code for using the proxy generator
should be simpler.

Note you need to have the ini setting 'proxy' => 1 set somewhere for it
to work.

http://svn.php.net/viewvc/pear/packages/DB_DataObject/trunk/DB/DataObject.php?
revision=326601&view=co

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://pear.php.net/bugs/bug.php?id=19505

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedJul 18, '12 at 3:52p
activeJul 18, '12 at 3:52p
posts1
users1
websitepear.php.net

1 user in discussion

Alan: 1 post

People

Translate

site design / logo © 2022 Grokbase