FAQ
Edit report at https://pear.php.net/bugs/bug.php?id=19324&edit=1

ID: 19324
Updated by: gsherwood@squiz.net
Reported By: deniz at dogan dot se
-Summary: Documentation confusing/incorrect regarding
configuring warnings
+Summary: Setting show_warnings configuration option does not
work
Status: Open
-Type: Documentation Problem
+Type: Bug
Package: PHP_CodeSniffer
Package Version: 1.3.3
PHP Version: 5.3.10
-Assigned To:
+Assigned To: squiz
Roadmap Versions:
New Comment:

-Summary: Documentation confusing/incorrect regarding
configuring warnings
+Summary: Setting show_warnings configuration option
does not work
-Type: Documentation Problem
+Type: Bug
-Assigned To:
+Assigned To: squiz
The documentation is correct, but a code change broke that
functionality.


Previous Comments:
------------------------------------------------------------------------

[2012-03-09 09:20:13] damd

Description:
------------
The documentation clearly states:

To hide warnings by default, set the show_warnings configuration
option to 0.
phpcs --config-set show_warnings 0

This doesn't actually hide the warnings I get in my report about
line lengths.

Expected result:
----------------
I expect the output to not contain any WARNING lines.

Actual result:
--------------
I get e.g. 38 | WARNING | Line exceeds 85 characters; contains
94 characters

------------------------------------------------------------------------

Search Discussions

  • Gsherwood at Mar 12, 2012 at 12:53 am
    Edit report at https://pear.php.net/bugs/bug.php?id=19324&edit=1

    ID: 19324
    Updated by: gsherwood@squiz.net
    Reported By: deniz at dogan dot se
    Summary: Setting show_warnings configuration option does not
    work
    -Status: Assigned
    +Status: Closed
    Type: Bug
    Package: PHP_CodeSniffer
    Package Version: 1.3.3
    PHP Version: 5.3.10
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    -Status: Assigned
    +Status: Closed
    Fixed in git repo:
    https://github.com/squizlabs/PHP_CodeSniffer/commit/c8ac067ea5519c5e4d7fb8017
    22eb2c7b858e844


    Previous Comments:
    ------------------------------------------------------------------------

    [2012-03-12 01:54:53] squiz

    -Summary: Documentation confusing/incorrect regarding
    configuring warnings
    +Summary: Setting show_warnings configuration option
    does not work
    -Type: Documentation Problem
    +Type: Bug
    -Assigned To:
    +Assigned To: squiz
    The documentation is correct, but a code change broke that
    functionality.

    ------------------------------------------------------------------------

    [2012-03-09 09:20:13] damd

    Description:
    ------------
    The documentation clearly states:

    To hide warnings by default, set the show_warnings configuration
    option to 0.
    phpcs --config-set show_warnings 0

    This doesn't actually hide the warnings I get in my report about
    line lengths.

    Expected result:
    ----------------
    I expect the output to not contain any WARNING lines.

    Actual result:
    --------------
    I get e.g. 38 | WARNING | Line exceeds 85 characters; contains
    94 characters

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedMar 12, '12 at 12:52a
activeMar 12, '12 at 12:53a
posts2
users1
websitepear.php.net

1 user in discussion

Gsherwood: 2 posts

People

Translate

site design / logo © 2022 Grokbase