FAQ
Edit report at https://pear.php.net/bugs/bug.php?id=19126&edit=1

ID: 19126
Updated by: danielc@analysisandsolutions.com
Reported By: danielc at analysisandsolutions dot com
Summary: upgrade PHPUnit require statements & other fixes (for
PEAR QA Team)
Status: Open
Type: Bug
Package: Net_Nmap
Package Version: SVN
PHP Version: 5_4 SVN-2011-12-10
-Assigned To:
+Assigned To: doconnor
Roadmap Versions:
New Comment:

-Assigned To:
+Assigned To: doconnor
doconnor: I had done all the work for this fix in my local svn working
directory. Moving the stuff to github blew away those changes. Can you
please make the changes now?


Previous Comments:
------------------------------------------------------------------------

[2011-12-10 22:48:30] danielc

Description:
------------
Hi Luca:

Current versions of PHPUnit have a different layout, so calls to require
PHPUnit/Framework.php fail. Newer versions also have an autoloader.
The require statements need to be adjusted so both older and newer
versions to work. Getting PEAR's continuous integration testing system
running is an urgent priority.

In addition, the Nmap.php file and the Nmap dir need to go into a
directory named Net. Then there's are several tweaks to the test files
so they'll be executable. I have all of this ready to go in my SVN
working directory and I have karma to make the commits needed. I hope
you'll give me approval to implement these fixes.

Thanks,

--Dan

------------------------------------------------------------------------

Search Discussions

  • Daniel Oconnor at Jan 4, 2012 at 11:31 am
    Edit report at https://pear.php.net/bugs/bug.php?id=19126&edit=1

    ID: 19126
    Updated by: daniel.oconnor@gmail.com
    Reported By: danielc at analysisandsolutions dot com
    Summary: upgrade PHPUnit require statements & other fixes (for
    PEAR QA Team)
    Status: Assigned
    Type: Bug
    Package: Net_Nmap
    Package Version: SVN
    PHP Version: 5_4 SVN-2011-12-10
    -Assigned To: doconnor
    +Assigned To: lucor
    Roadmap Versions:
    New Comment:

    -Assigned To: doconnor
    +Assigned To: lucor
    https://github.com/pear/Net_Nmap/pull/1 ?


    Previous Comments:
    ------------------------------------------------------------------------

    [2012-01-04 03:44:34] danielc

    -Assigned To:
    +Assigned To: doconnor
    doconnor: I had done all the work for this fix in my local svn working
    directory. Moving the stuff to github blew away those changes. Can you
    please make the changes now?

    ------------------------------------------------------------------------

    [2011-12-10 22:48:30] danielc

    Description:
    ------------
    Hi Luca:

    Current versions of PHPUnit have a different layout, so calls to require
    PHPUnit/Framework.php fail. Newer versions also have an autoloader.
    The require statements need to be adjusted so both older and newer
    versions to work. Getting PEAR's continuous integration testing system
    running is an urgent priority.

    In addition, the Nmap.php file and the Nmap dir need to go into a
    directory named Net. Then there's are several tweaks to the test files
    so they'll be executable. I have all of this ready to go in my SVN
    working directory and I have karma to make the commits needed. I hope
    you'll give me approval to implement these fixes.

    Thanks,

    --Dan

    ------------------------------------------------------------------------
  • Lucor at Jan 5, 2012 at 10:36 am
    Edit report at https://pear.php.net/bugs/bug.php?id=19126&edit=1

    ID: 19126
    Updated by: lucor@php.net
    Reported By: danielc at analysisandsolutions dot com
    Summary: upgrade PHPUnit require statements & other fixes (for
    PEAR QA Team)
    -Status: Assigned
    +Status: Closed
    Type: Bug
    Package: Net_Nmap
    Package Version: SVN
    PHP Version: 5_4 SVN-2011-12-10
    Assigned To: lucor
    Roadmap Versions:
    New Comment:

    -Status: Assigned
    +Status: Closed
    Merged.
    Thanks.


    Previous Comments:
    ------------------------------------------------------------------------

    [2012-01-04 12:31:40] doconnor

    -Assigned To: doconnor
    +Assigned To: lucor
    https://github.com/pear/Net_Nmap/pull/1 ?

    ------------------------------------------------------------------------

    [2012-01-04 03:44:34] danielc

    -Assigned To:
    +Assigned To: doconnor
    doconnor: I had done all the work for this fix in my local svn working
    directory. Moving the stuff to github blew away those changes. Can you
    please make the changes now?

    ------------------------------------------------------------------------

    [2011-12-10 22:48:30] danielc

    Description:
    ------------
    Hi Luca:

    Current versions of PHPUnit have a different layout, so calls to require
    PHPUnit/Framework.php fail. Newer versions also have an autoloader.
    The require statements need to be adjusted so both older and newer
    versions to work. Getting PEAR's continuous integration testing system
    running is an urgent priority.

    In addition, the Nmap.php file and the Nmap dir need to go into a
    directory named Net. Then there's are several tweaks to the test files
    so they'll be executable. I have all of this ready to go in my SVN
    working directory and I have karma to make the commits needed. I hope
    you'll give me approval to implement these fixes.

    Thanks,

    --Dan

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedJan 4, '12 at 2:44a
activeJan 5, '12 at 10:36a
posts3
users3
websitepear.php.net

3 users in discussion

Daniel Oconnor: 1 post Danielc: 1 post Lucor: 1 post

People

Translate

site design / logo © 2021 Grokbase