FAQ
Edit report at https://pear.php.net/bugs/bug.php?id=19168&edit=1

ID: 19168
Updated by: danielc@analysisandsolutions.com
Reported By: danielc at analysisandsolutions dot com
Summary: upgrade PHPUnit require statements & other fixes (for
PEAR QA Team)
-Status: Open
+Status: Closed
Type: Bug
Package: XML_Serializer
Package Version: SVN
PHP Version: 5_4 SVN-2011-12-29
-Assigned To:
+Assigned To: danielc
Roadmap Versions:
New Comment:

-Status: Open
+Status: Closed
-Assigned To:
+Assigned To: danielc



Previous Comments:
------------------------------------------------------------------------

[2011-12-29 21:28:54] danielc

Added #patch bug:19168;patch:qa;revision:1325194134;.

------------------------------------------------------------------------

[2011-12-29 21:28:44] danielc

Description:
------------
Current versions of PHPUnit have a different layout, so calls to require
PHPUnit/Framework.php fail. Newer versions also have an autoloader.
The require statements need to be adjusted so both older and newer
versions to work.

Getting PEAR's continuous integration testing system running is an
urgent priority. Please fix this as soon as possible. I have karma and
the changes on hand so can easily commit them if you like.

In addition, other tweaks were necessary to get the tests running.

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedDec 29, '11 at 9:11p
activeDec 29, '11 at 9:11p
posts1
users1
websitepear.php.net

1 user in discussion

Danielc: 1 post

People

Translate

site design / logo © 2022 Grokbase