FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=17479&edit=1

ID: 17479
Updated by: helgith@gmail.com
Reported By: ken at linux dot ie
Summary: should use the system wide http proxy setting on *nix
Status: Open
Type: Feature/Change Request
Package: PEAR
Operating System: *nix
Package Version: 1.9.1
PHP Version: 5.2.6
Roadmap Versions:
New Comment:

Right now we do this:

if (getenv('PHP_PEAR_HTTP_PROXY')) {
define('PEAR_CONFIG_DEFAULT_HTTP_PROXY',
getenv('PHP_PEAR_HTTP_PROXY'));
} elseif (getenv('http_proxy')) {
define('PEAR_CONFIG_DEFAULT_HTTP_PROXY', getenv('http_proxy'));
} else {
define('PEAR_CONFIG_DEFAULT_HTTP_PROXY', '');
}

We will in fact look for http_proxy (as you are suggesting we use)

Are you sure you are not able to use this?


Previous Comments:
------------------------------------------------------------------------

[2010-06-10 00:08:48] kguest

Three possible types of values for http_proxy could be used:
<not set> or null - don't use a proxy at all
'inherit' - use proxy specified by the http_proxy environment variable
<set> e.g. http://192.168.1.2:128 - use specified proxy


if people want to have a system proxy but have none for their pear
install then the solution would be to do:
$ pear config-set http_proxy ''

The default setting would be to inherit the value from the environment
variable.

------------------------------------------------------------------------

[2010-06-09 19:17:47] dufuz

-Type: Bug
+Type: Feature/Change Request
This is not a bug, this is a feature request.

How do you propose this be done? The option here is to just look for the
http_proxy
and always use it if it's around, but what about when people want to
have a system
proxy but none set for pear?
The option for that would be to import that http proxy from the system
on installation
but then it would be hard to keep them in sync automagically.

------------------------------------------------------------------------

[2010-06-09 16:54:44] kguest

Description:
------------
On *nix systems [the cli tool] should use the system wide proxy setting
as set thus:
$export http_proxy='http://192.168.1.2:3128/'

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedJul 6, '11 at 5:59p
activeJul 6, '11 at 5:59p
posts1
users1
websitepear.php.net

1 user in discussion

Helgith: 1 post

People

Translate

site design / logo © 2022 Grokbase