FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=18594&edit=1

ID: 18594
Updated by: daniel.oconnor@gmail.com
Reported By: spam2 at rhsoft dot net
Summary: Net_SMTP-1.6.0 breaks SMTP-Auth
-Status: Open
+Status: Feedback
Type: Bug
Package: Net_SMTP
Operating System: Fedora Linux x86_64
Package Version: 1.6.0
PHP Version: 5.3.6
Roadmap Versions:
New Comment:

-Status: Open
+Status: Feedback



Previous Comments:
------------------------------------------------------------------------

[2011-06-12 07:39:17] doconnor

Hi Harald,
Thanks for the report. Can I ask you to adjust your tone in future when
making bug reports; and include reproducible
test steps - many of the people here are volunteers; and none of them
intentionally set out to break things for you.

Now what was the previous version of net_smtp you were using/have
currently restored to?

$ pear list | grep Net_SMTP

At the very least, we can then look at all of the changes to identify
where potential regression occurred.

Secondly, can I get you to verify that the version of imp you were using
previously is 4.3.9 - there's a reasonable
chance that configuration in is no longer set up the same way or
otherwise changed in some subtle way.

Thirdly, can I get you to try to make a small reproducible test case
using only Net_SMTP & the assorted credentials - we
can use to 100% verify it is Net_SMTP which is the problem; and to prove
any fixes that are made are tested.

------------------------------------------------------------------------

[2011-06-11 21:13:12] rhsoftware

Description:
------------
After upgrade ok: channel://pear.php.net/Net_SMTP-1.6.0 SMTP-Auth for
Horde-Webmail (IMP H3 4.3.9) is broken, means it does not try
authentication and that is why postfix rejects

[SMTP: Invalid response code received from server (code: 554, response:
5.7.1 <buildserver.thelounge.net[10.0.0.103]>: Client host rejected:
Access denied 5.7.1

this is sure a PEAR-Problem because after rsync a backup from
/usr/share/pear it works again without touching any configuration

$conf['mailer']['params']['host'] = 'backup-dbmail.thelounge.net';
$conf['mailer']['params']['port'] = 587;
$conf['mailer']['params']['auth'] = 'DIGEST-MD5';
$conf['mailer']['params']['username'] = 'webmail@thelounge.net';
$conf['mailer']['params']['password'] = '***********';
$conf['mailer']['type'] = 'smtp';

sorry but this is a basic-function of smtp which should not be broken by
any update and only luck let find users such things after "pear upgrade"
because you can never test anything a webapp is doing

why can a fucking "pear upgrade" in the terminal not show what apckages
are available and after confirm do an update - this is a blind butcher


Expected result:
----------------
send a message

Actual result:
--------------
smtp-auth is ignored and message rejected

------------------------------------------------------------------------

Search Discussions

  • Daniel Oconnor at Jun 17, 2011 at 5:54 am
    Edit report at http://pear.php.net/bugs/bug.php?id=18594&edit=1

    ID: 18594
    Updated by: daniel.oconnor@gmail.com
    Reported By: spam2 at rhsoft dot net
    Summary: Net_SMTP-1.6.0 breaks SMTP-Auth
    Status: Open
    Type: Bug
    Package: Net_SMTP
    Operating System: Fedora Linux x86_64
    Package Version: 1.6.0
    PHP Version: 5.3.6
    Roadmap Versions:
    New Comment:

    Hi Harald,
    Thanks for the report. Can I ask you to adjust your tone in future when
    making bug reports; and include reproducible
    test steps - many of the people here are volunteers; and none of them
    intentionally set out to break things for you.

    Now what was the previous version of net_smtp you were using/have
    currently restored to?

    $ pear list | grep Net_SMTP

    At the very least, we can then look at all of the changes to identify
    where potential regression occurred.

    Secondly, can I get you to verify that the version of imp you were using
    previously is 4.3.9 - there's a reasonable
    chance that configuration in is no longer set up the same way or
    otherwise changed in some subtle way.

    Thirdly, can I get you to try to make a small reproducible test case
    using only Net_SMTP & the assorted credentials - we
    can use to 100% verify it is Net_SMTP which is the problem; and to prove
    any fixes that are made are tested.


    Previous Comments:
    ------------------------------------------------------------------------

    [2011-06-11 21:13:12] rhsoftware

    Description:
    ------------
    After upgrade ok: channel://pear.php.net/Net_SMTP-1.6.0 SMTP-Auth for
    Horde-Webmail (IMP H3 4.3.9) is broken, means it does not try
    authentication and that is why postfix rejects

    [SMTP: Invalid response code received from server (code: 554, response:
    5.7.1 <buildserver.thelounge.net[10.0.0.103]>: Client host rejected:
    Access denied 5.7.1

    this is sure a PEAR-Problem because after rsync a backup from
    /usr/share/pear it works again without touching any configuration

    $conf['mailer']['params']['host'] = 'backup-dbmail.thelounge.net';
    $conf['mailer']['params']['port'] = 587;
    $conf['mailer']['params']['auth'] = 'DIGEST-MD5';
    $conf['mailer']['params']['username'] = 'webmail@thelounge.net';
    $conf['mailer']['params']['password'] = '***********';
    $conf['mailer']['type'] = 'smtp';

    sorry but this is a basic-function of smtp which should not be broken by
    any update and only luck let find users such things after "pear upgrade"
    because you can never test anything a webapp is doing

    why can a fucking "pear upgrade" in the terminal not show what apckages
    are available and after confirm do an update - this is a blind butcher


    Expected result:
    ----------------
    send a message

    Actual result:
    --------------
    smtp-auth is ignored and message rejected

    ------------------------------------------------------------------------
  • Spam2 at Jun 17, 2011 at 9:48 am
    Edit report at http://pear.php.net/bugs/bug.php?id=18594&edit=1

    ID: 18594
    Updated by: spam2@rhsoft.net
    Reported By: spam2 at rhsoft dot net
    Summary: Net_SMTP-1.6.0 breaks SMTP-Auth
    Status: Feedback
    Type: Bug
    Package: Net_SMTP
    Operating System: Fedora Linux x86_64
    Package Version: 1.6.0
    PHP Version: 5.3.6
    Roadmap Versions:
    New Comment:

    Net_SMTP 1.5.2 stable
    imp-4.3.9-3.fc14.rh.20110526.noarch

    IMP is not changed because Horde4 is not a topic here this time
    So the only change is Net_SMTP
    we can use to 100% verify it is Net_SMTP which is the problem
    it is becazse nothing other file is zouched on the system and it is the
    only
    PEAR-package which is updated and after revert this the problem is
    solved


    Previous Comments:
    ------------------------------------------------------------------------

    [2011-06-12 07:39:32] doconnor

    -Status: Open
    +Status: Feedback


    ------------------------------------------------------------------------

    [2011-06-12 07:39:17] doconnor

    Hi Harald,
    Thanks for the report. Can I ask you to adjust your tone in future when
    making bug reports; and include reproducible
    test steps - many of the people here are volunteers; and none of them
    intentionally set out to break things for you.

    Now what was the previous version of net_smtp you were using/have
    currently restored to?

    $ pear list | grep Net_SMTP

    At the very least, we can then look at all of the changes to identify
    where potential regression occurred.

    Secondly, can I get you to verify that the version of imp you were using
    previously is 4.3.9 - there's a reasonable
    chance that configuration in is no longer set up the same way or
    otherwise changed in some subtle way.

    Thirdly, can I get you to try to make a small reproducible test case
    using only Net_SMTP & the assorted credentials - we
    can use to 100% verify it is Net_SMTP which is the problem; and to prove
    any fixes that are made are tested.

    ------------------------------------------------------------------------

    [2011-06-11 21:13:12] rhsoftware

    Description:
    ------------
    After upgrade ok: channel://pear.php.net/Net_SMTP-1.6.0 SMTP-Auth for
    Horde-Webmail (IMP H3 4.3.9) is broken, means it does not try
    authentication and that is why postfix rejects

    [SMTP: Invalid response code received from server (code: 554, response:
    5.7.1 <buildserver.thelounge.net[10.0.0.103]>: Client host rejected:
    Access denied 5.7.1

    this is sure a PEAR-Problem because after rsync a backup from
    /usr/share/pear it works again without touching any configuration

    $conf['mailer']['params']['host'] = 'backup-dbmail.thelounge.net';
    $conf['mailer']['params']['port'] = 587;
    $conf['mailer']['params']['auth'] = 'DIGEST-MD5';
    $conf['mailer']['params']['username'] = 'webmail@thelounge.net';
    $conf['mailer']['params']['password'] = '***********';
    $conf['mailer']['type'] = 'smtp';

    sorry but this is a basic-function of smtp which should not be broken by
    any update and only luck let find users such things after "pear upgrade"
    because you can never test anything a webapp is doing

    why can a fucking "pear upgrade" in the terminal not show what apckages
    are available and after confirm do an update - this is a blind butcher


    Expected result:
    ----------------
    send a message

    Actual result:
    --------------
    smtp-auth is ignored and message rejected

    ------------------------------------------------------------------------
  • Jon at Jun 17, 2011 at 4:33 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=18594&edit=1

    ID: 18594
    Updated by: jon@php.net
    Reported By: spam2 at rhsoft dot net
    Summary: Net_SMTP-1.6.0 breaks SMTP-Auth
    Status: Feedback
    Type: Bug
    Package: Net_SMTP
    Operating System: Fedora Linux x86_64
    Package Version: 1.6.0
    PHP Version: 5.3.6
    -Assigned To:
    +Assigned To: jon
    Roadmap Versions:
    New Comment:

    -Assigned To:
    +Assigned To: jon
    The SMTP AUTH method selection code was rewritten for version 1.6.0.
    (The goal
    is to allow additional external AUTH methods to be registered with
    Net_SMTP.) The
    existing AUTH implementations, including DIGEST-MD5, should be the same
    as in
    previous version of Net_SMTP.

    Given that, these would be helpful next steps:

    - Temporarily try a different AUTH method other than DIGEST-MD5. LOGIN
    and
    PLAIN are good candidates.

    - Enable Net_SMTP's debugging mode (setDebug(true)). This will dump the
    full
    SMTP conversation to the output stream. That will be very helpful in
    determining
    where things are going wrong. I unfortunately don't know the easiest
    way to do
    that from within IMP.

    And my apologies for introducing this problem in the first place.


    Previous Comments:
    ------------------------------------------------------------------------

    [2011-06-17 11:48:00] rhsoftware

    Net_SMTP 1.5.2 stable
    imp-4.3.9-3.fc14.rh.20110526.noarch

    IMP is not changed because Horde4 is not a topic here this time
    So the only change is Net_SMTP
    we can use to 100% verify it is Net_SMTP which is the problem
    it is becazse nothing other file is zouched on the system and it is the
    only
    PEAR-package which is updated and after revert this the problem is
    solved

    ------------------------------------------------------------------------

    [2011-06-12 07:39:32] doconnor

    -Status: Open
    +Status: Feedback


    ------------------------------------------------------------------------

    [2011-06-12 07:39:17] doconnor

    Hi Harald,
    Thanks for the report. Can I ask you to adjust your tone in future when
    making bug reports; and include reproducible
    test steps - many of the people here are volunteers; and none of them
    intentionally set out to break things for you.

    Now what was the previous version of net_smtp you were using/have
    currently restored to?

    $ pear list | grep Net_SMTP

    At the very least, we can then look at all of the changes to identify
    where potential regression occurred.

    Secondly, can I get you to verify that the version of imp you were using
    previously is 4.3.9 - there's a reasonable
    chance that configuration in is no longer set up the same way or
    otherwise changed in some subtle way.

    Thirdly, can I get you to try to make a small reproducible test case
    using only Net_SMTP & the assorted credentials - we
    can use to 100% verify it is Net_SMTP which is the problem; and to prove
    any fixes that are made are tested.

    ------------------------------------------------------------------------

    [2011-06-11 21:13:12] rhsoftware

    Description:
    ------------
    After upgrade ok: channel://pear.php.net/Net_SMTP-1.6.0 SMTP-Auth for
    Horde-Webmail (IMP H3 4.3.9) is broken, means it does not try
    authentication and that is why postfix rejects

    [SMTP: Invalid response code received from server (code: 554, response:
    5.7.1 <buildserver.thelounge.net[10.0.0.103]>: Client host rejected:
    Access denied 5.7.1

    this is sure a PEAR-Problem because after rsync a backup from
    /usr/share/pear it works again without touching any configuration

    $conf['mailer']['params']['host'] = 'backup-dbmail.thelounge.net';
    $conf['mailer']['params']['port'] = 587;
    $conf['mailer']['params']['auth'] = 'DIGEST-MD5';
    $conf['mailer']['params']['username'] = 'webmail@thelounge.net';
    $conf['mailer']['params']['password'] = '***********';
    $conf['mailer']['type'] = 'smtp';

    sorry but this is a basic-function of smtp which should not be broken by
    any update and only luck let find users such things after "pear upgrade"
    because you can never test anything a webapp is doing

    why can a fucking "pear upgrade" in the terminal not show what apckages
    are available and after confirm do an update - this is a blind butcher


    Expected result:
    ----------------
    send a message

    Actual result:
    --------------
    smtp-auth is ignored and message rejected

    ------------------------------------------------------------------------
  • Spam2 at Jun 18, 2011 at 11:27 am
    Edit report at http://pear.php.net/bugs/bug.php?id=18594&edit=1

    ID: 18594
    Updated by: spam2@rhsoft.net
    Reported By: spam2 at rhsoft dot net
    Summary: Net_SMTP-1.6.0 breaks SMTP-Auth
    Status: Feedback
    Type: Bug
    Package: Net_SMTP
    Operating System: Fedora Linux x86_64
    Package Version: 1.6.0
    PHP Version: 5.3.6
    Assigned To: jon
    Roadmap Versions:
    New Comment:

    Sorry but i am in this case inly a enduser of horde/pear_smtp, never
    used it actevily an dfrom monday on two weeks at holiday, so i worked
    day and night the last week - no way to play with debugging here :-(


    Previous Comments:
    ------------------------------------------------------------------------

    [2011-06-17 18:33:01] jon

    -Assigned To:
    +Assigned To: jon
    The SMTP AUTH method selection code was rewritten for version 1.6.0.
    (The goal
    is to allow additional external AUTH methods to be registered with
    Net_SMTP.) The
    existing AUTH implementations, including DIGEST-MD5, should be the same
    as in
    previous version of Net_SMTP.

    Given that, these would be helpful next steps:

    - Temporarily try a different AUTH method other than DIGEST-MD5. LOGIN
    and
    PLAIN are good candidates.

    - Enable Net_SMTP's debugging mode (setDebug(true)). This will dump the
    full
    SMTP conversation to the output stream. That will be very helpful in
    determining
    where things are going wrong. I unfortunately don't know the easiest
    way to do
    that from within IMP.

    And my apologies for introducing this problem in the first place.

    ------------------------------------------------------------------------

    [2011-06-17 11:48:00] rhsoftware

    Net_SMTP 1.5.2 stable
    imp-4.3.9-3.fc14.rh.20110526.noarch

    IMP is not changed because Horde4 is not a topic here this time
    So the only change is Net_SMTP
    we can use to 100% verify it is Net_SMTP which is the problem
    it is becazse nothing other file is zouched on the system and it is the
    only
    PEAR-package which is updated and after revert this the problem is
    solved

    ------------------------------------------------------------------------

    [2011-06-12 07:39:32] doconnor

    -Status: Open
    +Status: Feedback


    ------------------------------------------------------------------------

    [2011-06-12 07:39:17] doconnor

    Hi Harald,
    Thanks for the report. Can I ask you to adjust your tone in future when
    making bug reports; and include reproducible
    test steps - many of the people here are volunteers; and none of them
    intentionally set out to break things for you.

    Now what was the previous version of net_smtp you were using/have
    currently restored to?

    $ pear list | grep Net_SMTP

    At the very least, we can then look at all of the changes to identify
    where potential regression occurred.

    Secondly, can I get you to verify that the version of imp you were using
    previously is 4.3.9 - there's a reasonable
    chance that configuration in is no longer set up the same way or
    otherwise changed in some subtle way.

    Thirdly, can I get you to try to make a small reproducible test case
    using only Net_SMTP & the assorted credentials - we
    can use to 100% verify it is Net_SMTP which is the problem; and to prove
    any fixes that are made are tested.

    ------------------------------------------------------------------------

    [2011-06-11 21:13:12] rhsoftware

    Description:
    ------------
    After upgrade ok: channel://pear.php.net/Net_SMTP-1.6.0 SMTP-Auth for
    Horde-Webmail (IMP H3 4.3.9) is broken, means it does not try
    authentication and that is why postfix rejects

    [SMTP: Invalid response code received from server (code: 554, response:
    5.7.1 <buildserver.thelounge.net[10.0.0.103]>: Client host rejected:
    Access denied 5.7.1

    this is sure a PEAR-Problem because after rsync a backup from
    /usr/share/pear it works again without touching any configuration

    $conf['mailer']['params']['host'] = 'backup-dbmail.thelounge.net';
    $conf['mailer']['params']['port'] = 587;
    $conf['mailer']['params']['auth'] = 'DIGEST-MD5';
    $conf['mailer']['params']['username'] = 'webmail@thelounge.net';
    $conf['mailer']['params']['password'] = '***********';
    $conf['mailer']['type'] = 'smtp';

    sorry but this is a basic-function of smtp which should not be broken by
    any update and only luck let find users such things after "pear upgrade"
    because you can never test anything a webapp is doing

    why can a fucking "pear upgrade" in the terminal not show what apckages
    are available and after confirm do an update - this is a blind butcher


    Expected result:
    ----------------
    send a message

    Actual result:
    --------------
    smtp-auth is ignored and message rejected

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedJun 17, '11 at 5:53a
activeJun 18, '11 at 11:27a
posts5
users3
websitepear.php.net

3 users in discussion

Daniel Oconnor: 2 posts Spam2: 2 posts Jon: 1 post

People

Translate

site design / logo © 2021 Grokbase