FAQ
Hello,

I scoured the web trying to find a solution to this problem. If this
question has been posted before, please pardon me.

So, basically I custom compiled PHP 5.3.4 with this command on my
64-bit Ubuntu 2.6.32-31-server 10.04.2 Server with the latest updates
applied. I am trying to compile PHP to handle large files (2GB+). The
installation goes well if I compile PHP without the CFLAGS. Also, the
version of the PHP doesn't matter either--I have the same problem if I
try to compile 5.2.11.


[COMMANDS]

cd /usr/local/src/; rm * -fR; cd /usr/local/src/;wget
http://us.php.net/distributions/php-5.3.4.tar.gz;wget
http://download.suhosin.org/suhosin-patch-5.3.4-0.9.10.patch.gz
cd /usr/local/src/; rm php-5.3.4/ -fR; tar -xzf php-5.3.4.tar.gz;
gunzip suhosin-patch-5.3.4-0.9.10.patch.gz;
cd php-5.3.4/; patch -p 1 -i ../suhosin-patch-5.3.4-0.9.10.patch
;touch ac* ;./buildconf --force

cd /usr/local/src/php-5.3.4/; CFLAGS="-D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64" ./configure --prefix=/usr
--with-config-file-path=/etc/php5/cgi
--with-config-file-scan-dir=/etc/php5/cgi/conf.d
--mandir=/usr/share/man --disable-debug --disable-pdo --disable-rpath
--disable-static --enable-bcmath --enable-calendar --enable-ctype
--enable-dbx --enable-discard-path --enable-exif --enable-fastcgi
--enable-filepro --enable-force-redirect --enable-ftp
--enable-gd-native-ttf --enable-inline-optimization --enable-mbregex
--enable-mbstring --enable-memcache --enable-memory-limit
--enable-pcntl --enable-pic --enable-session --enable-shmop
--enable-simplexml --enable-soap --enable-sockets --enable-suhosin
--enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-track-vars
--enable-trans-sid --enable-wddx --enable-xslt --enable-zip --with-bz2
--with-curl=shared,/usr --with-curlwrappers
--with-exec-dir=/usr/lib/php5/libexec --with-freetype-dir=shared,/usr
--with-gd=shared,/usr --with-gettext --with-gmp=shared,/usr
--with-iconv --with-jpeg-dir=shared,/usr --with-kerberos=/usr
--with-layout=GNU --with-libxml-dir=/usr --with-mcrypt
--with-mhash=shared,/usr --with-mime-magic=/usr/share/file/magic.mime
--with-mysql=shared,/usr --with-mysqli=shared,/usr/bin/mysql_config
--with-openssl=/usr --without-gdbm --without-mm --without-pdo-sqlite
--without-sqlite --with-pcre-regex=/usr --with-pear=/usr/share/php
--with-pic --with-png-dir=shared,/usr --with-regex=php
--with-system-tzdata --with-tidy=shared,/usr --with-ttf=shared,/usr
--with-xml --with-xmlrpc=shared --with-xpm-dir=shared
--with-xsl=shared,/usr --with-zlib;make; make install

[/COMMANDS]

I then issued these commands to install PHP extensions:

[COMMANDS]
pear update-channels;pecl uninstall apc;pecl install apc;pear upgrade
PEAR; pear install HTTP; pear install HTTP_Download; pear install
HTTP_Header; pear install MIME_Type; pecl install pecl_http
[/COMMANDS]

However, I see that "pecl install XXX" doesn't do any good. i.e. does
not install or compile the extensions I need. This is the output I
got:

[QUOTE]
root@web1:/usr# pear update-channels;pecl uninstall apc;pecl install
apc;pear upgrade PEAR; pear install HTTP; pear install HTTP_Download;
pear install HTTP_Header; pear install MIME_Type; pecl install
pecl_http
Updating channel "doc.php.net"
Channel "doc.php.net" is up to date
Updating channel "pear.php.net"
Channel "pear.php.net" is up to date
Updating channel "pecl.php.net"
Channel "pecl.php.net" is up to date
pecl/apc not installed
downloading APC-3.1.6.tgz ...
Starting to download APC-3.1.6.tgz (148,835 bytes)
.................................done: 148,835 bytes
downloading PEAR-1.9.2.tgz ...
Starting to download PEAR-1.9.2.tgz (295,120 bytes)
.............................................................done: 295,120 bytes
downloading HTTP-1.4.1.tgz ...
Starting to download HTTP-1.4.1.tgz (8,635 bytes)
.....done: 8,635 bytes
Did not download optional dependencies: pear/Archive_Zip,
pear/MIME_Type, use --alldeps to download automatically
pear/HTTP_Download can optionally use package "pear/Archive_Zip"
pear/HTTP_Download can optionally use package "pear/MIME_Type"
pear/HTTP_Download can optionally use PHP extension "mime_magic"
pear/HTTP_Download can optionally use PHP extension "pgsql"
downloading HTTP_Download-1.1.4.tgz ...
Starting to download HTTP_Download-1.1.4.tgz (14,571 bytes)
.....done: 14,571 bytes
downloading HTTP_Header-1.2.1.tgz ...
Starting to download HTTP_Header-1.2.1.tgz (10,682 bytes)
.....done: 10,682 bytes
Did not download optional dependencies: pear/System_Command, use
--alldeps to download automatically
pear/MIME_Type can optionally use package "pear/System_Command"
downloading MIME_Type-1.2.1.tgz ...
Starting to download MIME_Type-1.2.1.tgz (11,609 bytes)
.....done: 11,609 bytes
downloading pecl_http-1.7.0.tgz ...
Starting to download pecl_http-1.7.0.tgz (173,979 bytes)
.....................................done: 173,979 bytes
root@web1:/usr#
[/QUOTE]

I checked to make sure that "noexec" is not set on /etc/fstab for /tmp/ folder.

Please advise as to what is going on here?

Someone else is facing the same problem on the link I am facing and I
do not wish to go through the custom compile route. Here's the link:

http://www.linuxquestions.org/questions/linux-server-73/pecl-install-wont-work-840608/

Thanks so much!

Bill

Search Discussions

  • Bill G at May 10, 2011 at 6:21 am
    Hello,

    I scoured the web trying to find a solution to this problem. If this
    question has been posted before, please pardon me.

    So, basically I custom compiled PHP 5.3.4 with this command on my
    64-bit Ubuntu 2.6.32-31-server 10.04.2 Server with the latest updates
    applied. I am trying to compile PHP to handle large files (2GB+). The
    installation goes well if I compile PHP without the CFLAGS (This
    doesn't give me the support to handle large files). Also, the version
    of the PHP doesn't matter either--I have the same problem if I try to
    compile 5.2.11.


    [COMMANDS]
    cd /usr/local/src/; rm * -fR; cd /usr/local/src/;wget
    http://us.php.net/distributions/php-5.3.4.tar.gz;wget
    http://download.suhosin.org/suhosin-patch-5.3.4-0.9.10.patch.gz
    cd /usr/local/src/; rm php-5.3.4/ -fR; tar -xzf php-5.3.4.tar.gz;
    gunzip suhosin-patch-5.3.4-0.9.10.patch.gz;
    cd php-5.3.4/; patch -p 1 -i ../suhosin-patch-5.3.4-0.9.10.patch
    ;touch ac* ;./buildconf --force
    cd /usr/local/src/php-5.3.4/; CFLAGS="-D_LARGEFILE_SOURCE
    -D_FILE_OFFSET_BITS=64" ./configure --prefix=/usr
    --with-config-file-path=/etc/php5/cgi
    --with-config-file-scan-dir=/etc/php5/cgi/conf.d
    --mandir=/usr/share/man --disable-debug --disable-pdo --disable-rpath
    --disable-static --enable-bcmath --enable-calendar --enable-ctype
    --enable-dbx --enable-discard-path --enable-exif --enable-fastcgi
    --enable-filepro --enable-force-redirect --enable-ftp
    --enable-gd-native-ttf --enable-inline-optimization --enable-mbregex
    --enable-mbstring --enable-memcache --enable-memory-limit
    --enable-pcntl --enable-pic --enable-session --enable-shmop
    --enable-simplexml --enable-soap --enable-sockets --enable-suhosin
    --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-track-vars
    --enable-trans-sid --enable-wddx --enable-xslt --enable-zip --with-bz2
    --with-curl=shared,/usr --with-curlwrappers
    --with-exec-dir=/usr/lib/php5/libexec --with-freetype-dir=shared,/usr
    --with-gd=shared,/usr --with-gettext --with-gmp=shared,/usr
    --with-iconv --with-jpeg-dir=shared,/usr --with-kerberos=/usr
    --with-layout=GNU --with-libxml-dir=/usr --with-mcrypt
    --with-mhash=shared,/usr --with-mime-magic=/usr/share/file/magic.mime
    --with-mysql=shared,/usr --with-mysqli=shared,/usr/bin/mysql_config
    --with-openssl=/usr --without-gdbm --without-mm --without-pdo-sqlite
    --without-sqlite --with-pcre-regex=/usr --with-pear=/usr/share/php
    --with-pic --with-png-dir=shared,/usr --with-regex=php
    --with-system-tzdata --with-tidy=shared,/usr --with-ttf=shared,/usr
    --with-xml --with-xmlrpc=shared --with-xpm-dir=shared
    --with-xsl=shared,/usr --with-zlib;make; make install
    [/COMMANDS]

    I then issued this command to install PHP extensions:

    [COMMANDS]
    pear update-channels;pecl uninstall apc;pecl install apc;pear upgrade
    PEAR; pear install HTTP; pear install HTTP_Download; pear install
    HTTP_Header; pear install MIME_Type; pecl install pecl_http
    [/COMMANDS]

    However, I see that "pecl install XXX" doesn't do any good. i.e. does
    not install or compile the extensions I need. This is the output I
    got:

    [QUOTE]
    root@web1:/usr# pear update-channels;pecl uninstall apc;pecl install
    apc;pear upgrade PEAR; pear install HTTP; pear install HTTP_Download;
    pear install HTTP_Header; pear install MIME_Type; pecl install
    pecl_http
    Updating channel "doc.php.net"
    Channel "doc.php.net" is up to date
    Updating channel "pear.php.net"
    Channel "pear.php.net" is up to date
    Updating channel "pecl.php.net"
    Channel "pecl.php.net" is up to date
    pecl/apc not installed
    downloading APC-3.1.6.tgz ...
    Starting to download APC-3.1.6.tgz (148,835 bytes)
    .................................done: 148,835 bytes
    downloading PEAR-1.9.2.tgz ...
    Starting to download PEAR-1.9.2.tgz (295,120 bytes)
    .............................................................done: 295,120 bytes
    downloading HTTP-1.4.1.tgz ...
    Starting to download HTTP-1.4.1.tgz (8,635 bytes)
    .....done: 8,635 bytes
    Did not download optional dependencies: pear/Archive_Zip,
    pear/MIME_Type, use --alldeps to download automatically
    pear/HTTP_Download can optionally use package "pear/Archive_Zip"
    pear/HTTP_Download can optionally use package "pear/MIME_Type"
    pear/HTTP_Download can optionally use PHP extension "mime_magic"
    pear/HTTP_Download can optionally use PHP extension "pgsql"
    downloading HTTP_Download-1.1.4.tgz ...
    Starting to download HTTP_Download-1.1.4.tgz (14,571 bytes)
    .....done: 14,571 bytes
    downloading HTTP_Header-1.2.1.tgz ...
    Starting to download HTTP_Header-1.2.1.tgz (10,682 bytes)
    .....done: 10,682 bytes
    Did not download optional dependencies: pear/System_Command, use
    --alldeps to download automatically
    pear/MIME_Type can optionally use package "pear/System_Command"
    downloading MIME_Type-1.2.1.tgz ...
    Starting to download MIME_Type-1.2.1.tgz (11,609 bytes)
    .....done: 11,609 bytes
    downloading pecl_http-1.7.0.tgz ...
    Starting to download pecl_http-1.7.0.tgz (173,979 bytes)
    .....................................done: 173,979 bytes
    root@web1:/usr#
    [/QUOTE]

    I checked to make sure that "noexec" is not set on /etc/fstab for /tmp/ folder.

    Please advise as to what is going on here?

    Someone else is facing the same problem on the link I am facing and I
    do not wish to go through the custom compile route. Here's the link:

    http://www.linuxquestions.org/questions/linux-server-73/pecl-install-wont-work-840608/

    Thanks so much!

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedMay 10, '11 at 6:18a
activeMay 10, '11 at 6:21a
posts2
users1
websitepear.php.net

1 user in discussion

Bill G: 2 posts

People

Translate

site design / logo © 2021 Grokbase