FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=18030&edit=1

ID: 18030
Updated by: pear@sebastianmendel.de
Reported By: rgoyard at gmail dot com
Summary: Executing phpcs crashes with fatal error
Status: No Feedback
Type: Bug
Package: PHP_CodeSniffer
Operating System: Debian Lenny 5.0.6
Package Version: 1.3.0RC1
PHP Version: 5.2.6
Assigned To: squiz
Roadmap Versions:
New Comment:

We had the same problem and it got solved by uninstalling phpcs first.


Previous Comments:
------------------------------------------------------------------------

[2010-11-19 03:59:56] squiz

-Status: Feedback
+Status: No Feedback


------------------------------------------------------------------------

[2010-11-09 23:58:51] squiz

-Status: Open
+Status: Feedback
-Assigned To:
+Assigned To: squiz
I think you may still have old files from a previous install as the
PEAR_Sniffs_Files_LineLengthSniff has been removed. This would happen if
you force installed or something went wrong with the PEAR installer and
it didn't remove deleted files.

I suggest you uninstall PHP_CodeSniffer and make sure the PEAR directory
has been removed (normally something like:
/usr/local/PEAR/PHP/CodeSniffer). The directory should not exist after
an uninstall, so remove it if it does.

Then install phpcs again using PEAR or SVN.

Let me know if that works please.

------------------------------------------------------------------------

[2010-11-08 14:55:54] mimizfr

Description:
------------
Hi,
I've just tried to update phpcs to version 1.3.0RC1 and it
crashes with this fatal error :

Fatal error: Access level to
PEAR_Sniffs_Files_LineLengthSniff::$lineLimit must be public
(as in class Generic_Sniffs_Files_LineLengthSniff) in
/usr/share/php/PHP/CodeSniffer/Standards/PEAR/Sniffs/Files/
LineLengthSniff.php on line 36

Regards

mimiz

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedDec 17, '10 at 2:38p
activeDec 17, '10 at 2:38p
posts1
users1
websitepear.php.net

1 user in discussion

Pear: 1 post

People

Translate

site design / logo © 2022 Grokbase