FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=18001&edit=1

ID: 18001
Updated by: helgith@gmail.com
Reported By: warnar at dmmw dot nl
Summary: PEAR/RunTest coverage fails
-Status: Open
+Status: Closed
Type: Bug
Package: PEAR
Operating System: Windows 7 x64
Package Version: 1.9.1
PHP Version: 5.3.1
-Assigned To:
+Assigned To: dufuz
Roadmap Versions:
New Comment:

-Status: Open
+Status: Closed
-Assigned To:
+Assigned To: dufuz
This bug has been fixed in SVN.

If this was a documentation problem, the fix will appear on pear.php.net
by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should
be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.




Previous Comments:
------------------------------------------------------------------------

[2010-10-26 22:51:31] boekkooi

Description:
------------
When trying to run a test with coverage no xdebug file is generated.

Quickfix is goto line 373 and `'<?php'` to the string then change line
409 to `$this->save_text($temp_file, $text . "<?php\n" . $namespace .
join("\n", $lines));`.

Test script:
---------------
Run a test with coverage.

Expected result:
----------------
A xdebug file

Actual result:
--------------
No xdebug file

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedNov 16, '10 at 1:58a
activeNov 16, '10 at 1:58a
posts1
users1
websitepear.php.net

1 user in discussion

Helgith: 1 post

People

Translate

site design / logo © 2022 Grokbase