FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=18052&edit=1

ID: 18052
Updated by: gsherwood@squiz.net
Reported By: missotten dot michiel at gmail dot com
Summary: Missing option
-Status: Open
+Status: Bogus
Type: Bug
Package: PHP_CodeSniffer
Operating System: Debian
Package Version: 1.2.2
PHP Version: 5.3.0
-Assigned To:
+Assigned To: squiz
Roadmap Versions:
New Comment:

-Status: Open
+Status: Bogus
-Assigned To:
+Assigned To: squiz
This option is only available in the current SVN version. You'll need to
wait for the next release.


Previous Comments:
------------------------------------------------------------------------

[2010-11-13 22:27:00] zenklys

Description:
------------
The "-d" option from command line is not recognised.


Test script:
---------------
Simply execute :
phpcs -d memory_limit=64M



Expected result:
----------------
It should run normally increasing memory.

Actual result:
--------------
phpcs -d
ERROR: option "-d" not known.

------------------------------------------------------------------------

Search Discussions

  • Gsherwood at Nov 13, 2010 at 9:40 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=18052&edit=1

    ID: 18052
    Updated by: gsherwood@squiz.net
    Reported By: missotten dot michiel at gmail dot com
    Summary: Missing option
    -Status: Bogus
    +Status: Feedback
    Type: Bug
    Package: PHP_CodeSniffer
    Operating System: Debian
    Package Version: 1.2.2
    PHP Version: 5.3.0
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    -Status: Bogus
    +Status: Feedback
    Wrong status, too close together :)


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-11-13 22:39:17] squiz

    -Status: Open
    +Status: Bogus
    -Assigned To:
    +Assigned To: squiz
    This option is only available in the current SVN version. You'll need to
    wait for the next release.

    ------------------------------------------------------------------------

    [2010-11-13 22:27:00] zenklys

    Description:
    ------------
    The "-d" option from command line is not recognised.


    Test script:
    ---------------
    Simply execute :
    phpcs -d memory_limit=64M



    Expected result:
    ----------------
    It should run normally increasing memory.

    Actual result:
    --------------
    phpcs -d
    ERROR: option "-d" not known.

    ------------------------------------------------------------------------
  • Missotten Michiel at Nov 13, 2010 at 10:07 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=18052&edit=1

    ID: 18052
    Comment by: missotten.michiel@gmail.com
    Reported By: missotten dot michiel at gmail dot com
    Summary: Missing option
    Status: Feedback
    Type: Bug
    Package: PHP_CodeSniffer
    Operating System: Debian
    Package Version: 1.2.2
    PHP Version: 5.3.0
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    Ok. No precision of that in the documentation.

    - Any other way to increase memory_limit ?
    - Is next release is already planned ?


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-11-13 22:41:44] squiz

    -Status: Bogus
    +Status: Feedback
    Wrong status, too close together :)

    ------------------------------------------------------------------------

    [2010-11-13 22:39:17] squiz

    -Status: Open
    +Status: Bogus
    -Assigned To:
    +Assigned To: squiz
    This option is only available in the current SVN version. You'll need to
    wait for the next release.

    ------------------------------------------------------------------------

    [2010-11-13 22:27:00] zenklys

    Description:
    ------------
    The "-d" option from command line is not recognised.


    Test script:
    ---------------
    Simply execute :
    phpcs -d memory_limit=64M



    Expected result:
    ----------------
    It should run normally increasing memory.

    Actual result:
    --------------
    phpcs -d
    ERROR: option "-d" not known.

    ------------------------------------------------------------------------
  • Gsherwood at Nov 16, 2010 at 11:06 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=18052&edit=1

    ID: 18052
    Updated by: gsherwood@squiz.net
    Reported By: missotten dot michiel at gmail dot com
    Summary: Missing option
    -Status: Feedback
    +Status: Bogus
    -Type: Bug
    +Type: Feature/Change Request
    Package: PHP_CodeSniffer
    Operating System: Debian
    Package Version: 1.2.2
    PHP Version: 5.3.0
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    -Status: Feedback
    +Status: Bogus
    -Type: Bug
    +Type: Feature/Change Request
    A workaround is available in the original bug report:
    http://pear.php.net/bugs/bug.php?id=17244

    No release date is currently set.


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-11-13 23:08:37] zenklys

    Ok. No precision of that in the documentation.

    - Any other way to increase memory_limit ?
    - Is next release is already planned ?

    ------------------------------------------------------------------------

    [2010-11-13 22:41:44] squiz

    -Status: Bogus
    +Status: Feedback
    Wrong status, too close together :)

    ------------------------------------------------------------------------

    [2010-11-13 22:39:17] squiz

    -Status: Open
    +Status: Bogus
    -Assigned To:
    +Assigned To: squiz
    This option is only available in the current SVN version. You'll need to
    wait for the next release.

    ------------------------------------------------------------------------

    [2010-11-13 22:27:00] zenklys

    Description:
    ------------
    The "-d" option from command line is not recognised.


    Test script:
    ---------------
    Simply execute :
    phpcs -d memory_limit=64M



    Expected result:
    ----------------
    It should run normally increasing memory.

    Actual result:
    --------------
    phpcs -d
    ERROR: option "-d" not known.

    ------------------------------------------------------------------------
  • Missotten Michiel at Nov 17, 2010 at 12:10 am
    Edit report at http://pear.php.net/bugs/bug.php?id=18052&edit=1

    ID: 18052
    Updated by: missotten.michiel@gmail.com
    Reported By: missotten dot michiel at gmail dot com
    Summary: Missing option
    Status: Bogus
    Type: Feature/Change Request
    Package: PHP_CodeSniffer
    Operating System: Debian
    Package Version: 1.2.2
    PHP Version: 5.3.0
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    Just in case someone else is having problems with this :
    On Debian/Ubuntu systems, you have to increase php memory size for CLI.

    (Command Line Interface). The php.ini file can generally be found here
    /etc/php5/cli/php.ini


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-11-17 00:07:48] squiz

    -Status: Feedback
    +Status: Bogus
    -Type: Bug
    +Type: Feature/Change Request
    A workaround is available in the original bug report:
    http://pear.php.net/bugs/bug.php?id=17244

    No release date is currently set.

    ------------------------------------------------------------------------

    [2010-11-13 23:08:37] zenklys

    Ok. No precision of that in the documentation.

    - Any other way to increase memory_limit ?
    - Is next release is already planned ?

    ------------------------------------------------------------------------

    [2010-11-13 22:41:44] squiz

    -Status: Bogus
    +Status: Feedback
    Wrong status, too close together :)

    ------------------------------------------------------------------------

    [2010-11-13 22:39:17] squiz

    -Status: Open
    +Status: Bogus
    -Assigned To:
    +Assigned To: squiz
    This option is only available in the current SVN version. You'll need to
    wait for the next release.

    ------------------------------------------------------------------------

    [2010-11-13 22:27:00] zenklys

    Description:
    ------------
    The "-d" option from command line is not recognised.


    Test script:
    ---------------
    Simply execute :
    phpcs -d memory_limit=64M



    Expected result:
    ----------------
    It should run normally increasing memory.

    Actual result:
    --------------
    phpcs -d
    ERROR: option "-d" not known.

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedNov 13, '10 at 9:38p
activeNov 17, '10 at 12:10a
posts5
users3
websitepear.php.net

People

Translate

site design / logo © 2022 Grokbase