FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=18030&edit=1

ID: 18030
Updated by: gsherwood@squiz.net
Reported By: rgoyard at gmail dot com
Summary: Executing phpcs crashes with fatal error
-Status: Open
+Status: Feedback
Type: Bug
Package: PHP_CodeSniffer
Operating System: Debian Lenny 5.0.6
Package Version: 1.3.0RC1
PHP Version: 5.2.6
-Assigned To:
+Assigned To: squiz
Roadmap Versions:
New Comment:

-Status: Open
+Status: Feedback
-Assigned To:
+Assigned To: squiz
I think you may still have old files from a previous install as the
PEAR_Sniffs_Files_LineLengthSniff has been removed. This would happen if
you force installed or something went wrong with the PEAR installer and
it didn't remove deleted files.

I suggest you uninstall PHP_CodeSniffer and make sure the PEAR directory
has been removed (normally something like:
/usr/local/PEAR/PHP/CodeSniffer). The directory should not exist after
an uninstall, so remove it if it does.

Then install phpcs again using PEAR or SVN.

Let me know if that works please.


Previous Comments:
------------------------------------------------------------------------

[2010-11-08 14:55:54] mimizfr

Description:
------------
Hi,
I've just tried to update phpcs to version 1.3.0RC1 and it
crashes with this fatal error :

Fatal error: Access level to
PEAR_Sniffs_Files_LineLengthSniff::$lineLimit must be public
(as in class Generic_Sniffs_Files_LineLengthSniff) in
/usr/share/php/PHP/CodeSniffer/Standards/PEAR/Sniffs/Files/
LineLengthSniff.php on line 36

Regards

mimiz

------------------------------------------------------------------------

Search Discussions

  • Gsherwood at Nov 19, 2010 at 2:59 am
    Edit report at http://pear.php.net/bugs/bug.php?id=18030&edit=1

    ID: 18030
    Updated by: gsherwood@squiz.net
    Reported By: rgoyard at gmail dot com
    Summary: Executing phpcs crashes with fatal error
    -Status: Feedback
    +Status: No Feedback
    Type: Bug
    Package: PHP_CodeSniffer
    Operating System: Debian Lenny 5.0.6
    Package Version: 1.3.0RC1
    PHP Version: 5.2.6
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    -Status: Feedback
    +Status: No Feedback



    Previous Comments:
    ------------------------------------------------------------------------

    [2010-11-09 23:58:51] squiz

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: squiz
    I think you may still have old files from a previous install as the
    PEAR_Sniffs_Files_LineLengthSniff has been removed. This would happen if
    you force installed or something went wrong with the PEAR installer and
    it didn't remove deleted files.

    I suggest you uninstall PHP_CodeSniffer and make sure the PEAR directory
    has been removed (normally something like:
    /usr/local/PEAR/PHP/CodeSniffer). The directory should not exist after
    an uninstall, so remove it if it does.

    Then install phpcs again using PEAR or SVN.

    Let me know if that works please.

    ------------------------------------------------------------------------

    [2010-11-08 14:55:54] mimizfr

    Description:
    ------------
    Hi,
    I've just tried to update phpcs to version 1.3.0RC1 and it
    crashes with this fatal error :

    Fatal error: Access level to
    PEAR_Sniffs_Files_LineLengthSniff::$lineLimit must be public
    (as in class Generic_Sniffs_Files_LineLengthSniff) in
    /usr/share/php/PHP/CodeSniffer/Standards/PEAR/Sniffs/Files/
    LineLengthSniff.php on line 36

    Regards

    mimiz

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedNov 9, '10 at 10:58p
activeNov 19, '10 at 2:59a
posts2
users1
websitepear.php.net

1 user in discussion

Gsherwood: 2 posts

People

Translate

site design / logo © 2022 Grokbase