FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=17823&edit=1

ID: 17823
Updated by: gsherwood@squiz.net
Reported By: blueduck at gmx dot net
Summary: Notice: Please no longer include
"PHPUnit/Framework.php".
-Status: Open
+Status: Closed
Type: Bug
Package: PHP_CodeSniffer
Operating System: OSX 10.6
Package Version: 1.3.0a1
PHP Version: 5.3.3
-Assigned To:
+Assigned To: squiz
Roadmap Versions:
New Comment:

-Status: Open
+Status: Closed
-Assigned To:
+Assigned To: squiz
This bug has been fixed in SVN.

If this was a documentation problem, the fix will appear on pear.php.net
by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should
be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.

It does not appear to cause any issues in the current stable version, so
I just removed it.


Previous Comments:
------------------------------------------------------------------------

[2010-08-26 11:15:27] konafets

Description:
------------
I use PHPCS together with the PHPUnit 3.5.0RC1 and got this error:
Notice: Please no longer include "PHPUnit/Framework.php". in
/usr/lib/php/PHPUnit/Framework.php on line 51

I remove the inlude in PHP_CodeSniffer/tests/TestSuite.php and the error
is gone. I am not sure what happens if you remove this in PHPCS and use
this togehter with PHPUnit 3.4.x. so I assume you have to implement an
detection for the PHPUnit version.

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedAug 26, '10 at 11:54p
activeAug 26, '10 at 11:54p
posts1
users1
websitepear.php.net

1 user in discussion

Gsherwood: 1 post

People

Translate

site design / logo © 2022 Grokbase