FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=17775&edit=1

ID: 17775
Updated by: janisto@php.net
Reported By: janisto at php dot net
Summary: Uses deprecated function split()
Status: Open
Type: Bug
Package: Validate_FI
Operating System: Windows 7
Package Version: 0.4.0
PHP Version: 5.3.3
-Assigned To:
+Assigned To: janisto
Roadmap Versions:
New Comment:

-Assigned To:
+Assigned To: janisto



Previous Comments:
------------------------------------------------------------------------

[2010-08-21 11:34:19] janisto

Description:
------------
Validate/FI.php uses split(), which is deprecated since PHP 5.3.0
http://php.net/manual/en/function.split.php

Test script:
---------------
require_once 'Validate/FI.php';
$businessId = '1572860-0';
if ( Validate_FI::businessId($businessId) ) {
print 'Valid';
} else {
print 'Not valid!';
}

Expected result:
----------------
Valid

Actual result:
--------------
Deprecated: Function split() is deprecated in
C:\xampp\php\PEAR\Validate\FI.php on line 363
Valid

------------------------------------------------------------------------

Search Discussions

  • Janisto at Aug 21, 2010 at 1:53 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=17775&edit=1

    ID: 17775
    Updated by: janisto@php.net
    Reported By: janisto at php dot net
    Summary: Uses deprecated function split()
    -Status: Assigned
    +Status: Closed
    Type: Bug
    Package: Validate_FI
    Operating System: Windows 7
    Package Version: 0.4.0
    PHP Version: 5.3.3
    Assigned To: janisto
    Roadmap Versions:
    New Comment:

    -Status: Assigned
    +Status: Closed
    Thank you for your bug report. This issue has been fixed
    in the latest released version of the package, which you can download at
    http://pear.php.net/get/

    Fixed in 1.0.0 (stable)


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-08-21 11:35:16] janisto

    -Assigned To:
    +Assigned To: janisto


    ------------------------------------------------------------------------

    [2010-08-21 11:34:19] janisto

    Description:
    ------------
    Validate/FI.php uses split(), which is deprecated since PHP 5.3.0
    http://php.net/manual/en/function.split.php

    Test script:
    ---------------
    require_once 'Validate/FI.php';
    $businessId = '1572860-0';
    if ( Validate_FI::businessId($businessId) ) {
    print 'Valid';
    } else {
    print 'Not valid!';
    }

    Expected result:
    ----------------
    Valid

    Actual result:
    --------------
    Deprecated: Function split() is deprecated in
    C:\xampp\php\PEAR\Validate\FI.php on line 363
    Valid

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedAug 21, '10 at 11:35a
activeAug 21, '10 at 1:53p
posts2
users1
websitepear.php.net

1 user in discussion

Janisto: 2 posts

People

Translate

site design / logo © 2022 Grokbase