FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=17776&edit=1

ID: 17776
Updated by: janisto@php.net
Reported By: janisto at php dot net
Summary: Uses deprecated functions ereg() and ereg_replace()
Status: Open
Type: Bug
Package: Validate_FI
Operating System: Windows 7
Package Version: SVN
PHP Version: 5.3.3
-Assigned To:
+Assigned To: janisto
Roadmap Versions:
New Comment:

-Assigned To:
+Assigned To: janisto



Previous Comments:
------------------------------------------------------------------------

[2010-08-21 12:01:43] janisto

Description:
------------
Validate/FI.php uses ereg() and ereg_replace(), which are deprecated
since PHP 5.3.0
http://fi.php.net/manual/en/function.ereg.php
http://fi.php.net/manual/en/function.ereg-replace.php

Expected result:
----------------
Valid
Valid
Valid

Actual result:
--------------
Deprecated: Function ereg() is deprecated in
C:\xampp\php\PEAR\Validate\FI.php on line 530
Valid
Deprecated: Function ereg_replace() is deprecated in
C:\xampp\php\PEAR\Validate\FI.php on line 579
Valid
Deprecated: Function ereg_replace() is deprecated in
C:\xampp\php\PEAR\Validate\FI.php on line 644
Valid

------------------------------------------------------------------------

Search Discussions

  • Janisto at Aug 21, 2010 at 1:54 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=17776&edit=1

    ID: 17776
    Updated by: janisto@php.net
    Reported By: janisto at php dot net
    Summary: Uses deprecated functions ereg() and ereg_replace()
    -Status: Assigned
    +Status: Closed
    Type: Bug
    Package: Validate_FI
    Operating System: Windows 7
    Package Version: SVN
    PHP Version: 5.3.3
    Assigned To: janisto
    Roadmap Versions:
    New Comment:

    -Status: Assigned
    +Status: Closed
    Thank you for your bug report. This issue has been fixed
    in the latest released version of the package, which you can download at
    http://pear.php.net/get/

    Fixed in 1.0.0 (stable)


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-08-21 12:01:56] janisto

    -Assigned To:
    +Assigned To: janisto


    ------------------------------------------------------------------------

    [2010-08-21 12:01:43] janisto

    Description:
    ------------
    Validate/FI.php uses ereg() and ereg_replace(), which are deprecated
    since PHP 5.3.0
    http://fi.php.net/manual/en/function.ereg.php
    http://fi.php.net/manual/en/function.ereg-replace.php

    Expected result:
    ----------------
    Valid
    Valid
    Valid

    Actual result:
    --------------
    Deprecated: Function ereg() is deprecated in
    C:\xampp\php\PEAR\Validate\FI.php on line 530
    Valid
    Deprecated: Function ereg_replace() is deprecated in
    C:\xampp\php\PEAR\Validate\FI.php on line 579
    Valid
    Deprecated: Function ereg_replace() is deprecated in
    C:\xampp\php\PEAR\Validate\FI.php on line 644
    Valid

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedAug 21, '10 at 12:02p
activeAug 21, '10 at 1:54p
posts2
users1
websitepear.php.net

1 user in discussion

Janisto: 2 posts

People

Translate

site design / logo © 2022 Grokbase