FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=17535&edit=1

ID: 17535
Updated by: brett.bieber@gmail.com
Reported By: tim at timj dot co dot uk
Summary: "pear upgrade" unnecessarily upgrades dependencies
Status: Open
Type: Bug
Package: PEAR
Package Version: 1.9.1
PHP Version: Irrelevant
Roadmap Versions:
New Comment:

In the example cited the dependency has a minimum version, not a maximum
or specific version. Packages CAN specify specific versions as well as
maximum versions, and the installer will respect that. There should be
no risk of upgrading the dependencies and this allows bugfixes and
security fixes to get out.


Previous Comments:
------------------------------------------------------------------------

[2010-06-29 13:01:04] timj

Description:
------------
"pear upgrade" unnecessarily upgrades dependencies of the package being
upgraded.

e.g. assume that the following is installed:

A-1.0.0 (depends on B-1.0.0)
B-1.0.0

The channel server has:
A-1.0.1 (depends on B-1.0.0)
B-1.0.1

"pear upgrade A" will also upgrade B to v1.0.1, without warning. This is
unexpected (the user didn't ask to upgrade B) and unnecessary (there is
no dependency on the newer version). It would be better just to warn
that a new version of B is available.

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedJun 29, '10 at 3:45p
activeJun 29, '10 at 3:45p
posts1
users1
websitepear.php.net

1 user in discussion

Brett Bieber: 1 post

People

Translate

site design / logo © 2021 Grokbase