FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=17323&edit=1

ID: 17323
Updated by: borz_off@cs.msu.su
Reported By: justin at company dot cloud9living dot com
Summary: Magic Quotes Check is Incorrect
-Status: Open
+Status: Feedback
Type: Bug
Package: HTTP_Request2
Operating System: Linux Fedora Core 7
Package Version: 0.5.1
PHP Version: 5.2.12
Roadmap Versions:
New Comment:

-Status: Open
+Status: Feedback
Please clarify: what is the result of running
var_dump(ini_get('magic_quotes_runtime'));
on your system?


Previous Comments:
------------------------------------------------------------------------

[2010-04-19 23:21:24] cloud9living

Description:
------------
Line 820 in Request2.php is not a correct check and turns on magic
quotes every time it is run on my system. This creates havoc with any
DB requests called after the Request2.php function is loaded since I
have magic quotes off by default.

if ($magicQuotes) {
ini_set('magic_quotes_runtime', true);
}

Test script:
---------------
If the line is changed to the code below the check should be correct.
if ($magicQuotes === true) {
ini_set('magic_quotes_runtime', true);
}

------------------------------------------------------------------------

Search Discussions

  • Borz_off at Apr 21, 2010 at 7:46 am
    Edit report at http://pear.php.net/bugs/bug.php?id=17323&edit=1

    ID: 17323
    Updated by: borz_off@cs.msu.su
    Reported By: justin at company dot cloud9living dot com
    Summary: Magic Quotes Check is Incorrect
    -Status: Feedback
    +Status: Duplicate
    Type: Bug
    Package: HTTP_Request2
    Operating System: Linux Fedora Core 7
    Package Version: 0.5.1
    PHP Version: 5.2.12
    Roadmap Versions:
    New Comment:

    -Status: Feedback
    +Status: Duplicate
    Duplicate of bug #16440


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-04-20 07:10:07] avb

    -Status: Open
    +Status: Feedback
    Please clarify: what is the result of running
    var_dump(ini_get('magic_quotes_runtime'));
    on your system?

    ------------------------------------------------------------------------

    [2010-04-19 23:21:24] cloud9living

    Description:
    ------------
    Line 820 in Request2.php is not a correct check and turns on magic
    quotes every time it is run on my system. This creates havoc with any
    DB requests called after the Request2.php function is loaded since I
    have magic quotes off by default.

    if ($magicQuotes) {
    ini_set('magic_quotes_runtime', true);
    }

    Test script:
    ---------------
    If the line is changed to the code below the check should be correct.
    if ($magicQuotes === true) {
    ini_set('magic_quotes_runtime', true);
    }

    ------------------------------------------------------------------------
  • Justin at Apr 21, 2010 at 2:34 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=17323&edit=1

    ID: 17323
    Updated by: justin@company.cloud9living.com
    Reported By: justin at company dot cloud9living dot com
    Summary: Magic Quotes Check is Incorrect
    Status: Duplicate
    Type: Bug
    Package: HTTP_Request2
    Operating System: Linux Fedora Core 7
    Package Version: 0.5.1
    PHP Version: 5.2.12
    Roadmap Versions:
    New Comment:

    Below I have include my php.ini file as well as the result which you
    requested. This issue presents it self on Fedora Core 6 and 7 with PHP
    5.2.12 and Ubuntu 9.10 with PHP 5.2.10 all of which use the same php.ini
    settings listed below.

    //var_dump(ini_get('magic_quotes_runtime'));
    string(3) "Off"

    // /etc/php.ini
    ; Magic quotes
    ;

    ; Magic quotes for incoming GET/POST/Cookie data.
    magic_quotes_gpc = Off

    ; Magic quotes for runtime-generated data, e.g. data from SQL, from
    exec(), etc.
    magic_quotes_runtime = Off

    ; Use Sybase-style magic quotes (escape ' with '' instead of \').
    magic_quotes_sybase = Off


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-04-21 08:40:21] avb

    -Status: Feedback
    +Status: Duplicate
    Duplicate of bug #16440

    ------------------------------------------------------------------------

    [2010-04-20 07:10:07] avb

    -Status: Open
    +Status: Feedback
    Please clarify: what is the result of running
    var_dump(ini_get('magic_quotes_runtime'));
    on your system?

    ------------------------------------------------------------------------

    [2010-04-19 23:21:24] cloud9living

    Description:
    ------------
    Line 820 in Request2.php is not a correct check and turns on magic
    quotes every time it is run on my system. This creates havoc with any
    DB requests called after the Request2.php function is loaded since I
    have magic quotes off by default.

    if ($magicQuotes) {
    ini_set('magic_quotes_runtime', true);
    }

    Test script:
    ---------------
    If the line is changed to the code below the check should be correct.
    if ($magicQuotes === true) {
    ini_set('magic_quotes_runtime', true);
    }

    ------------------------------------------------------------------------
  • Borz_off at Apr 21, 2010 at 2:58 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=17323&edit=1

    ID: 17323
    Updated by: borz_off@cs.msu.su
    Reported By: justin at company dot cloud9living dot com
    Summary: Magic Quotes Check is Incorrect
    Status: Duplicate
    Type: Bug
    Package: HTTP_Request2
    Operating System: Linux Fedora Core 7
    Package Version: 0.5.1
    PHP Version: 5.2.12
    Roadmap Versions:
    New Comment:

    Please try running the new version 0.5.2, it should hopefully fix your
    problem.

    Seems like the issue wasn't with php.ini settings but rather the
    settings updated in httpd.conf / .htaccess


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-04-21 15:28:50] cloud9living

    Below I have include my php.ini file as well as the result which you
    requested. This issue presents it self on Fedora Core 6 and 7 with PHP
    5.2.12 and Ubuntu 9.10 with PHP 5.2.10 all of which use the same php.ini
    settings listed below.

    //var_dump(ini_get('magic_quotes_runtime'));
    string(3) "Off"

    // /etc/php.ini
    ; Magic quotes
    ;

    ; Magic quotes for incoming GET/POST/Cookie data.
    magic_quotes_gpc = Off

    ; Magic quotes for runtime-generated data, e.g. data from SQL, from
    exec(), etc.
    magic_quotes_runtime = Off

    ; Use Sybase-style magic quotes (escape ' with '' instead of \').
    magic_quotes_sybase = Off

    ------------------------------------------------------------------------

    [2010-04-21 08:40:21] avb

    -Status: Feedback
    +Status: Duplicate
    Duplicate of bug #16440

    ------------------------------------------------------------------------

    [2010-04-20 07:10:07] avb

    -Status: Open
    +Status: Feedback
    Please clarify: what is the result of running
    var_dump(ini_get('magic_quotes_runtime'));
    on your system?

    ------------------------------------------------------------------------

    [2010-04-19 23:21:24] cloud9living

    Description:
    ------------
    Line 820 in Request2.php is not a correct check and turns on magic
    quotes every time it is run on my system. This creates havoc with any
    DB requests called after the Request2.php function is loaded since I
    have magic quotes off by default.

    if ($magicQuotes) {
    ini_set('magic_quotes_runtime', true);
    }

    Test script:
    ---------------
    If the line is changed to the code below the check should be correct.
    if ($magicQuotes === true) {
    ini_set('magic_quotes_runtime', true);
    }

    ------------------------------------------------------------------------
  • Justin at Apr 21, 2010 at 3:09 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=17323&edit=1

    ID: 17323
    Updated by: justin@company.cloud9living.com
    Reported By: justin at company dot cloud9living dot com
    Summary: Magic Quotes Check is Incorrect
    Status: Duplicate
    Type: Bug
    Package: HTTP_Request2
    Operating System: Linux Fedora Core 7
    Package Version: 0.5.1
    PHP Version: 5.2.12
    Roadmap Versions:
    New Comment:

    The changed worked perfectly for me. Thanks for the quick resolution
    of this issue!


    Previous Comments:
    ------------------------------------------------------------------------

    [2010-04-21 15:52:54] avb

    Please try running the new version 0.5.2, it should hopefully fix your
    problem.

    Seems like the issue wasn't with php.ini settings but rather the
    settings updated in httpd.conf / .htaccess

    ------------------------------------------------------------------------

    [2010-04-21 15:28:50] cloud9living

    Below I have include my php.ini file as well as the result which you
    requested. This issue presents it self on Fedora Core 6 and 7 with PHP
    5.2.12 and Ubuntu 9.10 with PHP 5.2.10 all of which use the same php.ini
    settings listed below.

    //var_dump(ini_get('magic_quotes_runtime'));
    string(3) "Off"

    // /etc/php.ini
    ; Magic quotes
    ;

    ; Magic quotes for incoming GET/POST/Cookie data.
    magic_quotes_gpc = Off

    ; Magic quotes for runtime-generated data, e.g. data from SQL, from
    exec(), etc.
    magic_quotes_runtime = Off

    ; Use Sybase-style magic quotes (escape ' with '' instead of \').
    magic_quotes_sybase = Off

    ------------------------------------------------------------------------

    [2010-04-21 08:40:21] avb

    -Status: Feedback
    +Status: Duplicate
    Duplicate of bug #16440

    ------------------------------------------------------------------------

    [2010-04-20 07:10:07] avb

    -Status: Open
    +Status: Feedback
    Please clarify: what is the result of running
    var_dump(ini_get('magic_quotes_runtime'));
    on your system?

    ------------------------------------------------------------------------

    [2010-04-19 23:21:24] cloud9living

    Description:
    ------------
    Line 820 in Request2.php is not a correct check and turns on magic
    quotes every time it is run on my system. This creates havoc with any
    DB requests called after the Request2.php function is loaded since I
    have magic quotes off by default.

    if ($magicQuotes) {
    ini_set('magic_quotes_runtime', true);
    }

    Test script:
    ---------------
    If the line is changed to the code below the check should be correct.
    if ($magicQuotes === true) {
    ini_set('magic_quotes_runtime', true);
    }

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedApr 20, '10 at 6:15a
activeApr 21, '10 at 3:09p
posts5
users2
websitepear.php.net

2 users in discussion

Borz_off: 3 posts Justin: 2 posts

People

Translate

site design / logo © 2022 Grokbase