FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=7563&edit=1

ID: 7563
Comment by: protatoe
Reported By: digitalgenesis at gmail dot com
Summary: Improve memory usage
Status: Open
Type: Feature/Change Request
Package: PhpDocumentor
Operating System: FreeBSD 4.11-STABLE
Package Version: 1.3.0RC6
PHP Version: 4.3.11
New Comment:

Sorry to add to an old thread, but I was quiet surprised to see this
still an issue 4 years after it was reported.

Even at a 1GB of ram, it's still failing to parse out the
documentation. This only started happening after recompiling with
tokenizer support, because it was failing for different reasons with
out.


Previous Comments:
------------------------------------------------------------------------

[2007-01-10 15:59:48] ashnazg at php dot net

SF patch #1588942 is now committed to CVS, so memory_limit will now be
configurable in the INI file.

------------------------------------------------------------------------

[2006-12-18 15:29:04] cellog

the patch simply allows setting memory_limit, which does
not in fact improve memory usage, so no, this is a
separate and massive undertaking that is planned for 2.0

------------------------------------------------------------------------

[2006-12-18 12:44:16] ashnazg at php dot net

Greg, should I consider committing patch #1588942 as a "fix" for this
particular bug, or would that patch count as an enhancement ("feature")
and require this bug to wait for a feature release before it gets
committed?

------------------------------------------------------------------------

[2006-12-05 13:00:30] ashnazg at users dot sourceforge dot net

I submitted a Sourceforge patch last month that allows you to configure
a max memory value in the phpDocumentor.ini file. The patch is at
https://sourceforge.net/tracker/index.php?func=detail&aid=1588942&group_id=11194&atid=311194

Here's how it works:
- if you put a memory_limit value in phpDocumentor.ini, it is used...
period... regardless of how big or how small in relation to php.ini or
256;
- otherwise, the LARGER of php.ini's value OR the 256MB value is
used.


Oliver:
If your php.ini setting is already >256, then the existing code should
not be causing phpDocumentor to drop to the lower 256MB ceiling.
However, using my patch will allow you to set the value to whatever you
want it to be, using phpDocumentor.ini to do it.

------------------------------------------------------------------------

[2006-10-02 22:10:26] seufert at gmail dot com

I have this problem. Obviously no one is planning no fixing it.

However there is an interim fix.

Its outlined here.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=375070

Basically just edit /usr/bin/pecl

and add "-d memory_limit=-1" to the php command on the last line

I think this would be the most elegant fix, for now.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://pear.php.net/bugs/bug.php?id=7563

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedApr 9, '10 at 10:24p
activeApr 9, '10 at 10:24p
posts1
users1
websitepear.php.net

1 user in discussion

Protatoe: 1 post

People

Translate

site design / logo © 2021 Grokbase