FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=17196&edit=1

ID: 17196
Updated by: clbustos@surnet.cl
Reported By: rpjday at crashcourse dot ca
Summary: Short opening tag of "<?" deactivates beautifier.
-Status: Open
+Status: Bogus
Type: Feature/Change Request
Package: PHP_Beautifier
Operating System: Linux
Package Version: 0.1.14
PHP Version: 5.3.1
Roadmap Versions:
New Comment:

-Status: Open
+Status: Bogus
Thank you for taking the time to write to us, but this is not
a bug.

The php.ini recomends not to use shorts tag on production code. Anyway,
I will put a note on documentation, to warning the users.


Previous Comments:
------------------------------------------------------------------------

[2010-03-05 00:17:42] rpjday

Description:
------------
I was trying to beautify some legacy PHP code and couldn't figure out
why the beautifier was changing absolutely nothing until I tracked it
down to the fact that the files started with the short tag of "<?"
instead of "<?php". This clearly causes the beautifier to not do
anything, but there is no warning of any kind as to what's going on.
Perhaps a polite warning would be helpful.

------------------------------------------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedMar 16, '10 at 5:50a
activeMar 16, '10 at 5:50a
posts1
users1
websitepear.php.net

1 user in discussion

Clbustos: 1 post

People

Translate

site design / logo © 2022 Grokbase