FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=13606&edit=1

ID: 13606
Updated by: demon.gene@gmail.com
Reported By: mike at silverorange dot com
Summary: parameter name and description do not line up in
generated docs
Status: Feedback
Type: Bug
Package: PhpDocumentor
Operating System: Irrelevant
PHP Version: Irrelevant
Assigned To: ashnazg
Roadmap Versions:
New Comment:

Michael, is this oddity still visible somewhere to you? I've tried
duplicating with all the HTML output converters, and when I shrink the
browser enough to cause the descriptions to linewrap, they line up
perfectly for me.


Previous Comments:
------------------------------------------------------------------------

[2009-10-12 16:18:40] ashnazg

-Status: Open
+Status: Feedback
-Assigned To:
+Assigned To: ashnazg
Michael, can you point me directly to a URL where this is evident right
now in peardoc? I need to be sure I'm looking at the correct thing.

------------------------------------------------------------------------

[2008-04-06 08:19:53] dufuz

This is not a problem in pearweb but in the templates phpdocumentor
supplies if I understand correctly how that beast works ... Over to
Chuck now.

------------------------------------------------------------------------

[2008-04-05 23:38:42] gauthierm

First screenshot:
http://labs.silverorange.com/local/solabs/images/PEAR-web-docs-parameters-bad.png

Second screenshot:
http://labs.silverorange.com/local/solabs/images/PEAR-web-docs-parameters-good.png

------------------------------------------------------------------------

[2008-04-05 23:34:16] gauthierm

Description:
------------
See attached screenshots. The first screenshot is the current generated
documentation. The second screenshot has 'vertical-align: top;' applied
to all td elements.

------------------------------------------------------------------------

Search Discussions

  • Mike at Nov 23, 2009 at 10:52 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=13606&edit=1

    ID: 13606
    Updated by: mike@silverorange.com
    Reported By: mike at silverorange dot com
    Summary: parameter name and description do not line up in
    generated docs
    Status: Feedback
    Type: Bug
    Package: PhpDocumentor
    Operating System: Irrelevant
    PHP Version: Irrelevant
    Assigned To: ashnazg
    Roadmap Versions:
    New Comment:

    Chuck,

    The problem is still present and is quite visible on

    http://pear.php.net/package/Crypt_GPG/docs/1.0.0/Crypt_GPG/Crypt_GPG.html#me
    thodgetFingerprint (http://bit.ly/5Whvai)

    The documentation for the $format parameter actually starts with
    "optional. How
    the fingerprint should be formatted..." but the line points to
    "Crypt_GPG::FORMAT_NONE". It makes it appear as if the documentation
    for the
    second parameter is actually part of the first parameter's
    documentation.

    The problem is still solvable by applying a "vertical-align: top;"
    style to the td cells
    that display parameter documentation.


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-23 21:48:50] ashnazg

    Michael, is this oddity still visible somewhere to you? I've tried
    duplicating with all the HTML output converters, and when I shrink the
    browser enough to cause the descriptions to linewrap, they line up
    perfectly for me.

    ------------------------------------------------------------------------

    [2009-10-12 16:18:40] ashnazg

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: ashnazg
    Michael, can you point me directly to a URL where this is evident right
    now in peardoc? I need to be sure I'm looking at the correct thing.

    ------------------------------------------------------------------------

    [2008-04-06 08:19:53] dufuz

    This is not a problem in pearweb but in the templates phpdocumentor
    supplies if I understand correctly how that beast works ... Over to
    Chuck now.

    ------------------------------------------------------------------------

    [2008-04-05 23:38:42] gauthierm

    First screenshot:
    http://labs.silverorange.com/local/solabs/images/PEAR-web-docs-parameters-bad.png

    Second screenshot:
    http://labs.silverorange.com/local/solabs/images/PEAR-web-docs-parameters-good.png

    ------------------------------------------------------------------------

    [2008-04-05 23:34:16] gauthierm

    Description:
    ------------
    See attached screenshots. The first screenshot is the current generated
    documentation. The second screenshot has 'vertical-align: top;' applied
    to all td elements.

    ------------------------------------------------------------------------
  • Demon Gene at Nov 24, 2009 at 1:17 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=13606&edit=1

    ID: 13606
    Updated by: demon.gene@gmail.com
    Reported By: mike at silverorange dot com
    Summary: parameter name and description do not line up in
    generated docs
    Status: Feedback
    Type: Bug
    Package: PhpDocumentor
    Operating System: Irrelevant
    PHP Version: Irrelevant
    Assigned To: ashnazg
    Roadmap Versions:
    New Comment:

    Ah, that helps...

    The root issue seems to be 'centered' vertical alignment, so changing
    that to 'top' probably will solve it. Need to find a way to test this
    on sg1 box.


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-23 23:52:26] gauthierm

    Chuck,

    The problem is still present and is quite visible on

    http://pear.php.net/package/Crypt_GPG/docs/1.0.0/Crypt_GPG/Crypt_GPG.html#me
    thodgetFingerprint (http://bit.ly/5Whvai)

    The documentation for the $format parameter actually starts with
    "optional. How
    the fingerprint should be formatted..." but the line points to
    "Crypt_GPG::FORMAT_NONE". It makes it appear as if the documentation
    for the
    second parameter is actually part of the first parameter's
    documentation.

    The problem is still solvable by applying a "vertical-align: top;"
    style to the td cells
    that display parameter documentation.

    ------------------------------------------------------------------------

    [2009-11-23 21:48:50] ashnazg

    Michael, is this oddity still visible somewhere to you? I've tried
    duplicating with all the HTML output converters, and when I shrink the
    browser enough to cause the descriptions to linewrap, they line up
    perfectly for me.

    ------------------------------------------------------------------------

    [2009-10-12 16:18:40] ashnazg

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: ashnazg
    Michael, can you point me directly to a URL where this is evident right
    now in peardoc? I need to be sure I'm looking at the correct thing.

    ------------------------------------------------------------------------

    [2008-04-06 08:19:53] dufuz

    This is not a problem in pearweb but in the templates phpdocumentor
    supplies if I understand correctly how that beast works ... Over to
    Chuck now.

    ------------------------------------------------------------------------

    [2008-04-05 23:38:42] gauthierm

    First screenshot:
    http://labs.silverorange.com/local/solabs/images/PEAR-web-docs-parameters-bad.png

    Second screenshot:
    http://labs.silverorange.com/local/solabs/images/PEAR-web-docs-parameters-good.png

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=13606
  • Demon Gene at Nov 24, 2009 at 1:19 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=13606&edit=1

    ID: 13606
    Updated by: demon.gene@gmail.com
    Reported By: mike at silverorange dot com
    Summary: parameter name and description do not line up in
    generated docs
    -Status: Feedback
    +Status: Verified
    Type: Bug
    Package: PhpDocumentor
    Operating System: Irrelevant
    PHP Version: Irrelevant
    Assigned To: ashnazg
    Roadmap Versions:
    New Comment:

    -Status: Feedback
    +Status: Verified



    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-24 14:16:44] ashnazg

    Ah, that helps...

    The root issue seems to be 'centered' vertical alignment, so changing
    that to 'top' probably will solve it. Need to find a way to test this
    on sg1 box.

    ------------------------------------------------------------------------

    [2009-11-23 23:52:26] gauthierm

    Chuck,

    The problem is still present and is quite visible on

    http://pear.php.net/package/Crypt_GPG/docs/1.0.0/Crypt_GPG/Crypt_GPG.html#me
    thodgetFingerprint (http://bit.ly/5Whvai)

    The documentation for the $format parameter actually starts with
    "optional. How
    the fingerprint should be formatted..." but the line points to
    "Crypt_GPG::FORMAT_NONE". It makes it appear as if the documentation
    for the
    second parameter is actually part of the first parameter's
    documentation.

    The problem is still solvable by applying a "vertical-align: top;"
    style to the td cells
    that display parameter documentation.

    ------------------------------------------------------------------------

    [2009-11-23 21:48:50] ashnazg

    Michael, is this oddity still visible somewhere to you? I've tried
    duplicating with all the HTML output converters, and when I shrink the
    browser enough to cause the descriptions to linewrap, they line up
    perfectly for me.

    ------------------------------------------------------------------------

    [2009-10-12 16:18:40] ashnazg

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: ashnazg
    Michael, can you point me directly to a URL where this is evident right
    now in peardoc? I need to be sure I'm looking at the correct thing.

    ------------------------------------------------------------------------

    [2008-04-06 08:19:53] dufuz

    This is not a problem in pearweb but in the templates phpdocumentor
    supplies if I understand correctly how that beast works ... Over to
    Chuck now.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=13606
  • Demon Gene at Nov 24, 2009 at 5:02 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=13606&edit=1

    ID: 13606
    Updated by: demon.gene@gmail.com
    Reported By: mike at silverorange dot com
    Summary: parameter name and description do not line up in
    generated docs
    -Status: Verified
    +Status: Closed
    Type: Bug
    Package: PhpDocumentor
    Operating System: Irrelevant
    PHP Version: Irrelevant
    Assigned To: ashnazg
    -Roadmap Versions: 1.4.4
    +Roadmap Versions: 1.5.0a1
    New Comment:

    -Status: Verified
    +Status: Closed
    -Roadmap Versions: 1.4.4
    +Roadmap Versions: 1.5.0a1
    Updated this in the HTML:Smarty:PEAR output converter... committed to
    SVN.


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-24 14:19:05] ashnazg

    -Status: Feedback
    +Status: Verified


    ------------------------------------------------------------------------

    [2009-11-24 14:16:44] ashnazg

    Ah, that helps...

    The root issue seems to be 'centered' vertical alignment, so changing
    that to 'top' probably will solve it. Need to find a way to test this
    on sg1 box.

    ------------------------------------------------------------------------

    [2009-11-23 23:52:26] gauthierm

    Chuck,

    The problem is still present and is quite visible on

    http://pear.php.net/package/Crypt_GPG/docs/1.0.0/Crypt_GPG/Crypt_GPG.html#me
    thodgetFingerprint (http://bit.ly/5Whvai)

    The documentation for the $format parameter actually starts with
    "optional. How
    the fingerprint should be formatted..." but the line points to
    "Crypt_GPG::FORMAT_NONE". It makes it appear as if the documentation
    for the
    second parameter is actually part of the first parameter's
    documentation.

    The problem is still solvable by applying a "vertical-align: top;"
    style to the td cells
    that display parameter documentation.

    ------------------------------------------------------------------------

    [2009-11-23 21:48:50] ashnazg

    Michael, is this oddity still visible somewhere to you? I've tried
    duplicating with all the HTML output converters, and when I shrink the
    browser enough to cause the descriptions to linewrap, they line up
    perfectly for me.

    ------------------------------------------------------------------------

    [2009-10-12 16:18:40] ashnazg

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: ashnazg
    Michael, can you point me directly to a URL where this is evident right
    now in peardoc? I need to be sure I'm looking at the correct thing.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=13606

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedNov 23, '09 at 8:49p
activeNov 24, '09 at 5:02p
posts5
users2
websitepear.php.net

2 users in discussion

Demon Gene: 4 posts Mike: 1 post

People

Translate

site design / logo © 2022 Grokbase