FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=16804&edit=1

ID: 16804
Updated by: php@adamashley.name
Reported By: php at adamashley dot name
Summary: Report filename is shortened to much
Status: Open
Type: Bug
Package: PHP_CodeSniffer
Package Version: 1.2.1
PHP Version: 5.2.5
Roadmap Versions:
New Comment:

Appending --report-width=80 resolves the problem. When --report-width
is not supplied about half of the files with errors are truncated to the
last 4 to 8 characters


Previous Comments:
------------------------------------------------------------------------

[2009-11-19 01:30:00] aashley

Description:
------------
Error report truncates filename to much making it impossible to
determine which file the errors are from. Expected result is from 1.2.0

Test script:
---------------
/usr/bin/phpcs -v --standard=Mu
--ignore=dir_which_doesnt_exist,documentation,thirdparty,build/test,build/static,static,javascript
.

Expected result:
----------------
FILE:
...uildslave/slave/mu-framework_branch-version2.0-phpcs/build/init/web.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
1 | WARNING | 30% of lines in file must be comments. Currently only 10
of
approximately 45 (22%) lines of real code is.
--------------------------------------------------------------------------------


Actual result:
--------------
FILE: ...eb.php
--------------------------------------------------------------------------------
FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
--------------------------------------------------------------------------------
1 | WARNING | 30% of lines in file must be comments. Currently only 10
of
approximately 45 (22%) lines of real code is.
--------------------------------------------------------------------------------

------------------------------------------------------------------------

Search Discussions

  • Ken at Nov 21, 2009 at 8:38 am
    Edit report at http://pear.php.net/bugs/bug.php?id=16804&edit=1

    ID: 16804
    Updated by: ken@linux.ie
    Reported By: php at adamashley dot name
    -Summary: Report filename is shortened to much
    +Summary: Report filename is shortened too much
    Status: Open
    Type: Bug
    Package: PHP_CodeSniffer
    Package Version: 1.2.1
    PHP Version: 5.2.5
    Roadmap Versions:
    New Comment:

    -Summary: Report filename is shortened to much
    +Summary: Report filename is shortened too much



    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-19 01:33:36] aashley

    Appending --report-width=80 resolves the problem. When --report-width
    is not supplied about half of the files with errors are truncated to the
    last 4 to 8 characters

    ------------------------------------------------------------------------

    [2009-11-19 01:30:00] aashley

    Description:
    ------------
    Error report truncates filename to much making it impossible to
    determine which file the errors are from. Expected result is from 1.2.0

    Test script:
    ---------------
    /usr/bin/phpcs -v --standard=Mu
    --ignore=dir_which_doesnt_exist,documentation,thirdparty,build/test,build/static,static,javascript
    .

    Expected result:
    ----------------
    FILE:
    ...uildslave/slave/mu-framework_branch-version2.0-phpcs/build/init/web.php
    --------------------------------------------------------------------------------
    FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
    --------------------------------------------------------------------------------
    1 | WARNING | 30% of lines in file must be comments. Currently only 10
    of
    approximately 45 (22%) lines of real code is.
    --------------------------------------------------------------------------------


    Actual result:
    --------------
    FILE: ...eb.php
    --------------------------------------------------------------------------------
    FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
    --------------------------------------------------------------------------------
    1 | WARNING | 30% of lines in file must be comments. Currently only 10
    of
    approximately 45 (22%) lines of real code is.
    --------------------------------------------------------------------------------

    ------------------------------------------------------------------------
  • Gsherwood at Nov 23, 2009 at 4:42 am
    Edit report at http://pear.php.net/bugs/bug.php?id=16804&edit=1

    ID: 16804
    Updated by: gsherwood@squiz.net
    Reported By: php at adamashley dot name
    Summary: Report filename is shortened too much
    -Status: Open
    +Status: Feedback
    Type: Bug
    Package: PHP_CodeSniffer
    Package Version: 1.2.1
    PHP Version: 5.2.5
    -Assigned To:
    +Assigned To: squiz
    Roadmap Versions:
    New Comment:

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: squiz
    I can't replicate this at all and the code that does it is pretty
    basic.

    Any chance you can give me some full file paths that do break and some
    that don't? There must be a pattern there somewhere.

    Otherwise, also try setting the default report width. It is already 80
    and the function accepts a minimum of 70, but it is worth a try: phpcs
    --config-set report_width 80


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-21 09:38:17] kguest

    -Summary: Report filename is shortened to much
    +Summary: Report filename is shortened too much


    ------------------------------------------------------------------------

    [2009-11-19 01:33:36] aashley

    Appending --report-width=80 resolves the problem. When --report-width
    is not supplied about half of the files with errors are truncated to the
    last 4 to 8 characters

    ------------------------------------------------------------------------

    [2009-11-19 01:30:00] aashley

    Description:
    ------------
    Error report truncates filename to much making it impossible to
    determine which file the errors are from. Expected result is from 1.2.0

    Test script:
    ---------------
    /usr/bin/phpcs -v --standard=Mu
    --ignore=dir_which_doesnt_exist,documentation,thirdparty,build/test,build/static,static,javascript
    .

    Expected result:
    ----------------
    FILE:
    ...uildslave/slave/mu-framework_branch-version2.0-phpcs/build/init/web.php
    --------------------------------------------------------------------------------
    FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
    --------------------------------------------------------------------------------
    1 | WARNING | 30% of lines in file must be comments. Currently only 10
    of
    approximately 45 (22%) lines of real code is.
    --------------------------------------------------------------------------------


    Actual result:
    --------------
    FILE: ...eb.php
    --------------------------------------------------------------------------------
    FOUND 0 ERROR(S) AND 1 WARNING(S) AFFECTING 1 LINE(S)
    --------------------------------------------------------------------------------
    1 | WARNING | 30% of lines in file must be comments. Currently only 10
    of
    approximately 45 (22%) lines of real code is.
    --------------------------------------------------------------------------------

    ------------------------------------------------------------------------
  • Php at Nov 23, 2009 at 4:53 am
    Edit report at http://pear.php.net/bugs/bug.php?id=16804&edit=1

    ID: 16804
    Updated by: php@adamashley.name
    Reported By: php at adamashley dot name
    Summary: Report filename is shortened too much
    Status: Feedback
    Type: Bug
    Package: PHP_CodeSniffer
    Package Version: 1.2.1
    -PHP Version: 5.2.5
    +PHP Version: 5.2.10-2ubuntu6.1
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    -PHP Version: 5.2.5
    +PHP Version: 5.2.10-2ubuntu6.1
    I have added to files phpcs-1.2.0-files and phpcs-1.2.1-files which are
    the FILE: lines from the two respective versions of phpcs.

    Doing --config_set made no difference to the output.

    Increasing report with a small amount (ie 1) adds a corresponding
    number of characters to the output of the lines. Only by increasing the
    report width to larger than all the strings is the only way to get them
    to display


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-23 05:49:24] aashley

    Added #patch bug:16804;patch:phpcs-1.2.1-files;revision:1258955364;.

    ------------------------------------------------------------------------

    [2009-11-23 05:49:02] aashley

    Added #patch bug:16804;patch:phpcs-1.2.0-files;revision:1258955342;.

    ------------------------------------------------------------------------

    [2009-11-23 05:41:56] squiz

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: squiz
    I can't replicate this at all and the code that does it is pretty
    basic.

    Any chance you can give me some full file paths that do break and some
    that don't? There must be a pattern there somewhere.

    Otherwise, also try setting the default report width. It is already 80
    and the function accepts a minimum of 70, but it is worth a try: phpcs
    --config-set report_width 80

    ------------------------------------------------------------------------

    [2009-11-21 09:38:17] kguest

    -Summary: Report filename is shortened to much
    +Summary: Report filename is shortened too much


    ------------------------------------------------------------------------

    [2009-11-19 01:33:36] aashley

    Appending --report-width=80 resolves the problem. When --report-width
    is not supplied about half of the files with errors are truncated to the
    last 4 to 8 characters

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=16804
  • Gsherwood at Nov 23, 2009 at 5:01 am
    Edit report at http://pear.php.net/bugs/bug.php?id=16804&edit=1

    ID: 16804
    Updated by: gsherwood@squiz.net
    Reported By: php at adamashley dot name
    Summary: Report filename is shortened too much
    Status: Feedback
    Type: Bug
    Package: PHP_CodeSniffer
    Package Version: 1.2.1
    PHP Version: 5.2.10-2ubuntu6.1
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    I figured it out with your filenames. Just stupid code in the end.
    Thanks for sending that info through.


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-23 05:53:34] aashley

    -PHP Version: 5.2.5
    +PHP Version: 5.2.10-2ubuntu6.1
    I have added to files phpcs-1.2.0-files and phpcs-1.2.1-files which are
    the FILE: lines from the two respective versions of phpcs.

    Doing --config_set made no difference to the output.

    Increasing report with a small amount (ie 1) adds a corresponding
    number of characters to the output of the lines. Only by increasing the
    report width to larger than all the strings is the only way to get them
    to display

    ------------------------------------------------------------------------

    [2009-11-23 05:49:24] aashley

    Added #patch bug:16804;patch:phpcs-1.2.1-files;revision:1258955364;.

    ------------------------------------------------------------------------

    [2009-11-23 05:49:02] aashley

    Added #patch bug:16804;patch:phpcs-1.2.0-files;revision:1258955342;.

    ------------------------------------------------------------------------

    [2009-11-23 05:41:56] squiz

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: squiz
    I can't replicate this at all and the code that does it is pretty
    basic.

    Any chance you can give me some full file paths that do break and some
    that don't? There must be a pattern there somewhere.

    Otherwise, also try setting the default report width. It is already 80
    and the function accepts a minimum of 70, but it is worth a try: phpcs
    --config-set report_width 80

    ------------------------------------------------------------------------

    [2009-11-21 09:38:17] kguest

    -Summary: Report filename is shortened to much
    +Summary: Report filename is shortened too much


    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=16804
  • Gsherwood at Nov 23, 2009 at 5:04 am
    Edit report at http://pear.php.net/bugs/bug.php?id=16804&edit=1

    ID: 16804
    Updated by: gsherwood@squiz.net
    Reported By: php at adamashley dot name
    Summary: Report filename is shortened too much
    -Status: Feedback
    +Status: Closed
    Type: Bug
    Package: PHP_CodeSniffer
    Package Version: 1.2.1
    PHP Version: 5.2.10-2ubuntu6.1
    Assigned To: squiz
    Roadmap Versions:
    New Comment:

    -Status: Feedback
    +Status: Closed
    This bug has been fixed in SVN.

    If this was a documentation problem, the fix will appear on
    pear.php.net by the end of next Sunday (CET).

    If this was a problem with the pear.php.net website, the change should
    be live shortly.

    Otherwise, the fix will appear in the package's next release.

    Thank you for the report and for helping us make PEAR better.




    Previous Comments:
    ------------------------------------------------------------------------

    [2009-11-23 06:01:06] squiz

    I figured it out with your filenames. Just stupid code in the end.
    Thanks for sending that info through.

    ------------------------------------------------------------------------

    [2009-11-23 05:53:34] aashley

    -PHP Version: 5.2.5
    +PHP Version: 5.2.10-2ubuntu6.1
    I have added to files phpcs-1.2.0-files and phpcs-1.2.1-files which are
    the FILE: lines from the two respective versions of phpcs.

    Doing --config_set made no difference to the output.

    Increasing report with a small amount (ie 1) adds a corresponding
    number of characters to the output of the lines. Only by increasing the
    report width to larger than all the strings is the only way to get them
    to display

    ------------------------------------------------------------------------

    [2009-11-23 05:49:24] aashley

    Added #patch bug:16804;patch:phpcs-1.2.1-files;revision:1258955364;.

    ------------------------------------------------------------------------

    [2009-11-23 05:49:02] aashley

    Added #patch bug:16804;patch:phpcs-1.2.0-files;revision:1258955342;.

    ------------------------------------------------------------------------

    [2009-11-23 05:41:56] squiz

    -Status: Open
    +Status: Feedback
    -Assigned To:
    +Assigned To: squiz
    I can't replicate this at all and the code that does it is pretty
    basic.

    Any chance you can give me some full file paths that do break and some
    that don't? There must be a pattern there somewhere.

    Otherwise, also try setting the default report width. It is already 80
    and the function accepts a minimum of 70, but it is worth a try: phpcs
    --config-set report_width 80

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=16804

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedNov 19, '09 at 12:33a
activeNov 23, '09 at 5:04a
posts6
users3
websitepear.php.net

3 users in discussion

Gsherwood: 3 posts Php: 2 posts Ken: 1 post

People

Translate

site design / logo © 2022 Grokbase