FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=15620&edit=1

ID: 15620
Updated by: cweiske@php.net
Reported By: thijs at debian dot org
Summary: Please update package license
Status: Open
Type: Documentation Problem
Package: Mail
Package Version: 1.2.0b1
PHP Version: Irrelevant
Roadmap Versions:
New Comment:

Richard, Chuck - what do you say?


Previous Comments:
------------------------------------------------------------------------

[2009-01-12 15:51:01] thijs

Description:
------------
Hi,

The package is now licensed under a combination of PHP 2.02 and BSD
licenses.

There are some problems with the PHP 2.02 license; for example it
states that "This software includes Zend" and "This software includes
PHP", which is not the case for this module.

Would it be possible to update the license? My proposal would be to
license all files under the BSD license, so the whole package gets one
license, and the BSD license is a widely known liberal open source
license. As (in my opinion less preferred) alternative would be to
upgrade to version 3.01 of the PHP license.

thanks,
Thijs

------------------------------------------------------------------------

Search Discussions

  • Chuck at Oct 14, 2009 at 5:55 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=15620&edit=1

    ID: 15620
    Updated by: chuck@horde.org
    Reported By: thijs at debian dot org
    Summary: Please update package license
    Status: Open
    Type: Documentation Problem
    Package: Mail
    Package Version: 1.2.0b1
    PHP Version: Irrelevant
    Roadmap Versions:
    New Comment:

    Fine by me.


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-10-14 19:55:13] cweiske

    Richard, Chuck - what do you say?

    ------------------------------------------------------------------------

    [2009-01-12 15:51:01] thijs

    Description:
    ------------
    Hi,

    The package is now licensed under a combination of PHP 2.02 and BSD
    licenses.

    There are some problems with the PHP 2.02 license; for example it
    states that "This software includes Zend" and "This software includes
    PHP", which is not the case for this module.

    Would it be possible to update the license? My proposal would be to
    license all files under the BSD license, so the whole package gets one
    license, and the BSD license is a widely known liberal open source
    license. As (in my opinion less preferred) alternative would be to
    upgrade to version 3.01 of the PHP license.

    thanks,
    Thijs

    ------------------------------------------------------------------------
  • Richardh at Oct 14, 2009 at 6:31 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=15620&edit=1

    ID: 15620
    Updated by: richardh@phpguru.org
    Reported By: thijs at debian dot org
    Summary: Please update package license
    Status: Open
    Type: Documentation Problem
    Package: Mail
    Package Version: 1.2.0b1
    PHP Version: Irrelevant
    Roadmap Versions:
    New Comment:

    No problemo.


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-10-14 19:55:42] chagenbu

    Fine by me.

    ------------------------------------------------------------------------

    [2009-10-14 19:55:13] cweiske

    Richard, Chuck - what do you say?

    ------------------------------------------------------------------------

    [2009-01-12 15:51:01] thijs

    Description:
    ------------
    Hi,

    The package is now licensed under a combination of PHP 2.02 and BSD
    licenses.

    There are some problems with the PHP 2.02 license; for example it
    states that "This software includes Zend" and "This software includes
    PHP", which is not the case for this module.

    Would it be possible to update the license? My proposal would be to
    license all files under the BSD license, so the whole package gets one
    license, and the BSD license is a widely known liberal open source
    license. As (in my opinion less preferred) alternative would be to
    upgrade to version 3.01 of the PHP license.

    thanks,
    Thijs

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedOct 14, '09 at 5:55p
activeOct 14, '09 at 6:31p
posts3
users3
websitepear.php.net

3 users in discussion

Cweiske: 1 post Richardh: 1 post Chuck: 1 post

People

Translate

site design / logo © 2022 Grokbase