FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=16580&edit=1

ID: 16580
Comment by: tonurics@gmail.com
Reported By: jason at yellowpages-nds dot com
Summary: Incorrect install/upgrade path.
Status: Open
Type: Bug
Package: Mail_Queue
Operating System: Debian 5.0 (Lenny)
Package Version: 1.2.3
PHP Version: 5.2.5
Roadmap Versions:
New Comment:

A stopgap solution for those having trouble until things are fixed, is
to append "/usr/share/php/Mail/" to the include path before including
Mail_Queue. Like so:

<?php
set_include_path(get_include_path().PATH_SEPARATOR.'/usr/share/php/Mail/');
require_once('Mail/Queue.php');
?>


Previous Comments:
------------------------------------------------------------------------

[2009-09-09 03:47:47] tonurics

Description:
------------
Mail_Queue 1.2.3 is upgraded (I assume installed as well) to the wrong
PEAR path. Causing catastrophic failure and the end of times.

Test script:
---------------
<?php
require_once('Mail/Queue.php');
?>

Expected result:
----------------
Mail_Queue should be installed here: /usr/share/php/Mail/Queue.php

Actual result:
--------------
Mail_Queue is erroneously installed here:
/usr/share/php/Mail/Mail/Queue.php

The Mail_Queue will not be found and cause any files requiring it to
fail.

------------------------------------------------------------------------

Search Discussions

  • Till at Sep 9, 2009 at 9:01 am
    Edit report at http://pear.php.net/bugs/bug.php?id=16580&edit=1

    ID: 16580
    Updated by: till@php.net
    Reported By: jason at yellowpages-nds dot com
    Summary: Incorrect install/upgrade path.
    -Status: Open
    +Status: Closed
    Type: Bug
    Package: Mail_Queue
    Operating System: Debian 5.0 (Lenny)
    Package Version: 1.2.3
    PHP Version: 5.2.5
    -Assigned To:
    +Assigned To: till
    Roadmap Versions:
    New Comment:

    -Status: Open
    +Status: Closed
    -Assigned To:
    +Assigned To: till
    Thank you for your bug report. This issue has been fixed
    in the latest released version of the package, which you can download
    at
    http://pear.php.net/get/

    Hey,

    it's fixed already, but instead of 1.2.4, I was told to re-release
    1.2.3.

    The fix is:
    pear install -f Mail_Queue

    Sorry for the inconvenience!

    Till


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-09-09 04:00:28] tonurics

    A stopgap solution for those having trouble until things are fixed, is
    to append "/usr/share/php/Mail/" to the include path before including
    Mail_Queue. Like so:

    <?php
    set_include_path(get_include_path().PATH_SEPARATOR.'/usr/share/php/Mail/');
    require_once('Mail/Queue.php');
    ?>

    ------------------------------------------------------------------------

    [2009-09-09 03:47:47] tonurics

    Description:
    ------------
    Mail_Queue 1.2.3 is upgraded (I assume installed as well) to the wrong
    PEAR path. Causing catastrophic failure and the end of times.

    Test script:
    ---------------
    <?php
    require_once('Mail/Queue.php');
    ?>

    Expected result:
    ----------------
    Mail_Queue should be installed here: /usr/share/php/Mail/Queue.php

    Actual result:
    --------------
    Mail_Queue is erroneously installed here:
    /usr/share/php/Mail/Mail/Queue.php

    The Mail_Queue will not be found and cause any files requiring it to
    fail.

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedSep 9, '09 at 2:00a
activeSep 9, '09 at 9:01a
posts2
users2
websitepear.php.net

2 users in discussion

Tonurics: 1 post Till: 1 post

People

Translate

site design / logo © 2021 Grokbase