FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=14523&edit=1

ID: 14523
Updated by: mrook@php.net
Reported By: sharon_correll at sil dot org
Summary: results are consistently corrupted
-Status: Open
+Status: Feedback
Type: Bug
Package: Archive_Tar
Operating System: Windows XP
Package Version: 1.3.2
PHP Version: 5.2.5
Roadmap Versions:
New Comment:

-Status: Open
+Status: Feedback
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PEAR better.

Hi,

can you confirm that this problem still exists using version 1.3.3
of Archive_Tar?


Previous Comments:
------------------------------------------------------------------------

[2009-03-27 02:33:50] dufuz

Does revision 1.39 or above fix it ? 1.39 contains a rewrite of exactly
what is diffed between 1.29 and 1.32

Archive_Tar-1.3.3 will soon be out, be on a look out and see if the
issue still persists.

------------------------------------------------------------------------

[2008-12-12 10:01:58] chrisdunavant

I'm seeing the same issue on an Ubuntu platform. I did a little more
testing and found that the problem doesn't occur when just doing a
"tar"
file output but occurs when adding "gzip" compression. I also found
that
Revision 1.29 of Tar.php worked fine and Revision 1.32 had the problem.

I tried to do a diff between the two revisions to see if I could see
anything obvious but it wasn't clear what might be the culprit. BTW, I

am using "addString" to add all the files to the archive. Another odd
fact
is that it works fine if I only add things like PDF files, JPG files,
XLS files
but if I add a Word doc (I tried several different Word files) it
doesn't
work. I'd be happy to provide more information if needed. Thanks!

------------------------------------------------------------------------

[2008-08-19 17:32:12] sharoncorrell

Even without the .PNG...just trying to zip up an .XML file (8 K)
doesn't work--the file is truncated by a handful of characters (about
17-18). In one case I tried zipping 3 files. The first file is truncated
and the name of the second file is embedded in it.

------------------------------------------------------------------------

[2008-08-19 00:26:07] doconnor

Flickr or photobucket or something?

------------------------------------------------------------------------

[2008-08-18 15:40:08] sharoncorrell

Sorry, I thought there would be a way to attch my sample files, but it
doesn't seem to be possible to attach my .PNG.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://pear.php.net/bugs/bug.php?id=14523

Search Discussions

  • Mrook at Aug 18, 2009 at 8:58 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=14523&edit=1

    ID: 14523
    Updated by: mrook@php.net
    Reported By: sharon_correll at sil dot org
    Summary: results are consistently corrupted
    Status: Feedback
    Type: Bug
    Package: Archive_Tar
    Operating System: Windows XP
    Package Version: 1.3.2
    PHP Version: 5.2.5
    Roadmap Versions:
    New Comment:

    Thank you for taking the time to report a problem with the package.
    Unfortunately you are not using a current version of the package --
    the problem might already be fixed. Please download a new
    version from http://pear.php.net/packages.php

    If you are able to reproduce the bug with one of the latest
    versions, please change the package version on this bug report
    to the version you tested and change the status back to "Open".
    Again, thank you for your continued support of PEAR.

    Hi,

    can you confirm that this problem still exists using version 1.3.3
    of Archive_Tar?


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-08-18 22:57:34] mrook

    -Status: Open
    +Status: Feedback
    Thank you for this bug report. To properly diagnose the problem, we
    need a backtrace to see what is happening behind the scenes. To
    find out how to generate a backtrace, please read
    http://bugs.php.net/bugs-generating-backtrace.php

    Once you have generated a backtrace, please submit it to this bug
    report and change the status back to "Open". Thank you for helping
    us make PEAR better.

    Hi,

    can you confirm that this problem still exists using version 1.3.3
    of Archive_Tar?

    ------------------------------------------------------------------------

    [2009-03-27 02:33:50] dufuz

    Does revision 1.39 or above fix it ? 1.39 contains a rewrite of exactly
    what is diffed between 1.29 and 1.32

    Archive_Tar-1.3.3 will soon be out, be on a look out and see if the
    issue still persists.

    ------------------------------------------------------------------------

    [2008-12-12 10:01:58] chrisdunavant

    I'm seeing the same issue on an Ubuntu platform. I did a little more
    testing and found that the problem doesn't occur when just doing a
    "tar"
    file output but occurs when adding "gzip" compression. I also found
    that
    Revision 1.29 of Tar.php worked fine and Revision 1.32 had the problem.

    I tried to do a diff between the two revisions to see if I could see
    anything obvious but it wasn't clear what might be the culprit. BTW, I

    am using "addString" to add all the files to the archive. Another odd
    fact
    is that it works fine if I only add things like PDF files, JPG files,
    XLS files
    but if I add a Word doc (I tried several different Word files) it
    doesn't
    work. I'd be happy to provide more information if needed. Thanks!

    ------------------------------------------------------------------------

    [2008-08-19 17:32:12] sharoncorrell

    Even without the .PNG...just trying to zip up an .XML file (8 K)
    doesn't work--the file is truncated by a handful of characters (about
    17-18). In one case I tried zipping 3 files. The first file is truncated
    and the name of the second file is embedded in it.

    ------------------------------------------------------------------------

    [2008-08-19 00:26:07] doconnor

    Flickr or photobucket or something?

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=14523
  • Sharon_correll at Aug 19, 2009 at 1:21 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=14523&edit=1

    ID: 14523
    Updated by: sharon_correll@sil.org
    Reported By: sharon_correll at sil dot org
    Summary: results are consistently corrupted
    Status: Feedback
    Type: Bug
    Package: Archive_Tar
    Operating System: Windows XP
    Package Version: 1.3.2
    PHP Version: 5.2.5
    Roadmap Versions:
    New Comment:

    I switched to using the File_Archive package instead. So I don't have
    an easy way to tell if the problem has been fixed.


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-08-18 22:58:39] mrook

    Thank you for taking the time to report a problem with the package.
    Unfortunately you are not using a current version of the package --
    the problem might already be fixed. Please download a new
    version from http://pear.php.net/packages.php

    If you are able to reproduce the bug with one of the latest
    versions, please change the package version on this bug report
    to the version you tested and change the status back to "Open".
    Again, thank you for your continued support of PEAR.

    Hi,

    can you confirm that this problem still exists using version 1.3.3
    of Archive_Tar?

    ------------------------------------------------------------------------

    [2009-08-18 22:57:34] mrook

    -Status: Open
    +Status: Feedback
    Thank you for this bug report. To properly diagnose the problem, we
    need a backtrace to see what is happening behind the scenes. To
    find out how to generate a backtrace, please read
    http://bugs.php.net/bugs-generating-backtrace.php

    Once you have generated a backtrace, please submit it to this bug
    report and change the status back to "Open". Thank you for helping
    us make PEAR better.

    Hi,

    can you confirm that this problem still exists using version 1.3.3
    of Archive_Tar?

    ------------------------------------------------------------------------

    [2009-03-27 02:33:50] dufuz

    Does revision 1.39 or above fix it ? 1.39 contains a rewrite of exactly
    what is diffed between 1.29 and 1.32

    Archive_Tar-1.3.3 will soon be out, be on a look out and see if the
    issue still persists.

    ------------------------------------------------------------------------

    [2008-12-12 10:01:58] chrisdunavant

    I'm seeing the same issue on an Ubuntu platform. I did a little more
    testing and found that the problem doesn't occur when just doing a
    "tar"
    file output but occurs when adding "gzip" compression. I also found
    that
    Revision 1.29 of Tar.php worked fine and Revision 1.32 had the problem.

    I tried to do a diff between the two revisions to see if I could see
    anything obvious but it wasn't clear what might be the culprit. BTW, I

    am using "addString" to add all the files to the archive. Another odd
    fact
    is that it works fine if I only add things like PDF files, JPG files,
    XLS files
    but if I add a Word doc (I tried several different Word files) it
    doesn't
    work. I'd be happy to provide more information if needed. Thanks!

    ------------------------------------------------------------------------

    [2008-08-19 17:32:12] sharoncorrell

    Even without the .PNG...just trying to zip up an .XML file (8 K)
    doesn't work--the file is truncated by a handful of characters (about
    17-18). In one case I tried zipping 3 files. The first file is truncated
    and the name of the second file is embedded in it.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=14523

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedAug 18, '09 at 8:57p
activeAug 19, '09 at 1:21p
posts3
users2
websitepear.php.net

2 users in discussion

Mrook: 2 posts Sharon_correll: 1 post

People

Translate

site design / logo © 2022 Grokbase