FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=16366&edit=1

ID: 16366
Updated by: helgith@gmail.com
Reported By: adam at oit dot gatech dot edu
Summary: compiling 5.2.10 leads to non-functioning pear
-Status: Open
+Status: Closed
Type: Bug
Package: PEAR
Operating System: Solaris 9
PHP Version: 5.2.10
-Assigned To:
+Assigned To: dufuz
-Roadmap Versions:
+Roadmap Versions: 1.9.0
New Comment:

-Status: Open
+Status: Closed
-Assigned To:
+Assigned To: dufuz
-Roadmap Versions:
+Roadmap Versions: 1.9.0
This bug has been fixed in CVS.

If this was a documentation problem, the fix will appear on
pear.php.net by the end of next Sunday (CET).

If this was a problem with the pear.php.net website, the change should
be live shortly.

Otherwise, the fix will appear in the package's next release.

Thank you for the report and for helping us make PEAR better.




Previous Comments:
------------------------------------------------------------------------

[2009-06-28 23:57:15] dufuz

Which libxml2 do the users that have issues?

------------------------------------------------------------------------

[2009-06-23 16:12:33] cweiske

User "phiber_" experienced this on 5.2.10 and 5.2.9 on centos. adam_a
only on 5.2.10, not on 5.2.9, and all this on solaris.

Brett Bieber and Bjori could not reproduce it at all.

------------------------------------------------------------------------

[2009-06-22 20:45:08] dufuz

-Package: pearweb
+Package: PEAR


------------------------------------------------------------------------

[2009-06-22 20:07:27] adam_a

Compile options (with gcc 3.4.6):

CC=gcc \
export
LD_LIBRARY_PATH=/usr/local/ssl/lib:/opt/services/amp/lib:/usr/local/lib
export
PATH=/opt/SUNWspro/bin:/usr/ccs/bin:/usr/sbin:/usr/bin:/local/ssl/bin:/usr/xpg4/bin/:/services/mysql/bin:/opt/services/amp/bin:/usr/local/bin
export LDFLAGS="-R/opt/services/amp/lib -L/opt/services/amp/lib
-R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib
-L/usr/local/lib"
export CFLAGS="-R/opt/services/amp/lib -L/opt/services/amp/lib
-R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib
-L/usr/local/lib"
SSL_BASE=/opt/local/ssl \
./configure \
--with-apxs2=/opt/services/amp/apache2/bin/apxs \
--prefix=/opt/services/amp/apache2/php \
--with-config-file-path=/opt/services/amp/apache2/php/lib \
--with-mysql=/services/mysql \
--with-mysqli=/services/mysql/bin/mysql_config \
--with-ldap=/usr/local/ldap \
--with-mcrypt \
--with-curl=/opt/services/amp \
--with-openssl \
--with-gd \
--with-zlib=/usr/local \
--enable-mbstring \
--with-xsl=/opt/services/amp \
--with-libxml-dir=/opt/services/amp \
--with-jpeg-dir=/usr/local \
--with-png-dir=/usr/local \
--with-freetype-dir=/usr/local \
--enable-libgcc

------------------------------------------------------------------------

[2009-06-22 20:04:13] adam_a

Description:
------------
compiling php 5.2.10 with pear support leads to warnings on install
and
non-functional pear. Compilation of php 5.2.9 on same box with same
config options gives working pear.


Test script:
---------------
make install in source directory produces errors like:

Warning: Cannot use a scalar value as an array in
phar://install-pear-nozlib.phar/PEAR/ChannelFile.php on line 1391

running "pear install DB" produces the error:

pear.php.net is using a unsupported protocal - This should never
happen.

------------------------------------------------------------------------

Search Discussions

  • Jani at Aug 12, 2009 at 7:58 am
    Edit report at http://pear.php.net/bugs/bug.php?id=16366&edit=1

    ID: 16366
    Updated by: jani@php.net
    Reported By: adam at oit dot gatech dot edu
    Summary: compiling 5.2.10 leads to non-functioning pear
    -Status: Closed
    +Status: Assigned
    Type: Bug
    Package: PEAR
    Operating System: Solaris 9
    PHP Version: 5.2.10
    Assigned To: dufuz
    Roadmap Versions:
    New Comment:

    -Status: Closed
    +Status: Assigned
    What does "it's fixed" mean? Is is fixed so that if I now do 'make
    install-pear' and it grabs the phar thing from net it will work? (hint:
    I tried it, it still fails the same way)


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-08-11 22:03:23] dufuz

    -Status: Open
    +Status: Closed
    -Assigned To:
    +Assigned To: dufuz
    -Roadmap Versions:
    +Roadmap Versions: 1.9.0
    This bug has been fixed in CVS.

    If this was a documentation problem, the fix will appear on
    pear.php.net by the end of next Sunday (CET).

    If this was a problem with the pear.php.net website, the change should
    be live shortly.

    Otherwise, the fix will appear in the package's next release.

    Thank you for the report and for helping us make PEAR better.

    ------------------------------------------------------------------------

    [2009-06-28 23:57:15] dufuz

    Which libxml2 do the users that have issues?

    ------------------------------------------------------------------------

    [2009-06-23 16:12:33] cweiske

    User "phiber_" experienced this on 5.2.10 and 5.2.9 on centos. adam_a
    only on 5.2.10, not on 5.2.9, and all this on solaris.

    Brett Bieber and Bjori could not reproduce it at all.

    ------------------------------------------------------------------------

    [2009-06-22 20:45:08] dufuz

    -Package: pearweb
    +Package: PEAR


    ------------------------------------------------------------------------

    [2009-06-22 20:07:27] adam_a

    Compile options (with gcc 3.4.6):

    CC=gcc \
    export
    LD_LIBRARY_PATH=/usr/local/ssl/lib:/opt/services/amp/lib:/usr/local/lib
    export
    PATH=/opt/SUNWspro/bin:/usr/ccs/bin:/usr/sbin:/usr/bin:/local/ssl/bin:/usr/xpg4/bin/:/services/mysql/bin:/opt/services/amp/bin:/usr/local/bin
    export LDFLAGS="-R/opt/services/amp/lib -L/opt/services/amp/lib
    -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib
    -L/usr/local/lib"
    export CFLAGS="-R/opt/services/amp/lib -L/opt/services/amp/lib
    -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib
    -L/usr/local/lib"
    SSL_BASE=/opt/local/ssl \
    ./configure \
    --with-apxs2=/opt/services/amp/apache2/bin/apxs \
    --prefix=/opt/services/amp/apache2/php \
    --with-config-file-path=/opt/services/amp/apache2/php/lib \
    --with-mysql=/services/mysql \
    --with-mysqli=/services/mysql/bin/mysql_config \
    --with-ldap=/usr/local/ldap \
    --with-mcrypt \
    --with-curl=/opt/services/amp \
    --with-openssl \
    --with-gd \
    --with-zlib=/usr/local \
    --enable-mbstring \
    --with-xsl=/opt/services/amp \
    --with-libxml-dir=/opt/services/amp \
    --with-jpeg-dir=/usr/local \
    --with-png-dir=/usr/local \
    --with-freetype-dir=/usr/local \
    --enable-libgcc

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=16366
  • Helgith at Aug 19, 2009 at 2:10 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=16366&edit=1

    ID: 16366
    Updated by: helgith@gmail.com
    Reported By: adam at oit dot gatech dot edu
    Summary: compiling 5.2.10 leads to non-functioning pear
    -Status: Assigned
    +Status: Closed
    Type: Bug
    Package: PEAR
    Operating System: Solaris 9
    PHP Version: 5.2.10
    Assigned To: dufuz
    Roadmap Versions:
    New Comment:

    -Status: Assigned
    +Status: Closed
    As the status message said, it's fixed in CVS / SVN and is pending a
    release.
    If you read the message it does not say "fixed in release", phars are
    only ever updated on stable releases.


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-08-12 09:58:19] jani

    -Status: Closed
    +Status: Assigned
    What does "it's fixed" mean? Is is fixed so that if I now do 'make
    install-pear' and it grabs the phar thing from net it will work? (hint:
    I tried it, it still fails the same way)

    ------------------------------------------------------------------------

    [2009-08-11 22:03:23] dufuz

    -Status: Open
    +Status: Closed
    -Assigned To:
    +Assigned To: dufuz
    -Roadmap Versions:
    +Roadmap Versions: 1.9.0
    This bug has been fixed in CVS.

    If this was a documentation problem, the fix will appear on
    pear.php.net by the end of next Sunday (CET).

    If this was a problem with the pear.php.net website, the change should
    be live shortly.

    Otherwise, the fix will appear in the package's next release.

    Thank you for the report and for helping us make PEAR better.

    ------------------------------------------------------------------------

    [2009-06-28 23:57:15] dufuz

    Which libxml2 do the users that have issues?

    ------------------------------------------------------------------------

    [2009-06-23 16:12:33] cweiske

    User "phiber_" experienced this on 5.2.10 and 5.2.9 on centos. adam_a
    only on 5.2.10, not on 5.2.9, and all this on solaris.

    Brett Bieber and Bjori could not reproduce it at all.

    ------------------------------------------------------------------------

    [2009-06-22 20:45:08] dufuz

    -Package: pearweb
    +Package: PEAR


    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=16366
  • Cweiske at Aug 28, 2009 at 8:00 am
    Edit report at http://pear.php.net/bugs/bug.php?id=16366&edit=1

    ID: 16366
    Updated by: cweiske@php.net
    Reported By: adam at oit dot gatech dot edu
    Summary: compiling 5.2.10 leads to non-functioning pear
    Status: Closed
    Type: Bug
    Package: PEAR
    Operating System: Solaris 9
    PHP Version: 5.2.10
    Assigned To: dufuz
    Roadmap Versions:
    New Comment:

    You can fix the protocol error on an existing installation:
    http://blog.pear.php.net/2009/08/28/fixing-unsupported-protocol/


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-08-19 16:10:38] dufuz

    -Status: Assigned
    +Status: Closed
    As the status message said, it's fixed in CVS / SVN and is pending a
    release.
    If you read the message it does not say "fixed in release", phars are
    only ever updated on stable releases.

    ------------------------------------------------------------------------

    [2009-08-12 09:58:19] jani

    -Status: Closed
    +Status: Assigned
    What does "it's fixed" mean? Is is fixed so that if I now do 'make
    install-pear' and it grabs the phar thing from net it will work? (hint:
    I tried it, it still fails the same way)

    ------------------------------------------------------------------------

    [2009-08-11 22:03:23] dufuz

    -Status: Open
    +Status: Closed
    -Assigned To:
    +Assigned To: dufuz
    -Roadmap Versions:
    +Roadmap Versions: 1.9.0
    This bug has been fixed in CVS.

    If this was a documentation problem, the fix will appear on
    pear.php.net by the end of next Sunday (CET).

    If this was a problem with the pear.php.net website, the change should
    be live shortly.

    Otherwise, the fix will appear in the package's next release.

    Thank you for the report and for helping us make PEAR better.

    ------------------------------------------------------------------------

    [2009-06-28 23:57:15] dufuz

    Which libxml2 do the users that have issues?

    ------------------------------------------------------------------------

    [2009-06-23 16:12:33] cweiske

    User "phiber_" experienced this on 5.2.10 and 5.2.9 on centos. adam_a
    only on 5.2.10, not on 5.2.9, and all this on solaris.

    Brett Bieber and Bjori could not reproduce it at all.

    ------------------------------------------------------------------------

    The remainder of the comments for this report are too long. To view
    the rest of the comments, please view the bug report online at
    http://pear.php.net/bugs/bug.php?id=16366

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedAug 11, '09 at 8:03p
activeAug 28, '09 at 8:00a
posts4
users3
websitepear.php.net

3 users in discussion

Helgith: 2 posts Cweiske: 1 post Jani: 1 post

People

Translate

site design / logo © 2021 Grokbase