FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=15725&edit=1

ID: 15725
Updated by: brett.bieber@gmail.com
Reported By: Fedora at FamilleCollet dot com
Summary: set_magic_quotes_runtime deprecated in PHP 5.3.0
(alpha4dev)
Status: Open
Type: Feature/Change Request
Package: Cache_Lite
Operating System: Irrelevant
Package Version: 1.7.4
PHP Version: 5_3 CVS-2008-03-16
Roadmap Versions:
New Comment:

I would second applying this patch. There is no technical reason to not
apply it, as the api does not change, and it will not affect
compatibility with older versions – but will allow Cache_Lite to
run without E_DEPRECATED errors on 5.3.

Updated the patch to conform to PEAR CS.


Previous Comments:
------------------------------------------------------------------------

[2009-07-06 18:32:59] saltybeagle

The following patch has been added/updated:

Patch Name: magic_quotes_patch.txt
Revision: 1246901579
URL:
http://pear.php.net/bugs/patch-display.php?bug=15725&patch=magic_quotes_patch.txt&revision=1246901579&display=1

------------------------------------------------------------------------

[2009-01-22 14:23:55] tacker

Thanks for reporting, but this is not a bug.

PHP5/6 compatibility will come with version 2.0.

------------------------------------------------------------------------

[2009-01-22 12:27:23] remicollet

Description:
------------
Running Cache_Lite on latest PHP 5.3.0 snapshot generate a lot of
E_DEPRECATED warnings.

Simple patch proposal solve this issue (only call
set_magic_quotes_runtime if needed : when value > 0)

http://remi.fedorapeople.org/Lite.patch

If php config is ok with the future no warning reported.
If php config is not ok (magic_quotes_runtime On) warning will be
reported and the admin will be notity that he'll have to work on his
config.


Test script:
---------------
-

Expected result:
----------------
No E_DEPRECATED warning

Actual result:
--------------
-

------------------------------------------------------------------------

Search Discussions

  • Tacker at Jul 6, 2009 at 4:43 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=15725&edit=1

    ID: 15725
    Updated by: tacker@php.net
    Reported By: Fedora at FamilleCollet dot com
    Summary: set_magic_quotes_runtime deprecated in PHP 5.3.0
    (alpha4dev)
    -Status: Open
    +Status: Analyzed
    Type: Feature/Change Request
    Package: Cache_Lite
    Operating System: Irrelevant
    Package Version: 1.7.4
    PHP Version: 5_3 CVS-2008-03-16
    -Assigned To:
    +Assigned To: tacker
    -Roadmap Versions: 2.0
    +Roadmap Versions:
    New Comment:

    -Status: Open
    +Status: Analyzed
    -Assigned To:
    +Assigned To: tacker
    -Roadmap Versions: 2.0
    +Roadmap Versions:



    Previous Comments:
    ------------------------------------------------------------------------

    [2009-07-06 18:34:57] saltybeagle

    I would second applying this patch. There is no technical reason to not
    apply it, as the api does not change, and it will not affect
    compatibility with older versions – but will allow Cache_Lite to
    run without E_DEPRECATED errors on 5.3.

    Updated the patch to conform to PEAR CS.

    ------------------------------------------------------------------------

    [2009-07-06 18:32:59] saltybeagle

    The following patch has been added/updated:

    Patch Name: magic_quotes_patch.txt
    Revision: 1246901579
    URL:
    http://pear.php.net/bugs/patch-display.php?bug=15725&patch=magic_quotes_patch.txt&revision=1246901579&display=1

    ------------------------------------------------------------------------

    [2009-01-22 14:23:55] tacker

    Thanks for reporting, but this is not a bug.

    PHP5/6 compatibility will come with version 2.0.

    ------------------------------------------------------------------------

    [2009-01-22 12:27:23] remicollet

    Description:
    ------------
    Running Cache_Lite on latest PHP 5.3.0 snapshot generate a lot of
    E_DEPRECATED warnings.

    Simple patch proposal solve this issue (only call
    set_magic_quotes_runtime if needed : when value > 0)

    http://remi.fedorapeople.org/Lite.patch

    If php config is ok with the future no warning reported.
    If php config is not ok (magic_quotes_runtime On) warning will be
    reported and the admin will be notity that he'll have to work on his
    config.


    Test script:
    ---------------
    -

    Expected result:
    ----------------
    No E_DEPRECATED warning

    Actual result:
    --------------
    -

    ------------------------------------------------------------------------
  • Tacker at Jul 7, 2009 at 5:39 am
    Edit report at http://pear.php.net/bugs/bug.php?id=15725&edit=1

    ID: 15725
    Updated by: tacker@php.net
    Reported By: Fedora at FamilleCollet dot com
    Summary: set_magic_quotes_runtime deprecated in PHP 5.3.0
    (alpha4dev)
    -Status: Analyzed
    +Status: Closed
    Type: Feature/Change Request
    Package: Cache_Lite
    Operating System: Irrelevant
    Package Version: 1.7.4
    PHP Version: 5_3 CVS-2008-03-16
    Assigned To: tacker
    Roadmap Versions:
    New Comment:

    -Status: Analyzed
    +Status: Closed
    Thank you for your bug report. This issue has been fixed
    in the latest released version of the package, which you can download
    at
    http://pear.php.net/get/




    Previous Comments:
    ------------------------------------------------------------------------

    [2009-07-06 18:41:08] tacker

    -Status: Open
    +Status: Analyzed
    -Assigned To:
    +Assigned To: tacker
    -Roadmap Versions: 2.0
    +Roadmap Versions:


    ------------------------------------------------------------------------

    [2009-07-06 18:34:57] saltybeagle

    I would second applying this patch. There is no technical reason to not
    apply it, as the api does not change, and it will not affect
    compatibility with older versions – but will allow Cache_Lite to
    run without E_DEPRECATED errors on 5.3.

    Updated the patch to conform to PEAR CS.

    ------------------------------------------------------------------------

    [2009-07-06 18:32:59] saltybeagle

    The following patch has been added/updated:

    Patch Name: magic_quotes_patch.txt
    Revision: 1246901579
    URL:
    http://pear.php.net/bugs/patch-display.php?bug=15725&patch=magic_quotes_patch.txt&revision=1246901579&display=1

    ------------------------------------------------------------------------

    [2009-01-22 14:23:55] tacker

    Thanks for reporting, but this is not a bug.

    PHP5/6 compatibility will come with version 2.0.

    ------------------------------------------------------------------------

    [2009-01-22 12:27:23] remicollet

    Description:
    ------------
    Running Cache_Lite on latest PHP 5.3.0 snapshot generate a lot of
    E_DEPRECATED warnings.

    Simple patch proposal solve this issue (only call
    set_magic_quotes_runtime if needed : when value > 0)

    http://remi.fedorapeople.org/Lite.patch

    If php config is ok with the future no warning reported.
    If php config is not ok (magic_quotes_runtime On) warning will be
    reported and the admin will be notity that he'll have to work on his
    config.


    Test script:
    ---------------
    -

    Expected result:
    ----------------
    No E_DEPRECATED warning

    Actual result:
    --------------
    -

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedJul 6, '09 at 4:37p
activeJul 7, '09 at 5:39a
posts3
users2
websitepear.php.net

2 users in discussion

Tacker: 2 posts Brett Bieber: 1 post

People

Translate

site design / logo © 2022 Grokbase