FAQ
Edit report at http://pear.php.net/bugs/bug.php?id=16127&edit=1

ID: 16127
Updated by: daniel.oconnor@gmail.com
Reported By: showmaster at herr-der-mails dot de
Summary: PEAR installer fails installing package
-Status: Open
+Status: Feedback
Type: Bug
Package: Structures_Graph
Operating System: Windows
Package Version: 1.0.2
PHP Version: 4.4.0
Roadmap Versions:
New Comment:

-Status: Open
+Status: Feedback

Thank you for taking the time to report a problem with the package.
Unfortunately you are not using a current version of the package --
the problem might already be fixed. Please download a new
version from http://pear.php.net/packages.php

If you are able to reproduce the bug with one of the latest
versions, please change the package version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PEAR.

Works for me?


C:\vx\tests\unit\ordering>pear install structures_graph
Ignoring installed package pear/structures_graph
Nothing to install

C:\vx\tests\unit\ordering>pear install -f structures_graph
WARNING: channel "pear.php.net" has updated its protocols, use
"channel-update pear.php.net" to update
downloading Structures_Graph-1.0.2.tgz ...
Starting to download Structures_Graph-1.0.2.tgz (30,947 bytes)
.........done: 30,947 bytes
install ok: channel://pear.php.net/Structures_Graph-1.0.2

C:\vx\tests\unit\ordering>


Previous Comments:
------------------------------------------------------------------------

[2009-04-19 23:40:25] showmaster

Description:
------------
PEAR installer stops installing package with the following error:

XML Error: 'not well-formed (invalid token)' on line '10'

seems to be a bad character in package.xml

Test script:
---------------
start a fresh installation of pear (finishes with warning)
try to install package with: pear install Structures_Graph

Expected result:
----------------
successfully installing package

Actual result:
--------------
PEAR installer stops installing package with the following error:
XML Error: 'not well-formed (invalid token)' on line '10'

------------------------------------------------------------------------

Search Discussions

  • Daniel Oconnor at Apr 20, 2009 at 1:35 pm
    Edit report at http://pear.php.net/bugs/bug.php?id=16127&edit=1

    ID: 16127
    Updated by: daniel.oconnor@gmail.com
    Reported By: showmaster at herr-der-mails dot de
    Summary: PEAR installer fails installing package
    -Status: Feedback
    +Status: Closed
    Type: Bug
    Package: Structures_Graph
    Operating System: Windows
    Package Version: 1.0.2
    PHP Version: 4.4.0
    -Assigned To:
    +Assigned To: doconnor
    Roadmap Versions:
    New Comment:

    -Status: Feedback
    +Status: Closed
    -Assigned To:
    +Assigned To: doconnor

    This is a dupe of another one, but cheers anyhow Tobias :)


    Previous Comments:
    ------------------------------------------------------------------------

    [2009-04-20 10:53:13] showmaster

    tried it again by using PHP 5.2.8 today and the installation works
    fine. unexpectedly the new installation updated the old one, but that's
    ok.

    ------------------------------------------------------------------------

    [2009-04-20 09:07:54] doconnor

    -Status: Open
    +Status: Feedback

    Thank you for taking the time to report a problem with the package.
    Unfortunately you are not using a current version of the package --
    the problem might already be fixed. Please download a new
    version from http://pear.php.net/packages.php

    If you are able to reproduce the bug with one of the latest
    versions, please change the package version on this bug report
    to the version you tested and change the status back to "Open".
    Again, thank you for your continued support of PEAR.

    Works for me?


    C:\vx\tests\unit\ordering>pear install structures_graph
    Ignoring installed package pear/structures_graph
    Nothing to install

    C:\vx\tests\unit\ordering>pear install -f structures_graph
    WARNING: channel "pear.php.net" has updated its protocols, use
    "channel-update pear.php.net" to update
    downloading Structures_Graph-1.0.2.tgz ...
    Starting to download Structures_Graph-1.0.2.tgz (30,947 bytes)
    .........done: 30,947 bytes
    install ok: channel://pear.php.net/Structures_Graph-1.0.2

    C:\vx\tests\unit\ordering>

    ------------------------------------------------------------------------

    [2009-04-19 23:40:25] showmaster

    Description:
    ------------
    PEAR installer stops installing package with the following error:

    XML Error: 'not well-formed (invalid token)' on line '10'

    seems to be a bad character in package.xml

    Test script:
    ---------------
    start a fresh installation of pear (finishes with warning)
    try to install package with: pear install Structures_Graph

    Expected result:
    ----------------
    successfully installing package

    Actual result:
    --------------
    PEAR installer stops installing package with the following error:
    XML Error: 'not well-formed (invalid token)' on line '10'

    ------------------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppear-bugs @
categoriesphp
postedApr 20, '09 at 7:08a
activeApr 20, '09 at 1:35p
posts2
users1
websitepear.php.net

1 user in discussion

Daniel Oconnor: 2 posts

People

Translate

site design / logo © 2021 Grokbase